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Origin of the programs 
The GWB package was originally developed at the Department of Geology of the University 
of Illinois at Urbana-Champaign over a period of more than twenty years, under the 
sponsorship of a consortium of companies and government laboratories. The members of 
the consortium, past and present, include: 

Amoco Production Company 
Arco Oil and Gas Company 
Chevron Petroleum Technology Corporation 
ConocoPhillips Company 
ExxonMobil Upstream Research Company 
Hewlett Packard, Incorporated 
Idaho National Engineering Lab 
Japan National Oil Corporation 
Lawrence Livermore National Laboratory 
Marathon Oil Company 
Mobil Research and Development Corporation 
Sandia National Laboratories 
SCKCEN (Belgian nuclear authority) 
Silicon Graphics Computer Systems 
Texaco, Incorporated 
Union Oil Company of California 
United States Geological Survey 
 
The original GWB package was written by Craig Bethke with the assistance of Ming-Kuo 

Lee and Jeffrey Biesiadecki of the Hydrogeology Program in the Department of Geology, 
University of Illinois at Urbana-Champaign. The GWB is currently developed and 
supported by Aqueous Solutions LLC, located in Champaign, Illinois. 

A number of programmers in the Hydrogeology Program, including Rick Hedin, Peter 
Berger, Tren Haselton, Ester Soriano, David Solt, and Lalita Kalita helped develop the user 
interface. Brian Healy and Walter Kreiling developed a library used by the programs to 
produce graphical images on various output devices, and David Solt, Tren Haselton, 
Changlin Huang, Ester Soriano, Xiang Zhao, and Kevin Gorczowski have updated and 
eventually replaced this library over the years. J.K. Bohlke, Eric Daniels, and MingKuo 

Lee compiled the dataset of isotope fractionation factors; Daniel Saalfeld helped 
translate thermodynamic datasets to the GWB format; Amy Berger helped develop the 
surface complexation model; Qusheng Jin helped implement the redox kinetics and 
microbiological features; and Jungho Park created the GWBSymbol font and helped 
develop React’s ability to use custom rate laws. Peter Berger, Rick Hedin, Phil Parker, Dan 
Saalfeld, and Sharon Yeakel developed the active graphics facilities and other features of 
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release 7.0; Sharon Yeakel helped prepare documentation for the release. Phil Parker 
worked on developing the multithreaded versions of X1t and X2t for release 8.0, and Dan 
Saalfeld, Sharon Yeakel, and Jesse Luehrs developed program GSS and other features of 
the release. Dan Saalfeld, Sharon Yeakel, and Jesse Luehrs, with the assistance of Brian 
Farrell, developed release 9.0. 

Dan Saalfeld, Sharon Yeakel, Brian Farrell, Bryan Plummer, Steven Canning and Craig 
Bethke developed release 10.0. Dan Saalfeld, Sharon Yeakel, Yusheng Hou, Oscar Garcia, 
Brian Farrell, Katelyn Zatwarnicki, Shelley Goel, Peter Berger and Craig Bethke developed 
the GWB 11 release. Brian Farrell, Yusheng Hou, Daniel Saalfeld, Melika Sharifironizi and 
Craig Bethke developed GWB12. Brian Farrell, Melika Sharifironizi, Jia Wang, Taha Anwar, 
Daniel Saalfeld, Yusheng Hou, and Craig Bethke developed subsequent versions of the 
software, which have been released continuously as a subscription service. 

The software authors appreciate the assistance of more people than we can remember 
who over the years helped with software development and testing. These people include 
Theresa Beckman, Bill Bourcier, Pat Brady, Tenhung Chu, David Finkelstein, Ted Flynn, 
Annette Fugl, Oscar Garcia Cabrejo, Man Jae Kwon, Matt Kyrias, Kurt Larson, Meng Lei, 
Melinda Legg, Gordon Madise, Chuck Norris, Hernán Quinodoz, Derik Strattan, and 
Melinda Tidrick. We also thank the many students and users who have suggested 
improvements to the codes and documentation. 
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Introduction 

The Geochemist’s Workbench is a set of software tools for manipulating chemical 
reactions, calculating stability diagrams and the equilibrium states of natural waters, 
tracing reaction processes, modeling reactive transport, plotting the results of these 
calculations, and storing the related data. The Workbench, designed for personal 
computers running MS Windows, is distributed in four packages: 

 GWB Essentials contains tools for balancing reactions, calculating activity 
diagrams, computing speciation in aqueous solutions, plotting the results of 
these calculations, and storing the related data. 

 GWB Standard contains the tools included in GWB Essentials, as well as a 
program for modeling reaction processes. 

 GWB Professional includes all the programs in the Standard release, plus 
programs for modeling reactive transport in one and two dimensions, and for 
plotting modeling results. The package also includes programs for constructing 
phase diagrams. Finally, the package includes the ChemPlugin self-linking 
software object. 

 GWB Advanced Professional extends the package to include MPI versions of 
the reactive transport models for use on computing clusters, the ChemPlugin 
self-linking software object adapted for cluster computers, and other 
specialized codes. 

The GWB Essentials release consists of seven programs: 
 GSS stores analyte and sample data in a spreadsheet specially developed to 

work with the GWB set of software tools. 
 Rxn automatically balances chemical reactions, calculates equilibrium 

constants and equations, and solves for the temperatures at which reactions 
are in equilibrium. 

 Act2 calculates and plots stability diagrams on activity and fugacity axes. It can 
also project the traces of reaction paths calculated using the React program. 

 Tact calculates and plots temperature-activity and temperature-fugacity 
diagrams and projects the traces of reaction paths. 

 SpecE8 calculates species distributions in aqueous solutions, the saturation 
state of minerals and solid solutions, and the fugacity and partial pressure of 
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gases. SpecE8 can account for sorption of species onto mineral surfaces 
according to a variety of methods, including surface complexation and ion 
exchange. SpecE8 can additionally figure the fractionation of stable isotopes. 

 Gtplot graphs SpecE8 results and GSS datasets, including on xy plots, ternary, 
Piper, Durov, and Stiff diagrams. 

 TEdit displays, modifies, and creates the thermodynamic and surface reaction 
datasets used by the various GWB applications. 

The GWB Standard release also includes the program: 
 React, in addition to having the capabilities of SpecE8, traces reaction paths 

involving fluids, minerals, solid solutions, and gases. React can also predict the 
fractionation of stable isotopes during reaction processes. The simulation 
results can be rendered with Gtplot. 

The GWB Professional release contains the additional programs: 
 Phase2 is an extension of React used to calculate phase diagrams. 
 P2plot draws the phase diagrams calculated by Phase2.  
 X1t simulates reactive transport in one-dimensional systems. The program has 

all of React’s geochemical modeling capabilities coupled with groundwater 
flow and transport. 

 X2t simulates reactive transport in two-dimensional systems. 
 Xtplot plots in map view and as xy plots the results of reactive transport 

simulations made using X1t and X2t. 
 ChemPlugin is a self-linking software object for building reactive transport 

models in any configuration, and for repurposing flow models as reactive 
transport simulators. 

GWB Advanced Professional adds: 
 cX1t and cX2t, parallel processing versions of X1t and X2t for use on computing 

clusters. 
 ChemPlugin_MPI, a cluster computing version of ChemPlugin. 
 Other specialized software; contact the developers for current information. 

Each of the programs operates in a similar fashion, so once you learn to use one, you 
will find the others easy to work with. 
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1.1 GWB documentation 
Depending on the package, the GWB comes with a set of User’s Guides accessible as pdf 
files from the Help pulldown of any of the programs, and also available in printed form: 

 GWB Essentials Guide—A guide to GSS, Rxn, Act2, Tact, SpecE8, Gtplot, and 
TEdit (this document). 

 Reaction Modeling Guide—Information on reaction modeling using React, and 
using Gtplot to render simulation results, along with information on using 
Phase2 and P2plot to construct phase diagrams. 

 Reactive Transport Modeling Guide—A guide to reactive transport modeling 
with X1t, X2t, and Xtplot. 

 Command Reference—A comprehensive guide to commands for the GWB 
programs. 

 Reference Manual—A guide to the format of the thermodynamic datasets, the 
report command, the plug-in feature, graphics output, and so on. 

 ChemPlugin™ User’s Guide—A tutorial and reference for using the self-linking 
software object. 

A considerable amount of information, including a large number of fully worked 
examples, is available in Geochemical and Biogeochemical Reaction Modeling by Craig M. 
Bethke, available from Cambridge University Press. 

1.2 Online tutorials 
The GWB website—www.gwb.com—contains a variety of step-by-step tutorials showing 
how to use the GWB software package. The website also contains a large number of 
diagrams and movies showing the results of GWB calculations. By clicking the icons next 
to each case, you can download the input scripts used to configure the calculation, or 
start the appropriate GWB application, configured and ready to run. 

The GWB YouTube channel—www.youtube.com/user/GeochemistsWorkbench—
contains a number of instructional video clips that will quickly and efficiently help you 
become expert in using the software. 
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1.3 GWB dashboard 
The GWB dashboard is the platform from which you run the GWB programs, access 
documentation, find online video tutorials, activate and configure the software, and 
upgrade your software installation. 

Start the GWB dashboard from the Start button on your Windows desktop. Select The 
Geochemist’s Workbench 17 in the menu, which brings up the GWB dashboard. The 
dashboard looks like: 

  

Take a moment to explore each of the tabs along the top of the window. 
You can launch the various GWB programs from the Apps pane. On the ChemPlugin 

pane you can find information on and examples of applying the self-linking software 
object. The Docs pane takes you to options for printed documentation. You can configure 
the software on the Settings pane, and the Support pane provides tools to activate the 
software and obtain user support. The Subscription pane shows options for upgrading or 
renewing your software license. You can start the individual GWB programs in any of 
several ways: click on the program’s icon in the Apps pane, open (e.g., double-click on) a 
GWB input file from Windows, or simply drag an input file into the GWB dashboard. 
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1.4 GWB modeling programs 
When Rxn, Act2, Tact, SpecE8, React, Phase2, X1t, and X2t start, they appear as a window 
containing several panes and a menubar. Rxn’s window, for example, is shown here. 

 

The window contains three panes: 
 The Basis pane, where you can set the most important calculation constraints, 

as described below. 
 The Command pane, where you can type Rxn commands. 
 The Results pane, where you view calculation results. 

You can detach each pane by dragging the pane title to the desktop with the left mouse 
button. In this way you can arrange and size the panes individually. The window also 
contains a menubar, from which you can select a number of options and display a variety 
of dialog boxes. 

When Rxn, Act2, Tact, SpecE8, React, Phase2, X1t, and X2t start, they assume the 
working directory from the previous run. The programs write output into this directory 
and look there for input files. You can change the working directory at any time by 
selecting File → Working Directory (Ctrl+Shift+W); the current setting is displayed on the 
window frame. 

Once you have configured a calculation, you generate the calculation results by 
selecting Run → Go or, on the Results output pane, pressing the Run button (or in Act2 
and Tact, the Update Plot button). Once you have viewed the calculation results, you can 
move to another pane or select options from the menubar to modify the program’s 
configuration. 
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Gtplot contains a graphics area and a menubar, but there are no panes to select (as 
shown below). You configure this program using the mouse (or keyboard shortcuts) to 
select options from the menubar, or by left-clicking, right-clicking, or double-clicking on 
aspects of the plot displayed. 

 

1.5 To GUI or not to GUI 
Some people like to work interactively with a GUI (a GUI is a Graphic User Interface, or 
“gooey”), whereas others prefer to type commands from the keyboard. In Rxn, Act2, Tact, 
SpecE8, React, Phase2, X1t, and X2t, you can work either way, or switch freely from one 
to the other. 

To enter commands, select the Command pane and type your input at the prompt, as 
shown here. 

 



   Introduction   9 

 
 

Alternatively, each GWB command has a GUI counterpart, which you invoke on a different 
pane, or by selecting an option or dialog from the program’s menubar. 

You can quickly find the GUI equivalents to each command by exploring the program, 
or by consulting the GWB Command Reference. Example calculations in this Guide are 
most commonly shown as sequences of commands, because the commands can be listed 
concisely. You can work the examples following either the command listings or their GUI 
equivalents. 

1.6 Saving and reading input files 
You can save the current settings in Rxn, Act2, Tact, SpecE8, and TEdit for later use. To do 
so, select File → Save As… (Ctrl+S). Or typing 

 

within Act2, for example, writes the program’s current configuration into a dataset 
“My_file.ac2”. 

Saved datasets contain input commands that can be read later by the program. Select 
an input dataset using the File → Open → Read script… dialog, or by typing 

 

Alternatively, simply open the file. A list of the most recently opened files can be accessed 
with File → Recent Files. The number of files in the list can be set in File → Preferences….  

The following filename extensions are defined under Windows for the GWB programs: 
.gss GSS .sp8 SpecE8 .p2p P2plot .tdat Thermo data 
.rxn Rxn .gtp Gtplot .x1t X1t .sdat Surface data 
.ac2 Act2 .rea React .x2t X2t   
.tac Tact .ph2 Phase2 .xtp Xtplot   

Double-clicking on “My_file.ac2”, for example, launches Act2 and executes the commands 
in the file. 

When you exit Rxn, Act2, Tact, SpecE8, and GSS, they automatically save their current 
configurations to files such as “rxn_resume.rxn” and “act2_resume.ac2” in your profile 
directory (found by typing %appdata% in the File Explorer Address bar, e.g., 
“c:\Documents and Settings\jones\Application Data\GWB”). Upon reentering the 
programs, you can restore the previous configuration by choosing File → Resume, or 
typing 

 

save My_file.ac2 

read My_file.ac2 

resume 
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from the command line. Set the File → Resume On Startup option if each time you start 
one of the programs you would like to resume your previous session automatically. 

Gtplot automatically saves the previous plot configuration in a dataset named 
“gtplot_conf.gtc” when you exit the program with the File → Quit option (Ctrl+Q). When 
you restart in the same working directory, or when you open a “.gtc” file, the program 
configuration is restored. You can reset the configuration by choosing File → Reset 
configuration (Ctrl+R) or use the File → Save As… option (Ctrl+S) to save different 
configuration files in the same directory (see Using Gtplot). 

1.7 Drag and drop feature 
The drag and drop feature is a convenient way to transfer data within or between GWB 
programs, or between GWB programs and any other application that supports it. 

Drag an input file from your Desktop or File Explorer into the GWB dashboard or any 
GWB application, and the input will be automatically loaded. For example, you could drag 
a script file (.sp8) or thermo data file (.tdat) into SpecE8, or drag a configuration file (.gtc) 
into Gtplot. 

Left-click, drag onto a GWB app, and release: 
 Input scripts and files 
 Thermo and surface reaction datasets 
 Conductivity, isotope fractionation, and water standards data 
 Plot configuration files 
 Scatter data and reaction traces 

You can drag chemical data directly from your spreadsheet or table into any GWB 
program. Drag data to the Basis pane of SpecE8 or React to analyze an individual sample, 
to one of the panes in X1t or X2t to constrain the initial, inlet, or injection fluids, or into 
GSS to transfer your data. 

In GSS, right-click on an individual cell or on the sample header (to select an entire 
sample) and drag. In MS Excel, MS Word, or MS PowerPoint, highlight the cell or column, 
left-click the frame surrounding it, and drag. Release the mouse button over the selected 
input pane in the GWB program. 

If dragging into GSS, bring the pointer to a sample header to fill that sample (as shown 
below), or to the  button to add new samples. 
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Right-click and drag samples: 
 from one GSS data sheet to another. 
 from GSS into Basis, Initial panes. 
 from GSS into MS Excel. 

Left-click and drag: 
 samples from MS Excel into GSS. 
 samples from MS Excel into Basis, Initial panes. 
 in GSS to rearrange samples or analytes. 

Right-click and drag any pane title to transfer data within a GWB program, from one 
GWB program to another, or to another application. 

In React, in order to “pick up” the results of a calculation and use these results as the 
starting point for a new calculation, right-click the Results pane title and drag it onto the 
Basis pane. 

Calculation output can be copied from the Results pane to any other application in the 
same way. Dragging the Results pane will copy and paste the last step components in the 
fluid. 

Right-click on a dialog title bar and drag to copy the settings of the dialog box from one 
GWB application to another. For example, if in SpecE8 you have the Alter Log Ks dialog all 
set up and filled with the values you would like to use in React, right-click the Alter Log Ks 
dialog title bar and drag it into React. The destination dialog box does not need to be 
open at the time. 

Right-click and drag panes and dialogs to transfer: 
 data from one instance of React, for example, to another. 
 data from one GWB program to another. 
 in React, calculation results from the Results pane to the Basis pane. 
 calculation results into GSS. 
 Basis, Initial pane values into GSS. 
 data into MS Excel, MS Word, or MS PowerPoint. 
 text into WordPad to see what the drag/drop actual text is. 
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You can rearrange the order of the panes by left-clicking and dragging the pane titles. 
You may also detach each pane by left-clicking on the pane title and dragging it to the 
desktop. In this way, you can arrange and size the panes individually to view and work 
with several panes at the same time. For example, you can type commands in the 
Command pane and immediately see the effect on the Basis, Results, and Plot panes. Re-
attach panes with their close buttons. View → Reset Windows resizes, re-attaches, and 
reorders all of the panes to the default configuration. 

You can drag data tables, elements, any type of species, or virial coefficients from one 
thermo or surface dataset open in TEdit to another. Left-click an entry on the tree 
structure of the source dataset, drag it to the tree structure or current entry of the target 
dataset, and release. If the source and target datasets are open in the same TEdit window, 
you can switch to the target dataset by hovering over its tab while dragging. 

Left-click and drag panes: 
 to rearrange the order of the panes. 
 to detach panes and arrange them on the desktop. 

Re-attach panes with their close buttons or View → Reset Windows (Alt+S). 
The User’s Guides provide many examples of how to configure the programs, how to 

use the various commands, and how to create input scripts. You can highlight any of these 
examples in the pdf files, left-click within the selected text, drag with the left mouse, and 
drop into a GWB program. The commands will be automatically executed in order. Open 
the Run → History… dialog box to review them, or type history in the Command pane. 
You might also create an input script by dropping the selected text into an application 
such as WordPad and saving the file as a plain text document with the appropriate 
extension (.sp8, .rea, etc.). 

*Note: If you are having trouble with Adobe Reader X drag and drop, go to Edit → 
Preferences → Categories → General and uncheck “Enable Protected Mode at startup”. 

Left-click and drag from the pdf User’s Guides: 
 command examples to the GWB programs or other applications. 
 script examples to the GWB programs or other applications. 

If you have a spreadsheet that contains the results of a large number of analyses, an 
alternative to drag and drop is to prepare a short script that performs the operations 
automatically, reading the analyses one at a time and adding the calculation results to the 
spreadsheet. For details of this process and a fully worked example, refer to the Multiple 
Analyses chapter of the GWB Reference Manual. 
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1.8 Helpful features 
The command line interface for the Command pane in Rxn, Act2, Tact, SpecE8, React, 
Phase2, X1t, and X2t includes a number of helpful features: 

 Spelling completion. When you type commands in the Command pane, the 
programs automatically complete the spelling of a mineral, chemical, or 
command name (given enough characters to identify the name uniquely)—just 
press the [tab] key. When the program cannot identify a unique name, it will 
cycle through the possible completions with subsequent [tab] key presses. You 
can also show all names beginning with a combination of characters by pressing 
Ctrl+D. 

 Command history. The programs maintain a list of previously executed 
commands, which can be retrieved, modified, and re-executed. Type history 
or select Run → History… to view the history list. 

 Special characters. A group of control characters is provided on the Command 
pane for purposes such as spelling completion and input correction. 

 Startup files. Users can establish files in their profile directories containing 
commands for Rxn, Act2, Tact, SpecE8, React, Phase2, X1t, and X2t to execute 
at startup. These files should be named with the app name and _startup (e.g., 
act2_startup.ac2) and placed in your profile directory (found by typing 
%appdata% in the File Explorer Address bar, e.g., “C:\Documents and 
Settings\jones\Application Data\GWB”). 

 Calculator. The interface will automatically evaluate any numerical expression 
typed in the Command pane. This feature facilitates, for example, conversion of 
numbers to logarithms, or vice versa. 

 Online documentation. The GWB User’s Guides are available in pdf format 
online from any of the GWB programs. Select Help on the menubar to access 
them. 

These features are described fully in the User Interface chapter of the GWB Reference 
Manual. 

1.9 Exporting results 
Programs Act2, Tact, Gtplot, P2plot, and Xtplot make it convenient to use the plots you 
create in articles, reports, presentations, and databases. You can copy the current plot to 
the clipboard and then paste it into a variety of applications, in a format meaningful to the 
application. 

To copy a plot, use Edit → Copy (Ctrl+C). If you paste the plot into MS PowerPoint, it 
will appear as an EMF (an MS Enhanced Metafile) graphic object. Pasting into Adobe 
Illustrator places a native AI graphic. 
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If you paste a plot from Gtplot, P2plot, or Xtplot into MS Excel or a text editor such as 
Notepad or MS Word, the numerical values of the data points that make up the lines on 
the plot will appear in spreadsheet format (as shown below). 

 

In MS Word or MS Excel, use Paste Special… to paste the plot as a picture instead. 

 

You can control the format in which the plot is copied to the clipboard by selecting Edit 
→ Copy As. You can choose to copy the plot as an AI object, an EMF object, or a bitmap, or 

“Paste” in Excel or Word 
inserts numerical values 

“Paste Special…” in 
Excel or Word 

inserts a picture 
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the data points in the plot as tab delimited or space delimited text. Use the tab delimited 
option to paste the data into a spreadsheet program like MS Excel. For examining the data 
in a text file created with an editor like Notepad or MS Word, the space delimited option 
writes a nicely aligned table. 

When importing AI graphics to Adobe Illustrator, the program may prompt you to 
update the legacy text before you can edit the file. In this case, choose “Update”. You need 
to release the clipping mask before you attempt to edit individual elements of the plot. 
Use the “Ungroup” and “Group” functions when repositioning or modifying elements. 

The programs can save plots to files in various formats by selecting File → Save 
Image… from the menubar. The Graphics Output section of the GWB Reference Manual 
summarizes the options available for saving and using graphical output. 

1.10 Automatic plot updates 
The software is designed so that whenever SpecE8, React, Phase2, X1t, or X2t completes 
a simulation, any instances of Act2, Tact, Gtplot, P2plot, or Xtplot that are displaying the 
results of that simulation will update their plots automatically. Similarly, whenever a GSS 
spreadsheet is updated, any app plotting that data directly or as scatter data will sync 
automatically, unless automatic updates have been disabled in GSS.  

1.11 Further reading 
This guide is intended as an introduction to using the programs in The Geochemist’s 
Workbench Essentials package, and as a reference for the software package. For 
information about geochemical modeling in general, including a number of examples of 
how the software can be applied, please refer to the text Geochemical and 
Biogeochemical Reaction Modeling by Craig M. Bethke, available from Cambridge 
University Press. The Further Reading chapter in this guide gives literature references to 
this text and a number of other sources that provide starting points for further reading. 

1.12 User resources 
The GWB website holds a set of visual tutorials that show how to use the GWB apps to 
solve a range of problems in geochemistry. Browse the GWB YouTube channel for a series 
of narrated video clips showing the GWB in action. 

The GWB website also contains galleries of diagrams and movies, along with the input 
files used to compute them. Finally, the GWB Online Academy is a self-guided course in 
geochemical and reactive transport modeling that takes you from beginner to expert. 

Gwb_users is an independent group of users who share comments and results and 
answer questions of general interest over the Internet. The group maintains an online 
forum that serves as a bulletin board for posting announcements, bug notices, and other 
current information about the software. 

http://www.gwb.com/
http://www.gwb.com/tutorials.php
https://www.youtube.com/user/GeochemistsWorkbench
http://www.gwb.com/diagrams.php
http://www.gwb.com/movies.php
http://academy.gwb.com/
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To subscribe to the forum (there is no charge), unsubscribe, or post a message, select 
GWB Users’ Group from the GWB dashboard or the Help pulldown in any of the GWB 
programs. Alternatively, you can visit the group’s home page at forum.gwb.com. 

http://forum.gwb.com/
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Configuring the Programs 

2.1 Configuring a calculation 
Rxn, Act2, Tact, and SpecE8 all work in the same manner. Each program maintains a set 
of species, known as the basis, with which it writes reactions. Initially, the basis is the set 
of aqueous species that appears at the beginning of the thermodynamic database (see 
Table 2.1). This set is known as the “original basis.” 

You can alter the basis to reflect the geochemical constraints that you wish to impose 
in your calculation by substituting (“swapping”) another aqueous species, mineral, solid 
solution end member, or gas for an entry in the original basis. To specify equilibrium with 
quartz, for example, you swap quartz for the basis species SiO2(aq). Or, to set the CO2 
fugacity of your geochemical system, you swap CO2(g) for either the HCO3

–  or H+ basis 
entries. Examples in Chapters 4–7 illustrate the basis swapping technique. 

To perform a calculation, follow these steps: 
1. Set the basis. First, add or swap the aqueous species, minerals, solid solution end 

members, or gases you wish to use to constrain your calculation into the basis. 
The basis should contain any species at known activity, such as H+ if the pH is 
known, minerals or end members co-existing with the system, or gases at known 
fugacity or partial pressure. If you are calculating a stability diagram, the basis 
also includes the species to appear on the diagram axes. 

2. Constrain the basis. Next, specify the temperature for the calculation and assign a 
value (“constraint”) for total concentration, mineral or end member mass, activity, 
fugacity, or partial pressure for each entry in the basis. 

3. Go. Select Run → Go to initiate the calculation, which might be letting the program 
balance a reaction, calculate and display a diagram, or trace a reaction path. 

4. Revise. When the calculation is completed, you can adjust the basis by adding 
new components or varying your constraints; then, recalculate the model. You can 
continue to revise and recalculate until you decide to quit. 
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Table 2.1 Basis species in the LLNL thermodynamic database, “thermo.tdat” 

H20 Water Li+ Lithium 

Ag+ Silver Mg++ Magnesium 

Al+++ Aluminum Mn++ Manganese 

Am+++ Americium NO3– Nitrogen 

As(OH)4– Arsenic Na+ Sodium 

Au+ Gold Ni++ Nickel 

B(OH)3 Boron Np++++ Neptunium 

Ba++ Barium O2(aq) Oxygen 

Br– Bromine Pb++ Lead 

Ca++ Calcium PuO2++ Plutonium 

HCO3– Carbon Ra++ Radium 

Cs+ Cesium Rb+ Rubidium 

Cl– Chlorine Ru+++ Ruthenium 

Co++ Cobalt SeO3– – Selenium 

Cr+++ Chromium SiO2(aq) Silicon 

Cu+ Copper Sr++ Strontium 

Eu+++ Europium SO4– – Sulfur 

F- Fluorine TcO4– Technetium 

H+ Hydrogen Th++++ Thorium 

HPO4– – Phosphorus Sn++++ Tin 

Hg++ Mercury U++++ Uranium 

I– Iodine V+++ Vanadium 

Fe++ Iron Zn++ Zinc 

K+ Potassium   

2.2 Setting and constraining the basis 
You set the basis by adding the appropriate entries for the original basis list (Table 2.1) to 
the calculation. Then, if necessary, you swap another species, mineral, end member, or 
gas for the original basis entry. If you prefer to type your input, you use the add and swap 
commands. 
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To configure the basis with the GUI, move to the Basis pane. You will see a list of 
current basis entries. Click the  button (Ctrl+N) to add an entry to the basis. A menu 
of available entries appears. Navigate the menu with the mouse, the up and down arrow 
keys, or by typing the entry’s first letter(s). To swap, click on the entry’s  button, and 
select an aqueous species, mineral, end member, or gas to swap into the basis. 

Once you have created a list of basis entries (e.g., as shown in Table 2.1), you can 
manipulate it in several ways. You constrain an entry by choosing a unit (e.g., the activity 
of a species or fugacity of a gas) and setting a value in the corresponding box. 

You can change the order of the entries by simply dragging them. To delete a basis 
entry, or several, select the entire entry and press the Delete key or the  button. To 
configure another invocation of the program with these entries, right-click on the pane 
title, drag it, and release (see Drag and drop). 

2.3 Thermodynamic datasets 
The programs work from any of the thermodynamic databases installed with the software, 
as well as those sourced elsewhere. Each database contains the properties of aqueous 
species, minerals, solid solutions, and gases; equilibrium constants for reactions among 
species; and data required to calculate activity coefficients and fugacity coefficients. In 
many cases, the data span the temperature range 0°C–300°C, at one atm pressure below 
100°C, and along the vapor pressure of water at higher temperatures, but the temperature 
range and pressure profile are set at the discretion of the database author. 

You can view, edit, and even create your own thermo datasets in the TEdit graphical 
editor (see Using TEdit). You can alternatively alter datasets using a text editor such as 
Notepad, but TEdit shows the database structure at a glance and provides significant 
verification and troubleshooting capabilities. The Thermo Datasets chapter in the GWB 
Reference Manual gives details of the database format. 

The default dataset, named “thermo.tdat”, supports activity coefficients calculated 
according to an extended form of the Debye-Hückel equation (the “Bdot” equation; see 
Activity coefficients under Using SpecE8). The database was compiled by Thomas 
Wolery, Joan Delany, Ken Jackson, James Johnson, and other members of the 
geochemical modeling group at Lawrence Livermore National Laboratories (LLNL). The 
dataset is based in large part on the SUPCRT data compilation (see references in the 
Further Reading section). 

The GWB is distributed with a number of other thermodynamic databases. Dataset 
“thermo.com.V8.R6+.tdat” is the “combined” LLNL dataset, version 8, release 6, in which 
the redox coupling among organic species has been modified somewhat. You may prefer 
to use this dataset if you are working extensively with systems containing organic species. 

Dataset “thermo_cemdata.tdat” is the Cemdata18 thermodynamic database designed 
for modeling reactions in cements and concrete (see Further Reading), extended to 
include entries for phosphate and zeolite minerals from the Swiss Federal Laboratories for 
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Materials Science and Technology (Empa). The dataset uses a variation of the Debye-
Hückel model, as implemented in the PhreeqC program, described below and in Activity 
coefficients under Using SpecE8. The dataset includes definitions for several 
Guggenheim and ideal binary solid solutions. 

SpecE8, React, Phase2, X1t, and X2t can use virial methods to model the activities of 
electrolyte species in saline fluids. Such calculations require thermo datasets containing 
the virial coefficients. Dataset “thermo_hmw.tdat”, included with the software release, 
includes coefficients for the Harvie-Møller-Weare activity model, a formalism of the Pitzer 
equations (see Activity coefficients under Using SpecE8). There is no provision in this 
dataset for calculations at temperatures other than 25°C. 

Datasets “thermo_ymp.R2.tdat” and “THEREDA_2021_GWB.tdat” are the Yucca 
Mountain Project and THEREDA Project’s compilations, respectively, each of which also 
follows the Harvie-Møller-Weare formalism. The datasets contain more chemical 
components than “thermo_hmw.tdat”, and include provision for extrapolating the data 
for many of the components to temperatures other the 25°C. Before applying any Pitzer 
dataset at temperatures other than 25°C, you should study its documentation (see Further 
Reading) carefully. 

Datasets “thermo_frezchem.tdat” and “thermo_coldchem.tdat” carry the H-M-W 
method to temperatures well below the freezing point of pure water. The former file is 
based on data from the FREZCHEM program, as set out by Toner and Sletten; the latter is 
taken from Toner and Catling (see Further Reading).  

Datasets “thermo_sit.tdat” and “thermo_nea.tdat”, available from the ThermoChimie 
project and the Nuclear Energy Agency, respectively, include coefficients for the Specific 
ion Interaction Theory (SIT) activity model (see Activity coefficients under Using SpecE8). 

Several other datasets are provided with the GWB release for compatibility with other 
geochemical modeling software. Files “thermo_minteq.tdat”, “thermo_phreeqc.tdat”, 
“thermo_phrqpitz.tdat”, and “thermo_wateq4f.tdat” contain data from the MINTEQ, 
PHREEQC, PHRQPITZ, and WATEQ4F software packages, respectively, which can be 
downloaded from the Visual Minteq home page (MINTEQ) and the U.S. Geological Survey 
(PHREEQC, PHRQPITZ, and WATEQ4F). When the GWB programs load these datasets, they 
use the same method as the original program (MINTEQ, and so on) to calculate activity 
coefficients. 

The programs can compute fugacity coefficients for gases using the methods of 
Tsonopoulos, Peng and Robinson, and Spycher and Reed (see Further Reading). Datasets 
distributed with recent releases contain factors needed to calculate fugacity coefficients 
for certain gases by these methods, as functions of temperature and pressure. The 
programs assign ideal behavior to gases lacking the factors required by the method in use.  

Starting with GWB 2022, the programs can account for binary solid solutions. The apps 
can determine activity coefficients for the end members accounting for site-mixing, a 
Guggenheim model, or various other nonideal methods, or can assume ideal behavior. 
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Any number of solid solutions can be defined within a thermo dataset, by the user at run 
time, or both. 

The programs at startup look for a dataset named “thermo.tdat” by default, but you 
can specify an alternative on the File → Preferences… dialog. If you set the default file to 
“mythermo.tdat”, for example, the programs will read the file “mythermo.tdat” as the 
default thermo dataset. 

The programs, at startup, look for the thermodynamic dataset in your working 
directory and, failing to find it there, in the public “gtdata” directory (commonly, 
“\Program Files\GWB\Gtdata”). You may set an alternative default directory on the File → 
Preferences… dialog. 

To load a different thermodynamic database into an open program, go to the 
File → Open → Thermo Data… dialog, use the data command within the Command 
pane, or simply drag the database into the application window. 

2.4 Redox couples 
The thermodynamic dataset contains a number of redox coupling reactions that link 
species of differing oxidation states. There are redox couples between Fe++ and Fe+++, 
HS– and SO4

– – , CH4(aq) and HCO3
– – , and so on. You can enable or disable coupling 

reactions interactively. In this way, you control the extent to which the programs honor 
redox equilibrium in their calculations. 

Each of the redox coupling reactions is identified by a redox species, which is a basis 
species in an alternative oxidation state (Table 2.2). In the examples in the previous 
paragraph, Fe+++, HS–, and CH4(aq) are the redox species; the corresponding basis 
species are Fe++, SO4

– – , and HCO3
– – . The programs, by default, honor each redox couple 

and hence assume redox equilibrium. You can disable any number of the couples, 
however, by selecting Config → Redox Couples…, or invoking the decouple command. 

Once a redox couple has been disabled, the redox species in question becomes an 
entry in the basis list and can be constrained independently of the other basis entries. In 
an equilibrium calculation, for example, you need only constrain the basis entry Fe++ and 
the oxidation state to consider ferrous and ferric iron species. By disabling the redox 
couple between Fe+++ and Fe++, however, ferric and ferrous iron are treated separately. 
You would need to further constrain Fe+++ to include ferric iron species in the calculation. 

Redox reactions in a thermo dataset are set out in a flexible fashion. Many datasets 
balance redox reactions in terms of the species O2(aq), but they can alternatively be 
written in terms of other species, such as O2(g), H2(aq), H2(g), or as half-cells in terms of e–.  
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Table 2.2 Oxidation states of redox and basis species (basis species in bold) in 
“thermo.tdat” 

–4 –3 –2 –1 0 +1 +2 

       

 AsH3(aq)      

     Au+  

CH4(aq)    CH3COO–   

   Cl–    

      Co++ 

      Cr++ 

     Cu+ Cu++ 

      Eu++ 

      Fe++ 

    H2(aq) H+  

     Hg2
++ Hg++ 

      Mn++ 

 NH4
+   N2(aq)   

       

       

      Ru++ 

  HS–     

  Se−−     

      Sn++ 
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+3 +4 +5 +6 +7 +8 

Am+++ Am++++ AmO2
+ AmO2

++   

As(OH)4
–  AsO4

–––    

Au+++      

 HCO3
–     

    ClO4
–  

Co+++      

Cr+++  CrO4
––– CrO4

––   

      

Eu+++      

Fe+++      

      

      

   MnO4
–– MnO4

–  

NO2
–  NO3

–    

Np+++ Np++++ NpO2
+ NpO2

++   

Pu+++ Pu++++ PuO2
+ PuO2

++   

Ru+++ Ru(OH)2
++  RuO4

–– RuO4
– RuO4 

   SO4
––   

 SeO3
––  SeO4

––   

 Sn++++     

Tc+++ TcO++ TcO4
––– TcO4

–– TcO4
–  

U+++ U++++ UO2
+ UO2

++   

V+++ VO++ VO4
–––    
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2.5 Solid solutions 
The GWB programs can account for binary solid solutions—minerals that vary in 
composition between two end members—taking the solutions to be either ideal or 
nonideal. The apps can further allow solid solutions to vary continuously or cast them as a 
sequence of discrete compositional tranches; Act2 and Tact, however, employ only the 
discrete method. 

In an ideal solution, the simplest case, the activity of a solution’s end member is equal 
to its mole fraction 𝑥𝑥. The activity of a pure mineral, then, is unity. In a nonideal solution, 
an end member’s activity is the product of its mole fraction 𝑥𝑥 and activity coefficient γ. 

One of several activity coefficient models can be invoked. In a Guggenheim model, for 
example, a Redlich-Kister-type expansion with up to three dimensionless Guggenheim 
parameters 𝑎𝑎0, 𝑎𝑎1, and 𝑎𝑎2 describes the excess free energy of mixing between end 
members 0 and 1: 
 ∆𝐺𝐺𝐸𝐸  = 𝑥𝑥0𝑥𝑥1RT [𝑎𝑎0 + 𝑎𝑎1(𝑥𝑥1 − 𝑥𝑥0) + 𝑎𝑎2(𝑥𝑥1 − 𝑥𝑥0)2] (2.1) 

 
Activity coefficients consistent with this expression are determined according to 
 ln 𝛾𝛾0 = 𝑥𝑥1

2 [𝑎𝑎0 − 𝑎𝑎1(3𝑥𝑥0 − 𝑥𝑥1) + 𝑎𝑎2(𝑥𝑥0 − 𝑥𝑥1)(5𝑥𝑥0 − 𝑥𝑥1)] (2.2) 
 
 ln 𝛾𝛾1 = 𝑥𝑥0

2 [𝑎𝑎0 + 𝑎𝑎1(3𝑥𝑥1 − 𝑥𝑥0) + 𝑎𝑎2(𝑥𝑥1 − 𝑥𝑥0)(5𝑥𝑥1 − 𝑥𝑥0)] (2.3) 

 
End member 0 appears first in the solution’s definition, followed by end member 1. When 
one end member contains only minor amounts of the other, the major component should 
be listed first. Otherwise, the end members can be specified in arbitrary order. 

The activity coefficient expressions are asymmetric with respect to end member order 
whenever 𝑎𝑎1 is nonzero. The order in which end members are defined affects the sign of 
the Guggenheim parameter 𝑎𝑎1 (but not 𝑎𝑎0 or 𝑎𝑎2). Reversing end member order, then, 
negates 𝑎𝑎1. In collecting Guggenheim coefficients from the literature, keep in mind that 
the convention set out in the equations above is inverted by some authors, requiring the 
sign of their 𝑎𝑎1 values to be reversed for use with the GWB. 

Expressed differently, the GWB apps expect a positive value for 𝑎𝑎1 to shift the excess 
free energy curve towards 𝑥𝑥1, the second end member. If a solid solution is not fully 
miscible, a positive value for 𝑎𝑎1 will further shift the miscibility gap in this direction. In 
drawing data from the literature, furthermore, take care to respect the stoichiometries 
assigned to end member minerals, as well as the minerals’ assumed stabilities.  

Any number of solid solutions can be defined within the thermodynamic database in 
use (see Solid solutions under Thermo Datasets in the GWB Reference Manual), 
configured by the user at run time, or both. A solid solution may be specified as ideal or 
nonideal and may be set as a continuous or discrete series. You define a solid solution at 
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run time using the Config → Solid Solutions… dialog or the solid_solution 
command. You can further change the properties of a solution set out in the thermo 
dataset using the same dialog, or with the alter command.  

To define a calcite-rhodochrosite solid solution, for example, go to Config → Solid 
Solutions…, click  under “Define new solid solutions”, and expand the  button. 
Supply a name such as “Cal-Rds” in the first box, choose end-member minerals “Calcite” 
and “Rhodochrosite” using the pulldown menus, and supply a tag such as “Cal” or “Rds” 
for each. To set a Guggenheim activity model, for example, change “type” from “ideal” to 
“guggenheim” and enter appropriate values for coefficients “a0” (“3” here), “a1” (“0.0), 
and “a2” (“0.0). 

  

Click Apply to create the solution. The command  

 

serves the same purpose. 
Rxn, SpecE8, React, Phase2, X1t, and X2t by default take solid solutions as continuous 

series. An end member is named following the syntax <solid_solution>::<end member 
tag>. Thus, the calcite end member of the calcite-rhodochrosite solution set out above is 
“Cal-Rds::Cal”. End members are swapped into the basis much like minerals, but in pairs 
(see Setting and constraining the basis under Configuring the Programs). 

 As solid solutions are read in, configured, and altered, the apps use the Guggenheim 
parameters to check each continuous solid solution for a miscibility gap. They first search 
for spinodal points, which, if found, indicate a partially immiscible solution. They proceed 
to solve for the binodal points—compositions spanning the miscibility gap—and append 
the resulting two binodes to the list of minerals carried in the calculation. A solid 

solid_solution Cal-Rds Calcite tag Cal contains \ 
  Rhodochrosite tag Rds guggenheim a0= 3 
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solution’s spinodals and binodals are reported in the Config → Show… dialog, or when 
you issue the explain command followed by the solution name.  

In discrete mode, the programs treat a solid solution as a series of fixed-composition 
minerals, or tranches. The programs generate tranches spanning the prescribed range in 
the mole fraction (from 0 to 1, by default) and spaced apart by the step specified (1/20th of 
the range, unless set otherwise). The tranches are named by combining end member tags 
and mole fractions, e.g., “Cal(.95)-Rds(.05)”, “Cal(.9)-Rds(.1)”, and so on. For solid 
solutions containing a trace of one end member, you might set a smaller range (e.g. from 0 
to 0.01) to more precisely model uptake of the minor end member. 

The apps calculate an equilibrium constant for each tranche from the end members’ 
equilibrium constants, mole fractions, and activity coefficients, according to 
 log K = 𝑥𝑥0(log 𝐾𝐾0 + log 𝛾𝛾0 + log 𝑥𝑥0) + 𝑥𝑥1(log 𝐾𝐾1 + log 𝛾𝛾1 + log 𝑥𝑥1)  (2.4) 

 
The tranches generated in this way are appended to the list of minerals taken from the 
thermo dataset. Each tranche is then treated in the calculations as if it were a simple 
mineral. Tranches can be directly swapped into the basis, suppressed, and so on. A 
tranche’s stability can be altered only indirectly, however, by adjusting the log Ks for the 
end member minerals. 

When a discrete solid solution has a miscibility gap, tranches within the gap become 
unstable relative to those outside it and so will not appear in the calculation results. 
Where the miscibility gap is large enough that each end member incorporates only a 
minor amount of the other, you may prefer to define solid solutions at opposite ends of 
the compositional range, thereby eliminating many superfluous tranches. For example, 
the aragonite-strontianite solid solution has a miscibility gap at 25°C from ~.0048 < xStr 
~.8579 (see Parkhurst and Appelo, 2013 in Further Reading). The solution might be 
configured with the commands 

 

Steps were set for neither solution, so default to 1/20th of the ranges specified.  
Other properties of end members and tranches reflect those of the simple minerals in 

question. Mole volumes are taken from the corresponding minerals, weighted in the case 
of tranches by end member mole fractions. In models that account for surface 
complexation (see Sorption onto mineral surfaces), site densities and specific surface 

solid_soln Sr-Aragonite Aragonite tag Arg contains \ 
  Strontianite tag Str from 0 to .0048 discrete \ 
  guggenheim a0= 3.43 a1= -1.82 
 
solid_soln Ca-Strontianite Strontianite tag Str contains \ 
  Aragonite tag Arg from 0 to .1421 discrete \ 
  guggenheim a0= 3.43 a1= 1.82 
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areas of end members are assumed to be equal to those of their corresponding minerals; 
again, the properties of tranches are weighted by end member content. 

In models that account for isotope fractionation (see Isotope fractionation datasets), 
you use the name of the corresponding simple mineral to segregate an end member or set 
its fractionation factor and isotopic composition. Fractionation factors for tranches are 
determined by averaging, as before. Alternatively, you can set out the polynomial 
expansion for an individual tranche in the isotope fractionation dataset.  

The following sections describe alternative solid solution activity models supported in 
the GWB programs. For more information on solid solutions, see Further Reading. 

2.5.1 Site-mixing model 
In a site-mixing model, an end member’s activity equals its mole fraction 𝑥𝑥 raised to the 
power of the site number b. Activity coefficients are calculated according to 
 ln 𝛾𝛾0 = (𝑏𝑏 − 1) ln 𝑥𝑥0 (2.5) 
 
 ln 𝛾𝛾1 = (𝑏𝑏 − 1) ln 𝑥𝑥1 (2.6) 

 
The site number reflects the stoichiometry of the exchange site in the end members. End 
members annite [KFe3AlSi3O10(OH)2] and phlogopite [KMg3AlSi3O10(OH)2], for example, 
might form a solid solution biotite [K(Fe,Mg)3AlSi3O10(OH)2] in which b equals 3. When b 
equals 1, the model is equivalent to an ideal solution.  

In the Solid Solutions… dialog, configure a site-mixing solution by choosing 
“site_mixing” for “type” and specifying the site number b. Or use commands like 

 

which serve the same purpose.  

2.5.2 Guggenheim model (expanded) 
As described above, you can set a Guggenheim model by defining parameters 𝑎𝑎0, 𝑎𝑎1, and 
𝑎𝑎2 directly. This is the simplest and most common method for configuring solutions of this 
type. Alternatively, you can allow activity coefficients to vary with temperature by setting 
Guggenheim parameters 𝐴𝐴0−𝐴𝐴2 in J/mol units, such that 𝐴𝐴0 =  𝑎𝑎0R𝑇𝑇𝐾𝐾, and so on, where R 
is the gas constant and 𝑇𝑇𝐾𝐾  is the temperature in Kelvins. In this case, you prescribe the 
J/mol parameters as a series of second-order temperature expansions  
 𝐴𝐴0 = 𝑝𝑝1 + 𝑝𝑝2𝑇𝑇𝐾𝐾 + 𝑝𝑝3𝑇𝑇𝐾𝐾

2 (2.7) 
 
 𝐴𝐴1 = 𝑝𝑝4 + 𝑝𝑝5𝑇𝑇𝐾𝐾 + 𝑝𝑝6𝑇𝑇𝐾𝐾

2 (2.8) 

solid_solution Biotite Annite tag Ann contains \ 
  Phlogopite tag Phl site_mixing b= 3 
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 𝐴𝐴2 = 𝑝𝑝7 + 𝑝𝑝8𝑇𝑇𝐾𝐾 + 𝑝𝑝9𝑇𝑇𝐾𝐾

2 (2.9) 

 
using a set of coefficients 𝑝𝑝1−𝑝𝑝9. (The option is not available when performing poly-
thermal simulations with X1t, X2t, or Phase2.) 

To configure a solution in this manner, use the Solid Solutions… dialog to select a 
Guggenheim solution as before, but instead of entering values for 𝑎𝑎0, 𝑎𝑎1, and 𝑎𝑎2 directly, 
click on the  button next to 𝑎𝑎0, then enter coefficients 𝑝𝑝1−𝑝𝑝9. Borrowing from the Sr-
Aragonite example from the previous section, we set expansions for 𝐴𝐴0 and 𝐴𝐴1 consistent 
with dimensionless Guggenheim coefficients 𝑎𝑎0 and 𝑎𝑎1 of 3.43 and −1.82, respectively, at 
25°C, and equivalent to values of 2.66 and −1.16 at 76°C 

   

Or use commands like 

 

which serve the same purpose. As is the case for 𝑎𝑎1, the sign of 𝑝𝑝4−𝑝𝑝6 are sensitive to end 
member order and convention.  

2.5.3 Regular solution model 
In the regular solution model, a single interaction coefficient 𝑊𝑊 (J/mol) is used to 
calculate activity coefficients 
 RT ln 𝛾𝛾0 = 𝑊𝑊𝑥𝑥1

2 (2.10) 
 
 RT ln 𝛾𝛾1 = 𝑊𝑊𝑥𝑥0

2 (2.11) 

solid_solution Sr-Aragonite Aragonite tag Arg contains \ 
  Strontianite tag Str guggenheim \ 
  p1= 13068.0 p2= -15.311 p3= 0.0 p4= -11201.0 p5= 22.435  
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The model is equivalent to the expanded Guggenheim model, truncated after the first 
interaction coefficient, but the coefficient 𝑊𝑊  
 𝑊𝑊 = 𝑝𝑝1 + 𝑝𝑝2𝑇𝑇𝐾𝐾 + 𝑝𝑝3𝑃𝑃 (2.12) 
has terms accounting for first-order temperature and pressure dependence, where 𝑃𝑃 is 
the pressure in bar. 

The GWB modeling programs, however, do not allow non-zero values for 𝑝𝑝3. In taking 
data from the literature, you should not simply omit such a term, if it exists. Instead, the 
product 𝑝𝑝3𝑃𝑃 can be folded into the value of 𝑝𝑝1 for isobaric calculations. When thermo.tdat 
is loaded, for example, at any temperature between 0 and 100°C the 𝑝𝑝1 coefficient can be 
set equal to 𝑝𝑝1 + 𝑝𝑝3 × 1.0134. The TEdit program, nonetheless, allows a value to be set 
for 𝑝𝑝3, since the app can serve to edit thermodynamic databases for the EQ3/6 package 
(see Exporting EQ3/6 datasets in the Using TEdit chapter of this guide). 

Within the Solid Solutions… dialog, configure a regular solution by choosing “regular” 
for “type” and specifying values for 𝑝𝑝1 and 𝑝𝑝2. Or use commands like 

 

which serve the same purpose. The example here is equivalent to a dimensionless 
Guggenheim coefficient 𝑎𝑎0 of 3 at 25°C, as configured in the opening section of this 
chapter, but decreases inversely with temperature. 

2.5.4 Cubic Maclaurin model 
In the cubic Maclaurin model, activity coefficients are calculated from interaction 
parameters 𝑊𝑊0 and 𝑊𝑊1 (J/mol) according to 
 RT ln 𝛾𝛾0 = (2𝑊𝑊1 − 𝑊𝑊0)𝑥𝑥1

2 + 2(𝑊𝑊0 − 𝑊𝑊1)𝑥𝑥1
3 (2.13) 

 
 RT ln 𝛾𝛾1 = (2𝑊𝑊0 − 𝑊𝑊1)𝑥𝑥1

2 + 2(𝑊𝑊1 − 𝑊𝑊0)𝑥𝑥1
3 (2.14) 

 
The interaction parameters are determined as first-order expansions in temperature (K) 
and pressure (bar) using coefficients 𝑝𝑝1−𝑝𝑝6 
 𝑊𝑊0 = 𝑝𝑝1 + 𝑝𝑝2𝑇𝑇𝐾𝐾 + 𝑝𝑝3𝑃𝑃 (2.15) 
 
 𝑊𝑊1 = 𝑝𝑝4 + 𝑝𝑝5𝑇𝑇𝐾𝐾 + 𝑝𝑝6𝑃𝑃 (2.16) 

 
As with the regular solution, the GWB modeling programs do not currently support 
nonzero values for the pressure terms. 

solid_solution Cal-Rds Calcite tag Cal contains \ 
  Rhodochrosite tag Rds regular p1= 7436.73 p2= 0.0 
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Within the Solid Solutions… dialog, configure a cubic Maclaurin model by choosing 
“cubic” for “type” and specifying values for 𝑝𝑝1−𝑝𝑝2 and 𝑝𝑝4−𝑝𝑝5. Or use commands like 

 

which serve the same purpose. Note, the activity coefficient expressions depend on the 
order in which end members are ordered. Reversing order, then, requires 𝑊𝑊0 and 𝑊𝑊1, and 
thus 𝑝𝑝1−𝑝𝑝3 and 𝑝𝑝4−𝑝𝑝6, to be switched. This configuration is equivalent to the expanded 
Guggenheim Sr-Aragonite example above.  

2.5.5 Third-order Maclaurin model 
In the third-order Maclaurin model, activity coefficients are calculated from interaction 
parameters 𝑊𝑊1 , 𝑊𝑊2, and 𝑊𝑊3 (J/mol) according to 

 RT ln 𝛾𝛾0 = [−(𝑊𝑊2 2⁄ )𝑥𝑥1
2 − (𝑊𝑊3 3⁄ )𝑥𝑥1

3] (2.17) 
 
 RT ln 𝛾𝛾1 = [−(𝑊𝑊2 + 𝑊𝑊3 2⁄ )𝑥𝑥0

2 + (𝑊𝑊3 3⁄ )𝑥𝑥0
3 + (𝑊𝑊1 + 𝑊𝑊2 2⁄ + 𝑊𝑊3 6⁄ )] (2.18) 

where 𝑊𝑊1 is actually recalculated according to 
 
 

𝑊𝑊1 = − 𝑊𝑊2 2⁄ − 𝑊𝑊3 6⁄  (2.19) 

The GWB modeling programs, however, do not currently support nonzero 𝑝𝑝3 values. The 
model, then, is currently equivalent to a regular solution, where 𝑊𝑊 = −𝑝𝑝2 2⁄ . 

Within the Solid Solutions… dialog, configure a third-order Maclaurin model by 
choosing “third_order” for “type” and specifying values for 𝑝𝑝1−𝑝𝑝2. Or use commands like  

 

which serve the same purpose. The activity model here is equivalent to the regular 
solution example above. 

2.6 Sorption onto mineral surfaces 
Rxn, SpecE8, React, Phase2, X1t, and X2t can account for the sorption of aqueous species 
onto mineral surfaces by a number of methods, including the two-layer surface 
complexation model (including the constant capacitance and constant potential models), 

solid_soln Sr-Aragonite Aragonite tag Arg contains \ 
  Strontianite tag Str cubic \ 
  p1= 1867.0 p2= 7.124 p3= 0.0 p4= 24269.0 p5= -37.746  

solid_solution Cal-Rds Calcite tag Cal contains \ 
 Rhodochrosite tag Rds third_order p1= 7436.73 p2= -14873.5 
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the triple-layer and CD-MUSIC models, ion exchange, distribution coefficients (Kd), 
Freundlich isotherms, and Langmuir isotherms. 

In each case, you supply a dataset of surface reactions. You can load into the GWB 
modeling programs more than one surface dataset and can mix datasets representing 
different methods in a single program run. TEdit provides a graphic interface for creating 
and modifying surface datasets or you can use a text editor. The Surface Datasets chapter 
in the GWB Reference Manual gives details of the database format for each method. 

2.6.1 Two-layer surface complexation model 
Rxn, SpecE8, React, Phase2, X1t, and X2t can account for surface complexation reactions 
by which species in solution sorb onto mineral surfaces. The programs employ the 
modified two-layer (or double-layer) model, as presented by Dzombak and Morel (see 
Further Reading). By this model, surface complexes form by reaction of aqueous species 
with sites on a mineral surface. 

Dataset “FeOH.sdat” contains reactions for hydrous ferric hydroxide (HFO), which 
sorbs strongly and plays a significant role in many oxidizing environments. Alternative 
datasets can be prepared in a parallel format for other sorbing minerals. The programs 
can consider several types of surfaces at a time. Each surface, furthermore, may occur on 
more than one mineral (e.g., a sorbing silica surface might be distributed across several 
zeolite minerals) and can contain a number of sorbing sites. 

The “FeOH.sdat” dataset considers two types of sites, labeled >(s)FeOH and >(w)FeOH. 
These sites represent, respectively, strong and weak sorbing positions on the surface. The 
dataset specifies that the sites occur on the surfaces of three minerals—hematite, Fe(OH)3 
precipitate, and goethite—and sets specific surface areas and site densities for each. 

The remainder of the dataset contains reactions describing the protonation, 
deprotonation, and complexation of surface sites. The reactions, each with a specified log 
K at 25°C, yield surface species such as >(w)FeOH2

+, >(w)FeO–, and >(w)FeOCa+ +. 
A second dataset supplied with the GWB, “FeOH+.sdat”, is identical to dataset 

“FeOH.sdat”, except it contains reactions from the Dzombak and Morel compilation for 
which log K values have been only estimated. A third dataset, “FeOH_minteq.sdat”, 
contains the surface complexation data from Visual Minteq release 2.20 for HFO.  

Datasets “Goethite.sdat” and “Gibbsite.sdat” are like the HFO compilation but 
represent sorption on goethite and gibbsite, respectively. As with the HFO datasets, 
additional versions “Goethite+.sdat” and “Gibbsite+.sdat” are expanded with estimated 
constants and “Goethite_minteq.sdat” and “Gibbsite_minteq.sdat” are expanded 
versions formatted for use with the Visual Minteq thermo dataset.  

When using multiple surface datasets in a calculation, you should take care to avoid 
redundancy. To use one of the HFO datasets with a goethite dataset, for example, you 
should comment out goethite’s sorbing sites in the former. 
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2.6.1.1 Constant capacitance model 
The constant capacitance is a special case of the two-layer surface complexation model, 
described above. In the two-layer model, the program calculates surface potential (ψ, in 
volts) from the electrical charge density (𝜎𝜎, in C/m2) on the sorbing surface according to 
the well-known result of Gouy and Chapman. The capacitance C of the surface is the ratio 
 
 C = σ/ψ (2.20) 
 
where C has units of F/m2. 

When treating systems of relatively high ionic strength or low surface charge, or both, 
the value of C may be taken as constant. This assumption simplifies the calculation since 
ψ can be calculated directly from 𝜎𝜎. You set a constant capacitance model in Rxn, SpecE8, 
React, Phase2, X1t, or X2t by loading a surface complexation dataset in the File → Open → 
Sorbing Surfaces… (or Config → Sorbing Surfaces…) dialog, setting a value for 
capacitance in F/m2, then hitting Apply 

 

or with the surface_capacitance command 

 

If you have loaded more than one dataset of surface reactions, you identify the surface 
in question with its “type”, as shown in the dataset header. For example, for dataset 
“FeOH.sdat”, you could enter 

 

surface_capacitance = 2 

surface_capacitance HFO = 2 
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To revert to the default relationship between surface charge and potential, enter 

 

In this case, the program reverts to the standard two-layer model. 
You may alternatively set a constant value for surface capacitance in the header of a 

surface complexation dataset. In this case, the value specified is carried unless the user 
modifies it with the surface_capacitance command. 

2.6.1.2 Constant potential model 
The constant potential model is a second special case of the two-layer surface 
complexation model. In the constant potential model, a single value of the surface 
potential is assigned, regardless of surface charge. Most commonly, the potential is set to 
0, which is equivalent to ignoring electrostatic effects on ion sorption. 

You set a constant potential model in Rxn, SpecE8, React, Phase2, X1t, or X2t in the 
File → Open → Sorbing Surfaces… (or Config → Sorbing Surfaces…) dialog 

 

or using the surface_potential command 

 

to set a value for electrical potential in mV. The command has the same format as the 
surface_capacitance command discussed above. You can also specify a constant 
value for potential in the header of a surface complexation dataset. Note that for a sorbing 
surface, you can set a constant capacitance or a constant potential model, but not both. 

surface_capacitance = ? 

surface_potential = 0 
surface_potential HFO = 0 
surface_potential = ? 
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2.6.2 Triple-layer model 
SpecE8, React, Phase2, X1t, and X2t can use the triple-layer method to model 
complexation of aqueous species with mineral surfaces, and Rxn can balance reactions 
involving triple-layer complexes. In the method, three planes – the 0, β, and d planes – 
make up a mineral’s complexing surface. The surface at the 0 plane can protonate by 
complexing with hydrogen ions from solution, or deprotonate by releasing them. Other 
ions in solution, including oxyions, hydroxyions, and so on, can form inner-sphere 
complexes on the 0 plane, as well as outer-sphere complexes at the β plane. 

The d plane represents the inner bound of a diffuse layer of counter-ions, ions that are 
attracted to electrical charge on the 0 and β planes. Charge on the d plane, reflecting net 
electrical charge within the diffuse layer, counter-balances charge on the 0 and β planes. 
From a distance into the solution, then, the mineral surface appears electrically neutral. 
The region between the 0 and β planes has a specified capacitance C1; capacitance of the 
layer between the β and d planes is also known and denoted C2. 

Successfully solving a triple-layer complexation problem yields consistent values for 
(1) the concentrations of the various surface complexes considered in the calculation, 
(2) the charge densities σo, σβ, and σd on the three planes; and (3) the corresponding 
electrical potentials ψo, ψβ, and ψd. 

To make use of the triple-layer method, you load a surface reaction or “.sdat” dataset 
identified in the header as containing data for the “three-layer” model type. A triple-layer 
dataset provides the charges zo and zβ on the 0 and β planes, respectively, for each surface 
complex. In keeping with GWB convention, reactions in a surface dataset represent 
dissociation of the surface complex. A reaction’s log K value, then, is the negative of log K 
for the corresponding association reaction, as might be presented in the literature. 

Three examples of triple-layer datasets are installed with the software. The datasets 
“Goethite_Se.sdat”, “Goethite_NaCl.sdat”, and “Goethite_NaClO4.sdat” represent, 
respectively, the surface complexation of selenite, sodium chloride, and sodium 
perchlorate. 

2.6.3 CD-MUSIC model 
The programs can also use the CD-MUSIC method to model complexation on mineral 
surfaces. Like the triple-layer model, CD-MUSIC distributes mass across three layers. 
Unlike the simpler model, however, an ion’s charge in the CD-MUSIC model can be 
distributed among the 0, β, and d planes, so that charge at each plane in a surface 
complex may be fractional. 

You invoke the CD-MUSIC method by loading a “.sdat” dataset identified in the header 
as the “cd-music” model type. As with the triple-layer model, C1 is the capacitance of the 
region between the 0 and β planes, C2 denotes capacitance between β and d, and each 
reaction in the dataset has an associated log K. The CD-MUSIC model, however, sets out 
for each reaction changes in electrical charge —  ∆zo, ∆z1 , and ∆z2 —  at each of the planes 
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0, β, and d, respectively. Recall that since GWB datasets describe dissociation, a reaction’s 
log K as well as its ∆z values are negated relative to the corresponding association 
reaction. 

The GWB distribution contains two example CD-MUSIC datasets, “Goethite_Cu.sdat” 
and  “Goethite_P.sdat”, as well as two larger datasets “Ferrihydrite_cdmusic.sdat” and 
“Goethite_cdmusic.sdat” derived from a compilation for the PhreeqC software (see 
Further Reading). 

2.6.4 Ion exchange 
The GWB programs can model ion exchange reactions on mineral surfaces in two ways. 
The first and simplest, although less general, method is to swap an activity ratio into the 
basis and prescribe its value. For example, from the Basis pane select the swap button  
next to an exchanging ion like Ca++ and select Ratio…. Set “Ca++” for the numerator and 
“Na+” squared in the denominator with an exponent of “2”. 

 

Then type the desired value for the ratio into the entry box. Or, if for a ratio of 0.2, 

 

This method works in each of the GWB modeling programs (Rxn, Act2, Tact, SpecE8, 
React, Phase2, X1t, and X2t). 

Using this simple method is equivalent to assuming that the reservoir of exchanging 
ions on the exchanging surface is sufficiently large that its composition can be taken as 
invariant. A second, more general method for modeling ion exchange is available in Rxn, 
SpecE8, React, Phase2, X1t, and X2t. This method accounts for the number of sites on the 
exchanging surface. 

To invoke the second method, you prepare a small dataset of exchange reactions, 
using file “IonEx.sdat” as a template. (This file is distributed with the GWB and installed 
with the thermo datasets, generally in directory “\Program Files\GWB\Gtdata”.) The 
program TEdit provides a convenient way to create the new dataset (see the chapter 

swap Ca++/Na+^2 for Ca++ 
ratio Ca++/Na+^2 = 0.2 
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Using TEdit in this guide). You can prepare the dataset to honor the Gaines-Thomas, 
Vanselow, or Gapon convention. 

Each exchange reaction is of the form 
 

 >X:A+ + B+ ⇆ >X:B+ + A+ (2.21) 
 

where A+ and B+ are ionic species and >X: represents the exchanging site. For the Gaines-
Thomas and Vanselow conventions, the exchange reaction involving a divalent ion takes 
the form 
 
 >X:2A++ + 2 B+ ⇆ 2 >X:B+ + A++ (2.22) 
 
where A+ + is the doubly charged ion. Such a reaction under the Gapon convention takes 
the form 
 
 

>X:A1
2⁄

++ + B+ ⇆  >X:B+ + 1
2⁄  A++  (2.23) 

 
A selectivity coefficient serves as the equilibrium constant for the mass action equation 
corresponding to each exchange reaction. 

It is important to note that the GWB carries mass action equations for ion exchange 
reactions written in terms of the activities rather than the molalities of the aqueous 
species. In taking selectivity coefficients from the literature, therefore, you should be 
careful to check units and convert from total molality to free activity, as necessary. 

2.6.5 Distribution coefficients (Kd) 
You can account for ion sorption in Rxn, SpecE8, React, Phase2, X1t, and X2t according to 
the distribution coefficient (Kd) approach. This approach does not carry a mass balance on 
the sorbing sites, so it is straightforward to implement and hence rather popular. The 
method’s accuracy, however, can be poor, so the technique should be applied with 
caution. 

According to the distribution coefficient approach, sorption reactions are written 

 
 >M++ ⇆ M++ (2.24) 
 
where >M+ + and M+ + represent an ion in sorbed and free form. In the GWB, the 
distribution coefficient Kd represents the ratio of the sorbed mass, in moles per gram of 
solid phase, to the activity aM++ of the free ion. 
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Note that in taking Kd values from the literature, you may need to convert the ion’s 
total molality to free activity. It is also important to remember that, unlike other sorption 
models, the distribution coefficient approach carries the sorbed concentration in moles 
per mass solid, rather than liquid phase. 

To set up a calculation, read one or more datasets containing distribution coefficients 
for sorption reactions using File → Open → Sorbing Surfaces… (or Config → Sorbing 
Surfaces…) or the surface_data command. Prepare the datasets using the file 
“Kd.sdat” as a template. 

2.6.6 Freundlich isotherms 
Freundlich isotherms are similar to the Kd approach, differing in that the sorbed mass 
SM>M++ of an ion, in moles per gram of solid phase, is given from the ion’s free activity, the 
Freundlich coefficient Kf, and an exponent nf, according to  
 
 SM>M++ =  Kf aM++

𝑛𝑛𝑓𝑓  (2.25) 

 
where 0 < nf  < 1. For an exponent nf  of one, the method reduces to the Kd approach. To 
invoke Freundlich isotherms, prepare a dataset of surface reactions using the file 
“Freundlich.sdat” as a template. 

2.6.7 Langmuir isotherms 
In Rxn, SpecE8, React, Phase2,  X1t, and X2t, you can also describe ion sorption in terms 
of Langmuir isotherms. In this method, ions are taken to sorb according to a reaction 
 
 >L:A+ ⇆  >L: + A+ (2.26) 
 
where >L:A+ is the surface complex, >L: is a sorbing site, and A+ is the sorbing ion. 

Each sorbing reaction has a corresponding equilibrium constant, commonly labeled 
Kads. As with other reactions in the GWB, the equilibrium constants refer to mass action 
equations for dissociation reactions written in terms of species’ free activity, rather than 
total molality. You may, therefore, need to correct data for this unit change when 
extracting data from the literature. 

The Langmuir method is in many ways similar to the two-layer surface complexation 
model. It does not, however, consider electrostatic forces. You set the number of sorbing 
sites explicitly, instead of having the software calculate this number from the mass of a 
sorbing mineral. 

To invoke a Langmuir model, prepare a reaction dataset containing the sorbing 
reactions and their equilibrium constants using the format of the file “Langmuir.sdat” as a 
template. 
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2.6.8 Polydentate sorption 
The programs Rxn, SpecE8, React, Phase2, X1t, and X2t can account for polydentate 
sorption, in which an aqueous species complexes with more than one surface site, 
following various protocols. A polydentate reaction may be set in a Langmuir, double 
layer, triple layer, or CD-MUSIC dataset, but the surface sites in the reaction must be of the 
same type: a species cannot form a complex with dissimilar sites. 

Given a polydentate sorption reaction in which a surface complex >SnB is composed of 
a species B complexed with to n sites >S 

 
 >S𝑛𝑛B ⇆  𝑛𝑛 >S + B (2.27) 
 
a mass action equation can be written according to any of the protocols shown in 
Table 2.3. In the mass action expressions, [>SnB] and [>S] are the molal concentrations of 
complexed and un-complexed sites, respectively, and the notation [>S]tot  represents the 
total site concentration, the sum of the concentrations of all sites, whether complexed or 
uncomplexed. 

Table 2.3 Polydentate sorption 

Protocol Mass action equation 

stoichiometric 
[>S] [B]
[>S B]

n

n

K =  

davis-leckie 
[>S][B]
[>S B]n

K =  

hiemstra-vanriemsdijk 
( )[>S] / [>S] [B]

[>S B] / [>S]

n
tot

n tot

K =  

appelo-postma 
( )[>S] / [>S] [B]

[>S B] / [>S]

n
tot

n tot

K
n

=  

 
The protocol is specified in the header section of a surface dataset, by appending the 

tag in the first column of Table 2.3 to the “Model type:” line. For example, 

 

Model type: two-layer hiemstra-vanriemsdijk  

  or 

Model type: cd-music appelo-postma 
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The default protocol is hiemstra-vanriemsdijk. Since many datasets either do not 
contain polydentate reactions or invoke the default formalism, the final argument on this 
line is many times omitted when constructing a surface dataset. 

2.7 Isotope fractionation datasets 
SpecE8, React, Phase2, X1t, and X2t can compute the equilibrium fractionation of the 
stable isotopes of any element for which one mass is dominant. The programs in a single 
run are able to consider fractionation of any number of the isotopes, from any 
combination of elements. They can, as examples, compute the distribution of both 13C and 
18O, 17O as well as 18O, or all three isotopes together. 

The GWB is distributed with a default database “isotope.dat” that contains coefficients 
for determining fractionation factors for the isotopes 2H, 13C, 18O, and 34S. Specifically, the 
dataset contains polynomial expansions as functions of temperature of the fractionation 
factors for aqueous species, minerals, and gases. 

The factors describe fractionation of chemical species relative to a reference species 
for each isotope. The reference species are the solvent H2O for 18O and 2H, dissolved CO2 
for 13C, and aqueous H2S for 34S. Note the dataset is incomplete, and that the program will 
assume a fractionation factor of 0 (zero) for any species not listed. 

Since an isotope fractionation file is an ascii (character) file, you can alter it using a text 
editor such as Notepad. You may add fractionation data for additional aqueous species, 
minerals, and gases, as well as for surface complexes, using the same data format as for 
other species. Following the format in “isotope.dat”, further, you can add fractionation 
data for the isotopes of elements not listed, such as 57Fe and 58Fe. 

You may also expand the dataset to include additional isotopes of the elements 
already present, such as 17O. In any event, an isotope in the dataset needs to be a minor 
isotope, one that comprises a small fraction of the mass of the element in question, that 
fractionates relative to a dominant isotope that makes up most of the element's mass.  

To load an isotope database besides “isotope.dat” into the program, go to the 
File → Open → Isotope Data… dialog. You can equivalently use the isotope_data 
command on the Command pane, or simply drag the database into the application 
window. To specify a new default for the isotope dataset, go to the File → Preferences… 
dialog. 

2.8 Electrical conductivity 
Programs SpecE8, React, Phase2, X1t, and X2t calculate electrical conductivity using one 
of two approaches: the USGS method, the default, and the older APHA method. The USGS 
approach, proposed by McCleskey, Nordstrom, Ryan, and Ball (see Further Reading), can 
be applied to solutions with ionic strengths up to 1 mol/kg, and at temperatures in the 
range 5°C –95°C. You invoke the USGS method by loading file “conductivity_USGS.dat” 
from the File → Open → Conductivity Data… dialog, or by dragging the dataset into the 
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app’s window. The dataset contains the coefficients of quadratic equations giving the 
ionic molal conductivities for various ions, as functions of ionic strength and temperature. 

The APHA procedure is outlined in Standard Methods for the Examination of Water and 
Wastewater, Section “2510A” (see Further Reading), and the equivalent conductances for 
different ions and their derivatives with respect to temperature are included in the file 
“conductivity_APHA.dat”. This approach is valid for temperatures between 20°C –30°C and 
ionic strengths up to 0.5 mol/kg. 

Significantly, the GWB programs correctly do not assume complete ionization; they use 
free species concentrations rather than total concentrations in performing the 
calculations. 

2.9 Environment variables 
You can specify various default settings for the GWB programs by defining environment 
variables. In a command line environment, you might, for example, issue the command 

 

which would define “my_thermo.tdat” as the default thermodynamic dataset that loads 
whenever a GWB app starts. You set environmental variables globally from the Windows 
Control Panel, under System → Advanced system settings. 

You can set the following environment variables: 
 
GWB_GTDATA The directory where the apps will look for thermo 

datasets, if not found in the working directory. 

GWB_THERMODATA The default thermodynamic dataset. 

GWB_CONDUCTIVITYDATA The dataset of coefficients for calculating electrical 
conductivity. 

GWB_ISOTOPEDATA The dataset of isotope fractionation factors. 

GWB_SURFACEDATA Dataset(s) of surface sorption reactions. 

 
 

set GWB_THERMODATA=my_thermo.tdat 
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Using GSS 

GSS—The Geochemist’s Spreadsheet—is a program developed to hold, manipulate, and 
graph the results of water chemistry analyses. GSS is a full-featured spreadsheet designed 
to work with the other software tools in the GWB. 

Enter or paste the analyses for all your samples, for each analyte measured, into a GSS 
data sheet. You can copy your data as a block and paste them in one step, thus creating a 
data sheet need take only a moment. Once ready, it can do a number of things that would 
be difficult with an ordinary spreadsheet. It can, for example, 

 Convert units with a click of the mouse 
 Use Gtplot to make cross plots and series or time series graphs 
 Create your favorite plots: triangular, Piper, Durov, Schoeller, Stiff, and so on 
 Overlay data on a redox-pH or activity diagram created with Act2 or Tact, or on 

a variety of diagrams created in Gtplot, P2plot, or Xtplot 
 Compare replicate analyses and check standards 
 Check results against regulatory limits or remedial objectives 
 Calculate speciation, mineral saturation, gas fugacity, and so on 
 Evaluate equations you specify 
 Mix samples in any proportion 
 Launch SpecE8 or React for any sample 

The next section describes how to set up the data sheet, and later sections explain how 
to perform calculations and graph results. GSS is designed to be up and running quickly, 
so there’s no reason to hesitate. 

3.1 Your first data sheet 
To create a data sheet, start GSS or select File → New if it is already running. You will see 
an empty data sheet containing some common analytes. 
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Begin by adding to the data sheet the analytes you need, and deleting those you don’t. 
Add analytes by clicking on  and choosing from various Chemical parameters, 

Physical parameters, or any of the Basis species in the thermodynamic dataset. If you 
don’t see what you need, choose User analytes and create your own. If you’d like to 
evaluate an equation using analytes in your spreadsheet, choose User equations and 
specify its form. You can add any number of the previously mentioned analytes in one step 
by selecting Multiple Analytes…. To delete an analyte, select it and press the Delete key. 

If the unit for an analyte doesn’t match your data, right-click on it. To change units for 
more than one analyte, select a group of analytes by holding down the shift or control key, 
then right-clicking on the group. Using the “As” pulldown, you can set units as elemental 
equivalents: “mg/kg SO4-- as S” or “mg/l As(OH)4- as As”. Similarly, you can set units as 
species equivalents, in terms of protonated or deprotonated forms of the basis or redox 
species: “mg/kg HPO4-- as PO4---”, “mg/l NH4+ as NH3”, and so on. 

Now arrange the analytes to match your data. Simply drag an analyte, or a group of 
analytes, to the desired point in the list. To arrange the datasheet with the analytes in 
columns rather than rows, click Edit → Transpose Data Sheet. The data sheet might look 
like the following example. 
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You are ready to add your data. Click on  in your data sheet to create a column 
(or row) of empty data cells. You can enter values into the cells individually, but it’s easier 
to copy from a source such as an Excel spreadsheet. Copy a block of values for all of your 
analytes and samples, then paste it into GSS with Edit → Paste. A completed data sheet is 
shown below. 

 

3.2 Working with a data sheet 
Once you have set up a data sheet containing your data, you can work with it in various 
ways. Example datasets are installed with the software, under “\Program 
Files\GWB\Script”. You can open one of these in GSS (File → Open → GSS Spreadsheet…) 
to experiment with the program. 

3.2.1 Changing the view 
You can change how the data is displayed on the current data sheet with the 
Edit → Appearance… dialog, and the default appearance for data sheets under 
File → Preferences…. This allows you to set the font, point size, and number of significant 
digits shown in the data cells. 

Zoom in and out with Edit → Zoom → Zoom In (Ctrl++) and Zoom Out (Ctrl+-); Zoom 
100% (Ctrl+Shift+Z) returns to the font size set in File → Preferences…. 

To change the width of the data cells, drag the dividing line between columns left or 
right. Dragging changes the width of all the data cells in the column at once. 



44   GWB Essentials 
 

 
 

If you have too much data to view, you can temporarily hide analytes or samples. 
Select the rows or columns you wish to hide, then under Data → Hide and Show choose 
Hide Analytes or Hide Samples; restore the display with Show All Analytes or Show All 
Samples. 

3.2.2 Data cells 
Each cell in a data sheet contains a numerical value, such as the concentration of a 
species, a character string, or a date or time. If you have no data for a cell, set a character 
string such as “n/d”, or just leave the cell empty. 

Where an analysis falls below the detection limit, enter a value such as “<0.01”. GSS 
carries this value as it changes units, and will display it with a special “less than” symbol 
on plots. 

You can enter dates in various formats: “Sep 21, 2016”, “9/21/16”, “September 21”, and 
so on. GSS displays the field in the local format set for your computer. Enter time as a 
value such as “2:20 PM”, “14:20”, or “2:20:30 PM”. 

3.2.3 Changing units 
To change units on the data sheet, select one or more analytes and right-click on the unit 
field, or choose Data → Units. Either way, from the As option you can set concentrations in 
elemental equivalents, such as “mg/kg SO4-- as S”, or in species equivalents, in terms of 
protonated or deprotonated forms of the basis or redox species, such as “mg/kg HS– as 
H2S”. When you change units, you can choose to convert the values in the corresponding 
data cells to the new unit or leave the numbers unchanged. 

Some unit conversions require knowledge of the fluid’s dissolved solids content (the 
TDS) or density, or both. If you enter values for these analytes, GSS uses the entries 
directly. Otherwise, the program estimates values for each sample from the information 
provided. It is best in that case to enter the complete analysis for a sample before 
converting units, so GSS can estimate density and TDS as accurately as possible. 

The program calculates TDS for each sample by adding the masses of the solutes, and 
figures density as that of an NaCl solution of the same TDS at the specified temperature, or 
25°C if none is set. Converting from concentration units (mg/kg, mmolar, …) to absolute 
mass (grams, mmoles, ...) requires an entry for solution mass. If a solution mass is not 
entered, the program calculates it from the concentrations given for the various solutes, 
assuming a solvent mass of 1 kg. 

3.2.4 Error bars 
Set an error bar for the entry in a data cell as a triplet of values separated by vertical bars. 
An entry 0.5|2.0|3.5, for example, appears in GSS plots as a data point at 2.0 overlying an 
error bar extending from 0.5 to 3.5. Entry 0.5| |3.5 appears as an error bar alone with no 
specified data point. 
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3.2.5 Calculating analytes 
You can add a number of calculated values to your data sheet, including 

 Chemical parameters, such as TDS, electrical conductivity, and hardness 
 Physical parameters, such as fluid density and viscosity 
 Components in fluid 
 Free concentration, activity, and activity coefficients of aqueous species 
 Saturation indices of minerals, such as calcite, and solid solutions 
 Fugacity and partial pressure of gases, such as CO2 

GSS doesn’t do the calculation itself; instead, it sends data from the data sheet to 
SpecE8, which does the calculations and returns the results to GSS. The SpecE8 program 
is described in the Using SpecE8 chapter. 

Keep in mind that the order of the analytes in the data sheet is important. In its 
calculations, SpecE8 will use the first constraint it finds for a particular basis component. 
For example, if both Eh and O2(aq) are present, SpecE8 will use whichever is first in the 
data sheet. You can easily change the order of the analytes by dragging, or hide analytes 
you don’t want used in the calculations. 

If the data sheet has hidden analytes, “less than” (<0.001) values, or 0 values, you may 
choose to omit them when generating input for SpecE8 in the Analysis → Options… 
dialog. You can also add additional commands to the SpecE8 input there or in the 
Analysis → Launch… dialog. Header command lines will be inserted near the beginning, 
just after the thermo data is read. Trailer command lines will be added to the end of the 
input. 
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To add calculated analytes to your data sheet, click on  → Calculate with 
SpecE8… or Analysis → Calculate with SpecE8…. The Calculate Analytes dialog box is 
shown below. 

 

Choose a variable type, then select one or more analytes and click OK or Apply. The 
calculated data will appear as a new row (or column) of cells in your data sheet.  

Your calculated analytes will not update automatically if the data in your spreadsheet 
changes. Trigger SpecE8 to repeat a calculation by right-clicking on an analyte’s name 
and selecting Recalculate Analyte.  

3.2.6 Sorting 
You can sort the analytes or samples in the data sheet numerically, or alphabetically for 
text entries, with the Data → Sort… dialog shown below. 

  

You might sort analytes so the components with the highest concentrations appear at the 
top of the sheet, and the lowest at the bottom. Or you could sort samples so they are 
ordered with the most acidic pH values to the left and most alkaline to the right. 
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Classes of analytes are grouped together in the sorted results. Basis species, then, are 
grouped, not interspersed with chemical parameters or other analytes. Sort a subset of 
the data, instead of the entire data sheet, by selecting the data and checking the “Sort 
selected analytes/samples only” box. You can sequentially undo your sorts with the 
Revert button. 

3.2.7 Notes 
You can save relevant information—the site’s location, who conducted the sampling, what 
laboratory analyzed the samples, and so on—along with your data sheet. To do so, select 
Data → Notes…. Information you type into the text box is saved with your GSS document. 

3.2.8 Comments 
You can embed comments within individual data cells. Right-click on a cell and select 
“Add Comment”, then type into the yellow box that opens. Click outside the box to embed 
the comment. View a comment by moving your mouse over the right side of a yellow-
shaded cell or by right-clicking on the cell and selecting “Comment”. With the comment 
box open, you can edit or delete the comment. Delete all comments by going to Data → 
Delete all Comments. 

3.2.9 Undo and redo 
You can reverse one or more recently performed actions in GSS by choosing Edit → Undo 
(Ctrl+Z). You set the number of levels of undo allowed in the File → Preferences… dialog. 
To cancel the effects of an undo, select Edit → Redo (Ctrl+Y). 

3.2.10 Saving and exporting data 
Choosing File → Save saves your data sheet as a “.gss” file. Files of this type are in a special 
format that contains not only the entries in the data cells, but the settings for the program 
options, the display, the name of the thermo dataset, and so on. 

You can export the entries in a GSS data sheet to other programs in several ways. The 
easiest way is to use GWB’s drag and drop feature (see Drag and drop). In GSS, select a 
Sample ID with the right mouse button, drag to the other program, and release. 
Alternatively, you can select the data cells of interest, copy them to the clipboard 
(Edit → Copy), and paste them in an application such as MS Excel, Notepad, or MS Word. 

You can also save the data sheet as a tab-delimited or comma-delimited file (“.txt” or 
“.csv”) that other applications can read. Select File → Save As… and choose the file type 
and file name. You can specify on this dialog the data orientation and whether to export 
hidden analytes or samples. 
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3.2.11 Resuming your session 
You can continue working on the data sheet from the last time you had GSS open by 
choosing File → Resume → Resume. To have GSS do this automatically each time you 
open the program, set File → Resume → Resume On Startup. 

3.3 Analytes 
Analytes are the measurements or sample properties that GSS can store, use, and display. 
Analytes in GSS fall into six categories: 

 Chemical parameters 
 Physical parameters 
 Basis species 
 User analytes 
 User equations 
 Calculated values 

Add analytes individually by clicking on  and choosing an option from the first 
five categories, or add multiple analytes in one step by selecting Multiple Analytes…. For 
values requiring a speciation calculation, click  → Calculate with SpecE8…. 

3.3.1 Chemical parameters 
A number of commonly used analytes are predefined within GSS. The chemical 
parameters include temperature, pH, Eh, TDS, and so on. 

3.3.2 Physical parameters 
The physical parameters include fluid density, length, width, X position, and Y position. 

3.3.3 Basis species 
Each of the primary basis species and redox species in the thermodynamic dataset loaded 
with your session is available as an analyte. The primary basis species might include 
components such as Na+, Ca+ +, Cl–, SO4

– – , and Fe+ +, whereas Fe+ + +, HS–, and so on might 
appear in the thermo dataset as redox species. 

A number of thermo datasets are installed with the GWB software, and others are 
available on the GWB.com website. When you create a new data sheet, GSS opens the 
thermo dataset listed in File → Preferences…, looking for it in the directory shown. You 
can edit the entries in the thermo dataset or create your own dataset, as described in the 
Thermo Datasets chapter of the GWB Reference Manual. 

To change datasets, use File → Open → Thermo Data…, or File → Recent Files. 
File → File Properties → Thermo Data… shows information about the thermo dataset 
currently in use. 
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3.3.4 User analytes 
If you can’t find the analyte you need, you can quickly define your own. You might, for 

example, set latitude or longitude as a text field, specify a numerical value for turbidity, 
and so on. To create an analyte, click  → User analytes → Edit… to launch the Edit 
User Analytes dialog 

 

Enter a name, choose the category in which the analyte will plot, then select its 
dimension and default unit (see the Units Recognized chapter in the GWB Reference 
Manual for a list of dimensions and units). Click Apply to finish. The analyte will be added 
to the spreadsheet, where you can assign a value for each sample.  

The left side of the dialog lists user analytes in the order they appear in the 
spreadsheet. You can click on an analyte in the list to see its properties, or click <new> to 
add more. By right-clicking, you can create, copy, or delete analytes. 

GSS keeps a list of your user analytes—those you define and any encountered in data 
sheets you open—in your computer’s registry, so they are available from one run to the 
next. These are accessible from  → User analytes → Recent. From the Recent 
submenu, select an analyte to add it to the sheet, or Clear All to clear the list.  

To bring in an analyte from another .gss file, if not in your registry, use  → User 
analytes → Import…. 

3.3.5 User equations 
User equations are similar to user analytes, except you specify a simple equation for GSS 
to evaluate, rather than specifying values individually. You might use GSS to calculate ion 
ratios, simple geothermometers, water quality metrics, and so on. 
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To create an equation, click  → User equations → Edit…  

 

In addition to the information required of user analytes, supply the equation to be 
evaluated, which can consist of four basic types of input:  

 Analytes in the spreadsheet, such as the Ca++ concentration in meq/l 
 Constants of geochemical interest, such as the molar gas constant 
 Functions, such as SQRT(), EXP(), LN(), or LOG() 
 Mathematical operators, such as +, - , *, /, ^ 

Analytes in an equation can be any of the supplied chemical or physical parameters or 
basis species, as well as user analytes, other user equations, or calculated values. Analyte 
names and their units to use in the calculation, which can differ from their current units in 
the spreadsheet, should be enclosed within ${ }, as in the examples below: 

 

Examples of constants include: 

 

${Ca++, meq/l} 
${HCO3-, mg/kg as C} 
${SiO2(aq), log mg/kg} 

R(J/mol/K) 
e 
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Table 3.1 describes the functions recognized by GSS. Examples of functions accepting 
one argument or multiple arguments separated by commas, respectively, include: 

 

Group terms using parentheses: 

 

You can type the equation directly or use the pulldowns beneath the equation box to 
insert recognized options. The first pulldown lists the input types and the second lists 
options for that type. The third, where applicable, lists units, “as” options, and log 
settings. Click Insert to add the input to the equation, then continue with more input until 
your equation is complete. Be sure the default unit you set corresponds to the equation as 
specified. An example equation to calculate the sodium adsorption ratio from the Na+, 
Ca++, and Mg++ concentrations in your spreadsheet is shown below: 

 

As with calculated analytes, user equations will not update automatically if the data in 
your spreadsheet changes. Trigger GSS to recalculate a user equation by right-clicking on 
the analyte’s name and selecting Recalculate Analyte.  

 

Table 3.1 Functions recognized as input to user equations  

Function Arguments Description 

ABS(), EXP(), LN(), 
LOG(), SQRT(), SGN() 

1 Absolute value, exponentiation, 
natural and common logarithms, 
square root, and sign functions 

SIN(), COS(), TAN(), 
ASIN(), ACOS(), ATAN(), 
SINH(), COSH(), TANH() 

1 Trigonometric functions (taking 
values in radians), their inverses, 
and hyperbolic trig functions 

MOD() 2 Modulus operation 

MIN(), MAX any number Minimum or maximum of values 

SUM(), AVERAGE(), 
STDEV() 

any number Sum, average, or standard 
deviation of a set of values 

LN(${Ionic strength, molal}) 
SUM(${Na+, mmolal}, ${K+, mmolal}, ${Ca++, mmolal}) 

${Na+, mol/l} / (${Na+, mol/l} + ${Ca++, mol/l}) 

${Na+, meq/l} / SQRT(.5* (${Ca++, meq/l} + ${Mg++, meq/l})) 
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3.3.6 Adding Multiple Analytes 
The fastest way to add more than one analyte is with the Add Multiple Analytes dialog. 

Click  → Multiple Analytes… or Data → Add Analytes… to open it. Initially, “All 
classes” is selected, but you can filter the category of analytes shown using the “Class” 
pulldown. Hold Ctrl or Shift while selecting to include multiple analytes, or use Ctrl+A to 
select all, then click OK or Apply. 

 

With the User analytes or User equations classes selected, you can right-click on an 
analyte to access more options. Choose to create a new analyte, edit an existing analyte, 
bring in an analyte from another .gss file, or clear the analyte from the registry. 

After adding your analytes, you can reorder them, change units, and transpose the data 
sheet to match your data source, then copy and paste a block of values into selected cells. 

3.3.7 Calculated values 
As described in the previous section, GSS can use SpecE8 to calculate 

 Chemical parameters, such as TDS, electrical conductivity, and hardness 
 Physical parameters, such as fluid density and viscosity 
 Components in fluid (e.g. the H+ component, when pH is set) 
 Species’ concentration, activity, and activity coefficients 
 Mineral and solid solution saturation indices 
 Gas fugacity and partial pressure 
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as described in the Using SpecE8 chapter of this guide. Select  → Calculate with 
SpecE8… or Analysis → Calculate with SpecE8… to add calculated analytes to the data 
sheet. 

You can control the details of how SpecE8 figures calculated values by going to the 
Analysis → Options… dialog. Here, you tell SpecE8 what to do if it encounters 0 or “less 
than” values. You can also set commands (see SpecE8 Commands in the GWB Command 
Reference) for SpecE8 to execute either before or after defining the chemical system, as it 
runs for each sample. You might, for example, enter a command such as 

 

to cause the program to force an ionic charge balance. 

3.3.8 Analyte properties 
You can see the properties of each analyte in the data sheet by choosing Data → Analyte 
Properties and selecting a class. The “Description” and “Source” fields can be set directly 
from the properties sheet; other fields are set in the thermo data, or from the Edit User 
Analytes or Edit User equations dialogs. To return to the data sheet, use the  button on 
the right. 

3.4 Regulations, replicates, standards, and mixing 
GSS can flag analyses violating regulatory limits or remedial objectives, compare replicate 
analyses, check analytical standards, and mix water samples. 

3.4.1 Flagging regulatory violations 
GSS can flag entries that fall outside the regulatory limits or remedial objectives for an 
analyte. To flag violations, select the Analysis → Check Regulatory Limits option. Entries 
below an analyte’s minimum level or above its maximum appear on your data sheet 
emboldened in red. 

GSS reads the regulatory limits from a text file that looks like 

 

balance on SO4-- 

# Analyte Min Max Unit   Notes 
# ----------------------------------------------- 
 
Al+++  -- 0.05 "mg/kg as Al" NSDWR 
AsO4--- -- 0.01 "mg/kg as As" MCL 
AsH3(aq) -- 0.01 "mg/kg as As" MCL 
pH  6.5 8.5 pH   NSDWR 
… 
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You specify the file to read on the File → Preferences… dialog. By default, the program 
reads a dataset “WaterQualityRegs.dat” installed with the software in “\Program 
Files\GWB”. You can use this file, based loosely on the US EPA’s drinking water standards, 
but most commonly you prepare a dataset to meet your own needs. 

3.4.2 Replicate analyses 
GSS can compare replicate analyses, analyses made of splits of the same sample, to verify 
the results agree to within an error tolerance. Select two or more samples on your data 
sheet, then choose Analysis → Compare Replicates…. The dialog that appears below 
shows the error tolerance and the samples to be compared. 

 

When you click OK or Apply, a column appears to the right (or bottom) of the data sheet 
showing the coefficient of variance among the samples for each analyte, along with a 
or , depending on whether or not the variance is within the tolerance indicated. Small 
coefficients of variance indicate good agreement among the replicates. 

To incorporate the variances into the data sheet, check the “Save as column” option. 
You can change the error tolerance, which defaults to ±5%, by right-clicking on one of the 
errors. Close the replicate display by clicking on  . 

3.4.3 Checking standards 
GSS can check analyses of standards, samples of well-known composition, for accuracy. 
Enter the standard’s known composition in a data sheet, along with its analysis or 
analyses. Select the standard and at least one analysis, then choose Analysis → Compare 
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To Standard…, which opens the dialog shown below, which shows the error tolerance to 
be allowed, the standard itself, and the analyses to compare to the standard. 

 

When you click OK or Apply, a column appears to the right (or bottom) of the data sheet 
showing the average deviation, along with a or , depending on whether or not the 
deviation is within the tolerance indicated. 

To incorporate the deviation results into the data sheet, check the “Save as column” 
option in the dialog box shown above. You can change the error tolerance by right-clicking 
on the error. Close the error display by clicking on . 

3.4.4 Mixing samples 
GSS can show the results of mixing two or more water samples in any proportion using the 
values of the total components calculated using SpecE8. Choose Analysis → Mix 
Samples… to open the Smart Mix wizard, then select the samples to mix and click Next >.  

You can control the details of how SpecE8 performs its calculations by going to the 
Analysis → Options… dialog. Here, you tell SpecE8 what to do if it encounters 0 or “less 
than” values.  

The wizard will list the Sample ID and the extent of the samples you’ve chosen to mix. 
GSS will mix samples volumetrically by default, but you can choose instead to mix 
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samples gravimetrically by selecting “mass” from the “Mix by” pulldown. When the “equal 
proportions” option is checked, each sample will be assigned a value of 1 liter (or 1 
kilogram of solution, if mixing by mass). By unchecking this option you can set values for 
samples individually. If you are mixing by mass and your spreadsheet includes values for 
the chemical parameter “Mass solution”, GSS will use those values. Otherwise, select a 
sample, set a value in the box, and click the Apply button, then repeat for the remaining 
samples. The Reset mixing button returns all settings to their defaults. Click Next > to 
move on to the next step. 

 

GSS will test each sample for convergence and report success or failure before 
beginning the mixing calculations. You can click More info… to see the SpecE8 input and 
calculation results for failed samples. Check the “show successful samples” box to show 
input and results for all samples. If a sample fails to converge, the Next > button to move 
on to the next step will be disabled. You can click < Back to remove the unsuccessful 
sample from the mix, or click Close to check the values in the spreadsheet before 
restarting the Smart Mix wizard. 

You can choose how GSS reports the extent of the mixed sample. If samples were 
mixed volumetrically, you can report the mixture’s total solution volume or scale the 
results to 1 liter of solution or solvent water. If samples were mixed by mass, you can 
report the total mass of the mixed fluid or scale the sample to 1 kilogram of solution or 
solvent water. Complete the mixing by clicking Calculate. 

The composition of the mixture will appear to the right (or bottom) of the data sheet, 
showing the results for each analyte in the spreadsheet. Unlike GWB releases 9.0 and 
earlier, GWB14 will automatically calculate the values of certain parameters that are not 
conserved during mixing, such as pH. Close the mixture display by clicking on . 
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To work with the mixture as if it were a sample, select the “Save as sample” option in the 
dialog box shown above. The result of the mixing calculation is placed in the data sheet as 
a new sample to the right of the selected column (or below the selected row). 

3.5 Launching SpecE8 and React 
You can use the chemical analyses in a GSS data sheet to set up and run SpecE8 or React 
calculations. These programs are described in the Using SpecE8 chapter in this guide and 
the Using React chapter in the GWB Reaction Modeling Guide. 

Select one or more samples on the data sheet, then choose Analysis → Launch…. If a 
sample has “less than” (<0.001) values, 0 values, or hidden analytes, you can choose to 
omit them when generating the input by going to the Analysis → Options… dialog. 

You can add additional commands to the SpecE8 or React input script created by GSS. 
Header command lines will be inserted near the beginning, just after the thermo data is 
read. Trailer command lines will be added at the end of the script. 
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When you hit Apply or OK, GSS writes into the specified directory an input file for each 
sample you have selected. The input files are named (Root filename) + (Sample ID) + 
“.sp8” or “.rea”. 

Unless you have selected “Save files only”, an instance of SpecE8 or React will be 
launched configured with the values in the first sample. If you have selected more than 
one sample, the program will do a batch run, writing the results to an output and plot file 
for each sample. 

3.6 Graphing data 
GSS can call on Gtplot to diagram the data in your data sheet in a variety of ways. The 
Using Gtplot chapter describes in detail the Gtplot program and the types of plots it 
creates. 
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3.6.1 Series and time series plots 
To graph the entries in your data sheet as a series, sample by sample, select the analyte or 
analytes to plot and click on Plot → XY Plot → Series Plot…. In the Gtplot window that 
opens, the samples are arranged along the x axis in the order they appear in your data 
sheet. To change which analytes are shown, or the axis units or data range, double-click 
on the y-axis label. 

To associate markers or their colors or sizes with samples in the data sheet, rather than 
analytes, go to Format → GSS Data…. To control whether the markers are connected by 
line segments, right-click on a marker and select or deselect “Connect Scatter Points”. 

To change the marker representing an analyte or sample, click in GSS on the marker 
next to the analyte or sample name. Choose a symbol and its color and size. GSS will 
automatically sync the changes with Gtplot unless the Plot → Auto Updates option is 
unchecked, in which case you can click on Plot → Update Plot(s) when you are ready to 
update Gtplot. 

To create a plot versus time, make sure “Date”, “Time”, or “Time elapsed” appears as 
an analyte in the data sheet, then choose Plot → XY Plot → Time Series Plot →, then 
choose from Time elapsed…, Time and date…, or Time of day…, if available. GSS will 
determine elapsed time for each sample from its date and time, if not specified directly. 

3.6.2 Cross plots 
To plot one analyte, or several, against another, select the analytes to appear in the 
diagram, then choose Plot → XY Plot → Cross Plot…. To change which analytes appear on 
the x or y axis, or the units or data range for either, double-click in Gtplot on the axis label. 
Control the markers and which samples appear in the plot as you would with a series plot. 

3.6.3 Ternary, Piper, and Durov diagrams 
To create a ternary (triangular) diagram, select in the data sheet three analytes to appear 
on the diagram axes, then choose Plot → Ternary Diagram…. Change the analytes 
appearing on the diagram axes or the axis units by double-clicking on the axis label. 

To plot a Piper or Durov diagram, select Plot → Piper Diagram… or Durov Diagram…. 
Control the markers and which samples appear in the plot as you would with a series plot. 

In order to see TDS represented as circles on Piper, ternary, and Durov diagrams, add 
TDS as an analyte in the data sheet and enter a value for each sample. Alternatively, you 
may select  → Calculate with SpecE8… to add calculated TDS to the data sheet, 
as described in the Calculating analytes section of this chapter. If you do not supply a 
measured value or use SpecE8 to calculate it, GSS will estimate TDS as described in the 
Changing units section of this chapter. 
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3.6.4 Other diagrams 
Create a Schoeller, Stiff, or radial diagram by clicking on Plot → Schoeller Diagram…, Stiff 
Diagram…, or Radial Plot…. To plot a bar or pie chart representing ion balance, choose 
Plot → Ion Balance → Bar Chart… or Pie Chart…. Choose samples from the Samples 
pane of the appropriate dialog (Schoeller Diagram…, and so on), which can be accessed 
in Gtplot under the Plot pulldown. 

3.6.5 Scatter data 
You can overlay the data entries in a GSS data sheet on any plot produced by the GWB 
applications, including activity diagrams made by Act2 and Tact and plots of the results of 
reaction and reactive transport models from Gtplot, P2plot, and Xtplot. 

To plot “scatter data,” first save your data sheet as a .gss file. In Act2, Tact, Gtplot, 
P2plot, or Xtplot, read the .gss file by selecting File → Open → Scatter Data.... Data points 
representing each sample will appear on the plot if the .gss file contains analytes 
corresponding to the plot axes. 

For details on plotting scatter data from .gss files, see the Using Act2, Using Tact, and 
Using Gtplot chapters in this guide, the Using Gtplot and Using P2plot chapters in the 
GWB Reaction Modeling Guide, and the Using Xtplot chapter in the GWB Reactive 
Transport Modeling Guide. 

 

Table 3.2 Keyboard shortcuts in GSS  

Ctrl+A Select all cells in the data sheet 

Ctrl+C Copy 

Ctrl+Shift+C Open a new conductivity file 

Ctrl+D Select all data cells in the data sheet 

Ctrl+F Find 

F1 Open GWB Essentials Guide 

F3 Find next instance 

Shift+F3 Find previous instance 

Ctrl+L Check regulatory limits toggle 

Ctrl+N Create new data sheet 

Ctrl+Shift+N Open Notes… dialog 

Ctrl+O Open an existing .gss file 
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Ctrl+P Print 

Ctrl+Q Quit the program 

Ctrl+Shift+R Restore the last data sheet configuration 

Ctrl+S Save the current spreadsheet to a file 

Ctrl+T Open a new thermo dataset 

Ctrl+U Update graphs in Gtplot 

Ctrl+V Paste 

Ctrl+W Open a new water quality regulatory standards file 

Ctrl+X Cut 

Ctrl+Y Redo 

Ctrl+Z Undo 

Ctrl++ Zoom in 

Ctrl+- Zoom out 

Ctrl+Shift+Z Zoom 100%—to font size in Preferences… 
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  Using Rxn 

Rxn is a program that, among other things, automatically balances chemical reactions 
among minerals, dissolved species, and gases. The program is easy to use, and quite 
useful. To show the balanced reaction by which analcime dissolves to form aqueous 
species, for example, start the program and move to the Basis pane. Clicking on the entry 
(initially, it is “???”) under “balance reaction for”, select “Analcime” from the list of 
“Minerals”. 

The Rxn window looks like this: 

 

To see the balanced reaction, select Run → Go, 
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press the Run button on the Results pane, or type 

 

The program gives the result 

 

The species H+, Na+, etc. are members of the original basis set carried in the 
thermodynamic database (see Table 2.1).  

react Analcime 
go 
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You can change the basis to generate reactions in alternative forms. To see the reaction 
balanced in terms of quartz and albite in place of SiO2(aq) and Al+ + +, use the  button to 
swap “Quartz” for “SiO2(aq)”, and “Albite” for “Al+++”. 

 

Or type 

 

The program gives the result 

 

swap Quartz for SiO2(aq) 
swap Albite for Al+++ 
go 
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Rxn will calculate a reaction’s equilibrium constant at a temperature of interest 
whenever the temperature is given. To find the equilibrium constant for the above 
reaction at 250°C, set temperature on the Basis pane, 

 

which gives the result log K = 0.3039. To unset the temperature, choose “reset” on the 
temperature pulldown menu, or type T = ?. 

The program can calculate additional information, including a polynomial fit that gives 
log K as a function of temperature (typically from 0°C to 300°C), the equilibrium equation 
for the reaction under various conditions, or the temperature at which a reaction is in 
equilibrium. To calculate additional information, put the program in “long” format by 
clicking on the  button on the Results pane, or by typing the command long. Return to 
the original “short” format by clicking on the  button, or typing short. 

For example, unsetting temperature and setting long mode generates the response: 
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You can see that at equilibrium the water activity equals the reaction’s equilibrium 
constant. The water activity is likely to be 1 or less, but the equilibrium constant is greater 
than 1 over the temperature range. The minerals albite, quartz, and analcime are unlikely, 
then, to be in equilibrium between 0°C and 300°C. 

If you set the water activity to unity on the Basis pane, or type 

 

the program reports in the Results pane that analcime in the presence of quartz should 
react to form albite: 

 

4.1 Balancing reactions 
Using basis swaps, you can balance any primary reaction. As an example of how Rxn 
balances reactions by basis swapping, consider the dissolution reaction of pyrite. Start on 
the Basis pane and under “balance reaction for”, select “???” → Mineral… → Pyrite. 

The pane should look like this 

 

(cont’d) 
a H2O = 1 
go 

Equilibrium equation: 
   log K = 0 
   Reaction is not in equilibrium between 0 and 300 C 
      Products favored over this temperature range 
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Alternatively, type 

 

Move to the Results pane and click Run to see the reaction 

 

written in terms of the species in the original basis. 
Alternatively, you could write the reaction producing hydrogen instead of consuming 

dissolved oxygen. Move back to the Basis pane, click on the  button next to O2(aq), and 
select Aqueous… → H2(aq) 

 

or type 

 

which gives the result 

 

Swapping dissolved H2S for the SO4–– ion (and unswapping the H2(aq)) 

 

react Pyrite 
go 

(cont’d) 
swap H2(aq) for O2(aq) 
go 
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or 

 

gives the reaction written in terms of reduced sulfur 

 

Finally, replacing oxygen in the basis with H2S(aq) 

 

gives a dissolution reaction written in terms of SO4–– and H2S 

 

that involves neither oxygen nor hydrogen. 

4.2 Calculating equilibrium equations 
To calculate the equilibrium equation corresponding to a reaction, constrain species 
activities and gas fugacities as needed and set Rxn in long format.  

To calculate the line between hematite (Fe2O3) and Fe+ + in Eh-pH coordinates at 25°C, 
assuming an iron activity of 10–8, for example, start Rxn and move to the Basis pane. 
Under “balance reaction for”, select “???” → Mineral… → Hematite. Change the unit for H+ 
from “activity” to “pH”. Set the H2O activity to “1”. Change the unit for Fe++ to “log 
activity” and set the value to “-8”. Click on the  button next to O2(aq) and select 
Aqueous… → e-, then change the unit from “activity” to “Eh”. Finally, set the temperature 
to “25°C”. 

(cont’d) 
unswap H2(aq) 
swap H2S(aq) for SO4-- 
go 
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The pane should look like this 

 

Or, type the commands 

 

T = 25 
react Hematite 
swap e- for O2(aq) 
log activity Fe++ = -8 
activity H2O = 1 
pH = ? 
Eh = ? 
long 
go 
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The result, shown on the Results pane, is 

 

The equation can be simplified by setting “factor reaction by” in the Basis pane to “1/6”, 

 

or  

 

which gives the equilibrium equation 

 

As a second exercise, we calculate at 200°C the equilibrium ratio of K+ to H+  activities 
for the reaction of muscovite to potassium feldspar (microcline) in the presence of quartz. 
Reset the configuration (select File → Reset Configuration) and move to the Basis pane. 
Under “balance reaction for”, select “???” → Mineral… → Maximum Microcline. Click on 
the  button next to K+ and select Ratio…. Set “K+” for the numerator, and “H+” in the 
denominator. Swap “Muscovite” for “Al+++” and “Quartz” for “SiO2(aq)”. Finally, set the 
temperature to “200°C”. 

factor = 1/6 

7.011 = pH + 5.634 x Eh 
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The pane should look like this 

 

Alternatively, type the commands 

 

T = 200 C 
react "Maximum Microcline" 
swap Muscovite for Al+++ 
swap Quartz for SiO2(aq) 
swap K+/H+ for K+ 
long 
go 
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Run the calculation and on the Results pane click  for long format results. 

 

Setting “factor reaction by” in the Basis pane to “3/2” 

 

will simplify the result, giving the equilibrium activity ratio directly 

 

at this temperature. 

4.3 Determining activity coefficients 
You can use Rxn to calculate activity coefficients from a version of Debye-Hückel theory, 
according to the dataset in use (see Activity coefficients under Using SpecE8). To do so, 
specify temperature and set solution ionic strength in molal units on the Basis pane, or 
use the ionic_strength (or I) command. To have Rxn calculate the activity of water, 
set the solution’s stoichiometric ionic strength on the Basis pane, or with the stoich_IS 
(or SI) command. 

Note, Rxn uses the Davies equation in place of virial methods. Additionally, Rxn will use 
the setting for stoichiometric ionic strength, if any, as a proxy for the sum of species 

1.5 Maximum Microcline = K+/H+ + .5 Muscovite + 3 Quartz 
Equilibrium equation: 
   4.057 = log a[K+/H+] 
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concentrations when calculating water activity by the Wolery (1992b) and Garrels and 
Christ (1965) methods (see Thermo Datasets in the GWB Reference Manual). 

To calculate activity coefficients, start Rxn and move to the Basis pane. Under 
“balance reaction for”, select “???” → Mineral… → Barite. Set the temperature to “25°C”. 
Finally, set the ionic strength to “3 molal”.  The pane should look like this 

 

Alternatively, type the commands 

 

Running the calculation causes the program to balance the reaction and report activity 
coefficients (“gammas”) for species Ba+ +  and SO4

– –  in a solution of 3 molal ionic strength 
at 25°C. The corresponding values, expressed directly instead of in exponential form, are 
0.16 and 0.11. 

react Barite 
T = 25 C 
I = 3 
long 
go 
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On the Results pane, the program gives the equilibrium equation for the reaction. 

 

Here, Rxn has used the calculated values for activity coefficients to simplify the equation, 
replacing activities with species molalities. 

4.4 Calculating equilibrium temperatures 
Rxn can calculate the temperature (or temperatures) at which a reaction is in equilibrium 
if the activity of each species and fugacity of each gas in the reaction is known. To 
calculate the temperature at which gypsum converts to anhydrite, swap the two minerals 
into the basis and set the water activity. 

Start Rxn and move to the Basis pane. Under “balance reaction for”, select “???” → 
Mineral… → Gypsum. Swap “Anhydrite” in for the “Ca++” and set the water activity to “1”. 
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The pane should look like this 

 

At unit water activity, the long format result is 

 

To calculate the temperature at lower water activity (which might be appropriate for a 
brine), set the activity of water to “0.7”. The program gives the result 

 

Rxn’s ability to calculate equilibrium temperatures can be useful for sorting among a 
mineral’s polymorphs to determine which is stable. For example, selecting Config → 
Show… and then selecting “Albite”, or typing  

 

produces a list of minerals in the database that have the same chemical formula as albite, 
which are “Albite high” and “Albite low”. 

Gypsum = Anhydrite + 2 H2O 
 
Reaction is in equilibrium at 43.7° C 
   Products favored above this temperature 

Reaction is in equilibrium at 11.8° C 
   Products favored above this temperature 

polymorphs Albite 
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The steps 

 

generate the information that high albite is the unstable form from 0°C to 300°C. 

4.5 Free energy change 
When you set a temperature and constrain a reaction sufficiently that either the reactants 
or reaction products are favored thermodynamically, Rxn will report the corresponding 
free energy change of reaction. 

Set Rxn to balance the reaction for the dismutation of acetate ion at 25°C, assuming 
bicarbonate is present at mmol/kg, and acetate and methane at 𝜇𝜇mol/kg levels.  

Start Rxn and move to the Basis pane. Under “balance reaction for”, select 
“???” → Aqueous… → CH3COO- and set its log activity to “-6”. Swap “CH4(aq)” for the 
“O2(aq)” and set its log activity to “-6”. Set the log activity of HCO3- to “-3” and the water 
activity to “1”. Finally, set the temperature to “25°C”.   

The pane should look like this 

 

react Albite 
swap “Albite high” for Al+++ 
long 
go 
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On the Results pane, the program reports the acetoclastis reaction  

 

along with the result that the reaction has a modest thermodynamic drive to proceed 
forward. 

4.6 Solid solutions 
Rxn can balance reactions involving end members of continuous, and tranches of discrete 
solid solutions (see Configuring the programs). You can work with solid solutions defined 
in the thermo dataset, or create new solutions with the Config → Solid Solutions… dialog 
or the solid_solution command. 

To configure a calcite-rhodochrosite solid solution, for example, select 
Config → Solid Solutions…, click  under “Define new solid solutions”, and expand 
the entry with the “+” button. Supply a name like “Cal-Rds”, choose end-member minerals 
“Calcite” and “Rhodochrosite”, and add tags such as “Cal” and “Rds”, respectively. 
Change the “type” from “ideal” to “Guggenheim”, set “a0” to “-3.2” and click Apply 
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Alternatively, the command  

 

serves the same purpose. 
To figure the equilibrium equation for the dissolution reaction of the calcite end 

member, move to the Basis pane and under “balance reaction for”, click “???” → End 
member… → Cal-Rds::Cal. Alternatively, use the command 

 

where “Cal-Rds” is the name of the solid solution and “Cal” is the end member’s tag.  
On the Results pane, click Run and expand the results by clicking the “+” button. The 

dissolution reaction and log K values are the same as for the pure mineral calcite. The 
equilibrium equation, however, carries the activity of the calcite end member 

solid_solution Cal-Rds Calcite tag Cal contains \ 
  Rhodochrosite tag Rds guggenheim a0 = -3.2 

react Cal-Rds::Cal 
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Return to the Basis pane and set the “mole fraction” of “Cal-Rds::Cal” to a value “0.9”, or 
use the command 

 

Rerun the calculation and note how Rxn reports the end member’s activity coefficient and 
carries its activity in the equilibrium equation  

  

Note if the solid solution activity model in use is temperature-dependent, you must 
additionally set the temperature to evaluate the activity coefficient expression. 

To consider the dissolution of a discrete-composition solid solution, as a second 
example, return to the Solid Solutions... dialog, change the “mode” pulldown to 
“discrete”  

xss Cal-Rds::Cal = 0.9 
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and click Apply. Note the “from” and “to” entries, as well as the “step”, which is 1/20th of 
the range by default. Rxn will use these values to generate a series of fixed-composition 
minerals, Cal(.95)-Rds(.05), Cal(.9)-Rds(.1), and so on. 

The continuous solid solution end member was removed from the reaction’s left side. 
Replace it with a tranche of the solid solution: Click “???” → Mineral… → Cal(.9)-Rds(.1) and 
recalculate the reaction. Alternatively, use the commands 

 

The tranche dissolves in the resulting reaction to form 0.9 Ca++ and 0.1 Mn++. The log K 
reported was determined as a function of the end member log Ks, mole fractions, and 
activity coefficients, as described in Solid solutions under Configuring the Programs. 

4.7 Sorption reactions 
Rxn manipulates the reactions by which ions sorb to a mineral in the same way it handles 
other types of reactions. Access a dataset of surface reactions by dragging it into the Rxn 
window; selecting File → Open → Sorbing Surfaces… (or Config → Sorbing Surfaces…), 
clicking on , and selecting a surface dataset; or with the surface_data (or 
surf_data) command. Once entered, you can view the surface sites and complexes by 
selecting Config → Show…, or typing show surfaces. 

4.7.1 Surface complexation 
To work with a surface complexation reaction, read a dataset of complexation reactions, 
such as “FeOH.sdat” supplied with the GWB. 

To try the feature, load this dataset by dragging it into the Rxn window, or by using one 
of the methods described above, and move to the Basis pane. Under “balance reaction 
for” select “???”→ Surface species… → >(s)FeOPb+. Set the units for “H+” to “pH”. 

(cont’d) 
solid_solution Cal-Rds discrete 
react Cal(.9)-Rds(.1) 
go 
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The pane should look like this 

 

On the Results pane, Rxn will report the reaction 

 

and its corresponding equilibrium equation 

 

The second term in the equation is the logarithm of the Boltzman factor, which accounts 
for electrostatic forces between the surface and solution. Here, F is the Faraday constant, 
PSI is mean surface potential, R is the gas constant, and TK is absolute temperature; m 
represents molal concentration. 

For two-layer reactions, Rxn will evaluate the Boltzman factor numerically if you 
specify temperature and ionic strength (on the Basis pane), and the charge density on the 
sorbing surface. Provide the latter value in units of 𝜇𝜇C/cm2 on the Sorbing Surfaces… 
dialog (Config → Sorbing Surfaces…) next to “constant charge” and hit Apply, or with the 
surface_charge (or surf_charge) command. 

Continuing on the Basis pane, set temperature to “25°C” and the ionic strength to “0.1” 

 

>(s)FeOPb+ + H+ = >(s)FeOH + Pb++ 

log K + (PSI[HFO] F)/(2.303 R TK) = log m[>(s)FeOH]  
   + log a[Pb++] - log m[>(s)FeOPb+] + pH  
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On Sorbing Surfaces…, set the constant charge to “-10.0 𝜇𝜇C/cm2”, then hit Apply 

 

Selecting Run → Go gives the simplified equation 

 

corresponding to 25°C, an ionic strength of 0.1 molal, and a surface charge density of -10 
𝜇𝜇C/cm2. 

The constant capacitance and constant potential models are variants of the surface 
complexation model. Set these on the Sorbing Surfaces… dialog (Config → Sorbing 
Surfaces…), or using the surface_capacitance and surface_potential 
commands, as described in the Configuring the Programs chapter. 

When working with triple-layer and CD-MUSIC reactions, the equilibrium equation 
involves a distinct surface charge and the corresponding surface potential for each of 
three layers. Determining a consistent set of charge densities and potentials requires a full 
solution to the surface speciation problem. As such, Rxn does not provide for simplifying 
the Boltzman factor for reactions from triple-layer or CD-MUSIC datasets. 

4.7.2 Ion exchange 
As described in the Configuring the Programs chapter, you can model ion exchange in 
two ways. The first method is to swap an activity ratio into the basis. This method is 
equivalent to assuming that there exists a sufficiently large reservoir of exchanging ions 
that the composition of the exchanging surface remains invariant. 

For a more general treatment, prepare a small dataset of exchange reactions using the 
file “IonEx.sdat” as a template. Load a dataset of exchange reactions by selecting 
File → Open → Sorbing Surfaces…, or with the surface_data (or read) command. The 
exchange reactions in this dataset are now available to your Rxn session. 

-5.707 = log m[>(s)FeOH] + log m[Pb++] - log m[>(s)FeOPb+]               
   + pH  
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You can load one or more exchange datasets (containing one or more exchange 
reactions) at a time, and in a single run combine ion exchange datasets with other types of 
surface reaction datasets. 

4.7.3 Distribution coefficients (Kd) 
To use distribution coefficients (Kd) to model sorption, prepare one or more datasets 
containing the sorption reactions and corresponding distribution coefficients using the 
file “Kd.sdat” as a template (see the Configuring the Programs chapter). As with any 
sorption model, read the dataset(s) by selecting File → Open → Sorbing Surfaces…, or 
using the surface_data command. Once the dataset(s) has been read, the sorption 
reactions they contain are available to your Rxn session. 

In the distribution coefficient model, the concentration of a sorbed ion is carried in 
units of moles per gram solid. If you wish to constrain the sorbed concentration of an ion 
in Rxn, do so in units of mol/g using the sorbed_mass (rather than the molality) 
command. 

4.7.4 Freundlich isotherms 
The use of Freundlich isotherms is broadly similar in implementation to the Kd approach, 
as described in the previous section, except the dataset of surface reactions follows the 
format of “Freundlich.sdat”, rather than “Kd.sdat”. 

4.7.5 Langmuir isotherms 
To model sorption according to Langmuir isotherms, prepare a dataset containing the 
sorption reactions in the format of dataset “Langmuir.sdat”. 

Enter the dataset into an Rxn run by selecting File → Open → Sorbing Surfaces…, or 
with the surface_data (or read) command. You can enter one or more Langmuir 
datasets, and mix Langmuir datasets with datasets for other sorption methods. 

4.8 Rxn command line 
You can start Rxn by clicking the icon on the GWB dashboard, opening a “.rxn” file, or 
entering the command rxn.exe from the Windows “Command Prompt.” 

When you start Rxn from the command line (as opposed to clicking on the icon), you 
can specify a number of arguments. For example, the command 

 

causes Rxn to read input commands from a file “my_script”, and to use “my_thermo.tdat” 
as the thermodynamic database. 

rxn –i my_script –d my_thermo.tdat 
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The following options are available from the command line: 
 
-cd Change the working directory to the directory containing 

the input script specified with the –i option. 

-nocd Do not change the working directory. 

<input_script> 
-i <input_script> 

Set a file from which to read input commands. 

-gtd <gtdata_dir> Set directory to search for thermodynamic datasets. 

-d <thermo_data> Set the thermodynamic dataset. 

-s <surface_data> Set a dataset of surface sorption reactions. 

-append Keep previous results of the “block” command on the 
clipboard. 

-main species Set the species to appear on the left side of the reaction.  

-short | -long Set the output to be written in concise or detailed format. 
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Using Act2 

Act2 is a program that calculates and plots activity-activity diagrams. This class of 
diagrams shows the stability of minerals and the predominance of aqueous species in 
chemical systems. A species activity, gas fugacity, activity or fugacity ratio, pH, Eh, or pe 
may serve as an axis variable. 

To diagram the effects of pH and the activity of dissolved oxygen on the speciation of 
uranium in water, for example, start the program and select “U++++” under “diagram 
species”. To do so, click on the current setting, initially “???”, to show the choice of basis 
entries available to diagram (remember that pressing U moves down the list to “U++++”). 
To the right, change the units by selecting “log activity”, then enter “-10” for the species’ 
log activity. 

In the box below, select “H+” for the x-axis species, and “O2(aq)” for the y axis. Then set 
“pH” as the unit for the x axis and adjust the y-axis range. The Basis pane should look like 
this: 
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Alternatively, enter the commands 

 

Here we have set a uranium activity of 10–10 and, by default, a temperature of 25°C. Specify 
axis ranges in terms of the logarithms of activity or fugacity values, and linearly in terms of 
pH, pe, and Eh. Move to the Plot pane to display the result. 

The program produces a file “Act2_output.txt” describing the calculation (select 
File → View → Act2_output.txt to inspect this dataset) and displays the diagram on the 
Plot pane. The figure below shows the resulting plot, a redox-pH diagram for uranium 
plotted against the activity of dissolved oxygen. Dashed lines show stability limits for 
water at 1 atm pressure. (Note that many of the figures in the User’s Guide have been 
simplified slightly or relabeled to allow for reduction and printing.)  

 

You can click on any boundary on the plot, including the water limits, to see the reaction it 
represents in a tooltip.  

diagram U++++ on O2(aq) vs pH 
log a U++++ = -10 
x from 0 to 14; y from -90 to 0 
go 
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You can return to the Basis or Command pane to alter the program configuration and 
produce further diagrams. To plot the fugacity of oxygen gas along the vertical axis on the 
diagram we just calculated, move to the Basis pane and swap the gas species into the 
basis by clicking on the  next to the y-axis entry and selecting Gas… → O2(g).  

The pane should look like this 

 

 Alternatively, enter the commands 

 

(cont’d) 
swap O2(g) for O2(aq) 
y from -90 to 0 
go 
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Move to the Plot pane to view the diagram. The figure below shows the results, a 
redox-pH diagram for uranium plotted against the fugacity of oxygen gas. 

 

Swapping the electron into the basis allows you to plot oxidation state in terms of Eh. On 
the Basis pane, swap Aqueous… → e- for O2(aq), and set units of “Eh”. 
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The pane should look like this 

 

Equivalent commands are 

 

Move to the Plot pane to view the diagram. 

(cont’d) 
swap e- for O2(aq) 
diagram on Eh 
y from -.75 to 1.25 
go 
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The figure below shows the results for the redox-pH diagram plotted against Eh. 

 

The oxidation state can be also represented in terms of the log activity ratio of a redox 
pair such as ferrous and ferric iron. On the Basis pane, click on  next to the y-axis entry 
and select Ratio…. Set “Fe+++” with a power of “1” as the numerator species, and “Fe++” 
with the same power in the denominator: 
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To the right of this entry in the Basis pane, set the axis to range from “-25” to “5”. The 
pane should look like this 

 

 Alternate commands are 

 

(cont’d) 
swap Fe+++/Fe++ for O2(aq) 
y from -25 to 5 
go 
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Move to the Plot pane to view the diagram. The figure below shows the results for the 
redox-pH diagram plotted against the activity ratio of Fe+ + + to Fe+ +. 

 

In calculating a diagram, Act2 balances each reaction possible among the aqueous 
species and minerals in the system and lists them along with their equilibrium equations 
in the “Act2_output.txt” dataset. 

5.1 Diagram calculation 
The most familiar class of activity-activity diagram is the redox-pH, but Act2 can calculate 
diagrams on any activity or fugacity axis, as well as diagrams that account for the 
presence of minerals, complexing species, and gas buffers. 

To evaluate the effect at 60°C of chloride complexing on copper at a CO2 fugacity of 1, 
for example, you could set the Cl– activity and CO2 fugacity in your input.  

Under “diagram species”, click on “???” and select “Cu+”. Change “activity” to “log 
activity” and set the value to “-6”.  

In the box below, select “H+” for the x-axis species, and “O2(aq)” for the y axis. Then 
select “pH” as the unit for the x axis and set the y-axis range from “-80” to “0”.  
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Under “in the presence of”, click  and select “HCO3-”, then click on the  button 
next to it and select Gas… → CO2(g). Set the fugacity to “1”. Next, click  and select 
“Cl-”, then set its value to “.1”. Finally, set temperature to “60°C”. 

The Basis pane should look like this: 

 

Or, use the commands 

 

Move to the Plot pane to view the diagram. 

T = 60 
diagram Cu+ on O2(aq) vs pH 
x from 0 to 14 
y from -80 to 0 
swap CO2(g) for HCO3- 
log a Cu+ = -6 
a Cl- = 0.1 
f CO2(g) = 1 
go 
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The figure below shows the activity-activity diagram drawn at 60°C for the copper-CO2-
chlorine system at fCO2 = 1 versus oxygen activity and pH at aCl- = .1: 

 

Note the implausibility of maintaining in nature this CO2 fugacity under alkaline 
conditions. 

The effect might be shown better by drawing the diagram at a pH of 6 using the activity 
of Cl– as an axis. Return to the Basis pane and click on “H+”, then select “Cl-” to take its 
place as the x-axis species. Set the log activity to range from “-3” to “.5”. Finally, note that 
“H+” has been automatically shifted to the “in the presence of” section with “pH” units. 
Set the value to “6”. 
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The pane should look like this 

 

Move to the Plot pane to view the diagram. The figure below shows the activity-activity 
diagram drawn at 60°C for the copper-CO2-chlorine system at fCO2 = 1 versus oxygen 
activity and aCl- at pH = 6. 
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A number of simple aluminosilicate minerals can be formed from kaolinite by 
exchanging cations for protons and adding or removing silica. The diagram defined by the 
following steps shows the stability of potassic and calcic aluminosilicates in the presence 
of quartz. 

Reset the configuration (select File → Reset Configuration) and move to the Basis 
pane. Under “diagram species”, set “Al+++” and then  Mineral… → Kaolinite.  

On the x axis, select “Ca++” and then  Ratio…. Set “Ca++” for the numerator and 
“H+” squared in the denominator with an exponent of “2”. Set the range from “12” to “20”. 
On the y axis, select “K+” and then  Ratio…. Set “K+” for the numerator and “H+” in the 
denominator. Set the range from “2” to “10”.  

Under “in the presence of”, click  and select “SiO2(aq)”, then 
 Mineral… → Quartz. The Basis pane should look like this 
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Or configure the diagram by the commands 

 

Move to the Plot pane to view the diagram. The figure below shows the stability 
diagram for aluminosilicate minerals at 25°C plotted versus aK+/aH+  and aCa++/aH+

2  in the 
presence of quartz. 

swap Kaolinite for Al+++ 
swap Quartz for SiO2(aq) 
swap K+/H+ for K+ 
swap Ca++/H+^2 for Ca++ 
diagram Kaolinite on K+/H+ vs Ca++/H+^2 
x 12 20; y 2 10 
go 
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To show the effect of varying the silica activity, replace the x axis with aSiO2 (aq). Return 
to the Basis pane and next to “Quartz” click  Unswap. Next, click on “Ca++/H+^2” on 
the x axis and select “SiO2(aq)” to take its place. Set the x axis to range from “-5” to “-2”. 
Next, set the y axis to range from “-5” to “10”. Finally, move to the “in the presence of” 
section and select “Ca++/H+^2”, then press delete. The pane should look like this 
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Or use the commands 

 

Move to the Plot pane to view the diagram. The figure below shows the stability 
diagram for aluminosilicate minerals at 25°C plotted versus aK+/aH+ and aSiO2 (aq) in the 
presence of quartz. 

(cont’d) 
unswap Quartz 
diagram vs SiO2(aq) 
remove Ca++/H+^2 
x -5 -2; y -5 10 
go 
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5.2 Solubility diagrams 
Solubility diagrams are similar to the diagrams calculated to this point, except that the 
activity of the main species, instead of being set to a constant value, appears as an axis 
variable. 

To calculate the solubility of U+ + + + versus pH, for example, move to the Basis pane 
and under “diagram species”, select “U++++”. Leave the activity blank. Under “on axes”, 
set “H+” and units of “pH” for x. For the y axis, select “U++++” and set a range from “-16” to 
“-6”. 
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The Basis pane should look like this 

 

An alternate method would be 

 

Move to the Plot pane to view your diagram. The figure below shows the solubility 
diagram for uraninite versus pH at 25°C: 

diagram U++++ on U++++ vs pH 
x from 0 to 14 
y from -16 to -6 
go 
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You can similarly take steps to draw a diagram showing the solubility of Al+ + + as a 
function of pH at 60°C in the presence of quartz. Reset the configuration (select File → 
Reset Configuration) and move to the Basis pane. Under “diagram species”, select 
“Al+++”. Leave the activity blank. Under “on axes”, set “H+” and units of “pH” for x. Set the 
range from “3” to “8”. For the y axis, select “Al+++” and set a range from “-8” to “-5”.  

Under “in the presence of”, click  and select “SiO2(aq)”, then  Mineral… → 
Quartz. Set temperature to “60°C”. The pane should look like this 
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Move to the Plot pane to view the diagram, which is shown below. 
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5.3 Mosaic diagrams 
Calculating diagrams that include complexing ions is complicated in some cases by the 
speciation of the ions over the diagram axes. For example, while the bicarbonate ion HCO3–  
is important at moderate pH values, it reacts under acidic conditions to form CO2(aq), and 
under alkaline conditions to form CO3– – . Similarly, the sulfate ion SO4– –  occurs in acidic 
waters as HSO4–  and under reducing conditions as H2S(aq), HS–, and S––; NO3–  is found in 
the reduced forms HNO2, NO2– , N2, NH4

+, and NH3; and HPO4– –  reacts depending on pH to 
form H3PO4, H2PO4

– , and PO4– – – . 
In such cases, Act2 can calculate mosaic diagrams in which the overall calculation is 

divided into subdiagrams, in which a single form of a complexing species predominates in 
each. Assembled, the subdiagrams form the complete diagram. The program allows any 
number of complexing ions to speciate. Each ion may speciate by reaction with the 
species on both of the axes, or the x axis or y axis alone. 

Set a mosaic diagram by adding a species to the diagram using the  button on 
the Basis pane in the “in the presence of” section. Then, under the corresponding units 
pulldown, select to speciate that species over x, y, or both x and y. Alternatively, you can 
use the speciate command. 

The following example, using the chemistry of the arsenic-sulfur system, shows the 
importance of the mosaic diagram. Move to the Basis pane and, under “diagram species”, 
select “As(OH)4-”. Set the log activity to “-3”. Under “on axes”, set “H+” and units of “pH” 
for x. For the y axis, select “O2(aq)” and set a range from “-70” to “-40”.  

Under “in the presence of”, click  and select “SO4--”. Set log activity to “-4”, then 
click the pulldown next to log activity and select “speciates over x-y”. Set temperature to 
“100°C”. 
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The pane should look like this 

 

Or use the commands 

 

Move to the Plot pane to view the diagram. The figure below shows a diagram 
predicting the importance of the sulfide minerals orpiment (As2S3) and realgar (AsS) under 
reducing conditions. 

T = 100 C 
diagram As(OH)4- on O2(aq) vs pH 
x from 0 to 14 
y from -70 to -40 
log a As(OH)4- = -3 
log a SO4-- = -4 
speciate SO4-- 
go 
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Interior broken lines show mosaic boundaries for sulfur speciation. Subdiagrams in the 
mosaic, from upper left to lower right, are for the species HSO4– , SO4– – , H2S(aq), HS–, and  
S– –. The basal broken line (black) is the stability limit for water under reducing conditions 
at 1 atm pressure. You can hover with your mouse over any field in the diagram to see the 
species assemblage there as a tooltip, and over any line to see the reaction it represents. 

Note that if we had not made a mosaic diagram but had instead assumed that SO4– –  or 
HS– predominates over the entire diagram, the result would be significantly in error.  

To test the first variation, click the pulldown next to log activity and select “speciates 
over x-y” once again to disable the option. The pane should look like 

 

You could also type 

 

(cont’d) 
unspeciate SO4— 
go 



   Using Act2   109  

 
 

To test the second case, click the  button next to “SO4--” and choose Aqueous… → HS-, 
as shown below, 

 

or type  

 

5.4 Solid solution diagrams 
Act2 can create diagrams accounting for solid solutions in discrete mode (see Solid 

solutions under Configuring the Programs), in which the solution is represented by a 
series of tranches spanning the solution’s range in composition. 

As an example, we diagram an ideal solution of calcite, CaCO3, and rhodochrosite, 
MnCO3. Go to Config → Solid Solutions…, click  under “Define new solid solutions”, 
and expand the selection with the “+” button. Supply a name “Cal-Rds” in the first box, 
choose end-member minerals “Calcite” and “Rhodochrosite”, and set tags “Cal” and 
“Rds”, respectively. Click Apply 

   

Since no step was set, the tranches are spaced by 1/20th of the compositional range. As 
such, the app will construct tranches Cal(.95)-Rds(.05), Cal(.9)-Rds(.1), and so on. 

On the Basis pane, under diagram species, click on “???” and select “HCO3-”. Set “log 
activity” to “-3”. Under “on axes”, set “Ca++” along x with a range from “-5” to “-1”. Along 
the y axis, select “Mn++” and set a range from “-7” to “-3”. Under “in the presence of”, click 

 and select “H+”. Set “pH” for the entry to “7”. The pane should look like  

(cont’d) 
swap HS- for SO4-- 
go 
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Alternatively, use the commands 

 

to configure the calculation. 
Move to the Plot pane to view the diagram, which shows the stability of the solid 

solution as a function of the activity of the substituting ions. You can click within the solid 
solution field “Cal-Rds” to outline the stability of any tranche. Hovering your cursor over 
the tranches reveals its composition in a tooltip, as shown below 

solid_solution Cal-Rds Calcite tag Cal contains \ 
   Rhodochrosite tag Rds  
 
diagram HCO3- on Mn++ vs Ca++ 
x from -5 to -1 increment 1 
y from -7 to -3 increment 1 
log a HCO3- = -3 
pH = 7 
go 
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The tranches are grouped into a stability field and labeled with the solid solution’s name. 
The end members are plotted separately but should not be interpreted as distinct phases. 
The boundary between an end member and the closest tranche is simply a reflection of 
the discretization (“step”) used for the calculation. The line separating “Cal-Rds” from 
“HCO3-” appears to be curved but is in fact composed of a series of short straight 
segments, one per tranche.  

The solid solution has a larger stability field than its pure end-member minerals 
combined, which we can see by suppressing it on the Suppress… dialog or by typing  

 

Reenabling the solid solution, we can compare a non-ideal version by changing the “type” 
pulldown on the Solid Solutions… dialog to “Guggenheim” and setting a hypothetical 
value of “2.2” for the “a0” coefficient, or by typing 

 

(cont’d) 
suppress Cal-Rds 
go 

(cont’d) 
unsuppress Cal-Rds 
solid_solution Cal-Rds Guggenheim a0 = 2.2 a1 = 0 
go 
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In this case, a miscibility gap can be ascertained by a sharp change in curvature of the 
“Cal-Rds” and “HCO3-” boundary, and by the exclusion of one or more adjacent tranches 
within the Cal-Rds stability field. 

Upon close inspection, compositions between Cal(.25)-Rds(.75) and Cal(.75)-Rds(.25) 
are not stable. The miscibility gap is symmetrical about a mole fraction of 0.5, reflecting 
the zero-value assumed for the “a1” Guggenheim coefficient. A positive “a1” value would 
shift the miscibility gap towards rhodochrosite, the second end member. 

In the preceding example, the discrete solid solution was described adequately by 
discretizing the entire possible range. When a solid solution contains trace amounts of an 
end member, you may prefer to limit the range using the “from” and “to” fields. When a 
solid solution has a very large miscibility gap, you might benefit from specifying two solid 
solution entries, as described in Solid solutions under Configuring the Programs. 

5.5 Editing plot appearance 
In Act2 you can interactively modify many aspects of the diagram. A right-click on an 
aspect or area of the plot displays a menu showing the options available. You may choose 
to reset an axis range or an aspect’s appearance to its default state. A double-click on an 
aspect brings up a dialog box related to the first item on the pulldown menu, which in 
most cases is the aspect’s appearance dialog. The dialogs can also be accessed through 
the Format menu. To change the font for individual aspects, choose Font from that 
aspect’s menu. A double-click on the background area will bring up the Quick Toggle… 
dialog, which lets you select the graphical elements to be shown.  
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Right-click on 
plot background 

Right-click on 
plot interior 

Double-click background to 
show Quick Toggle dialog 

Right-click text to 
show menu options 
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A left-click on an aspect causes it to be “selected”. An aspect has been selected when 
its color changes, as in the case of lines, or when it is surrounded by manipulation 
handles, in the case of text or markers. Change the size of text, markers, and the plot itself 
by dragging the sizing cursors. Adjust the placement of the plot by clicking within the plot 
or on either axis and dragging it. The plot title can be moved in the same way. 

Right-click line to 
show menu options 
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You can change the range on an axis by clicking and dragging a tick mark, number, or 
grid line. Dragging a tick within an axis shifts all of the values along the axis, effectively 
changing the minimum and maximum values at the ends of the axis, but keeping the 
spacing the same. Dragging the tick at an end of an axis changes the minimum or 
maximum value. To reset the axis range to span the range of the data being plotted, 
choose Reset Axis Range from the aspect menu. 

You can set all of the graphical attributes in the aspect appearance dialogs available 
through the Format menu. When you make changes to values or selections in an aspect 
appearance dialog, the changes don’t take effect on the plot immediately. You can set up 

Left-click title and 
drag to reposition Left-click edge and 

drag to resize plot 

Left-click to select; 
drag handle to resize 

Left-click axis and 
drag to move plot 

Left-click axis and 
drag to move plot 

Drag inner tick, 
number, or grid line 
to shift axis range 

Drag outer tick, 
number, or grid line 
to scale axis range 
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your choices for as many of the aspects as you like, or use the Reset button to reset the 
dialog to its default values. Use the Apply or OK button to apply the changes to the plot. 
Use the Cancel button if you decide that you don’t want the changes applied. 

Selecting Color → More Colors… from any aspect menu or clicking on any color button 
in an aspect appearance dialog allows you to set the color of the relevant aspect. 

 

The Colors dialog presents a hexagonal palette of colors on the Standard tab. To 
create custom colors, move to the Custom tab.  

 

In either tab, the current color of the aspect is displayed, as is any new selection you 
make. You can click Select… to turn your cursor into a dropper that picks the color from 
any window on your monitor. Once you make a selection, click OK to set the color, or 
Cancel to discard the selection and close the dialog. 

Reset dialog options 
to program defaults 

Left-click button to 
select new color 

Right-click → Color 
→ More Colors… 
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5.6 Reaction traces 
Act2 can overlay onto a diagram the trace of a reaction path calculated with the React 
program. To project the trace of a reaction, first use React, as described in Using React in 
the GWB Reaction Modeling Guide, to calculate the reaction path. React produces an 
output dataset “React_plot.gtp”, which Act2 can read. 

Within Act2, select File → Open → Reaction Trace… to select a “.gtp” file produced by a 
previous React run. After making the selection, the Trace… dialog (which is accessible 
from the Format pulldown menu) can be used to add additional “.gtp” files or remove 
them from the diagram. The dialog shows the status of each selected trace. A “.gtp” file 
will be skipped if, for example, it is incompatible with the axis variables or the 
temperature range of the diagram.  

Use the Trace… dialog to change the default line width and color of a trace, as well as 
the symbol, color, and size (in points) of the markers on the trace. Unique settings for the 
markers at the start or end of the reaction path can be used to indicate the direction of 
reaction progress. Use the checkbox next to each aspect to show or hide it on the diagram.  

After you hit Apply or OK, the program will read the data points and project them onto 
the diagram. Clear a trace file by selecting it and hitting the delete button, or remove all 
files by clicking Reset. 

When multiple “.gtp” files are loaded, check the box labeled “set trace data 
appearance individually” to independently control the appearance of the trace and 
markers for each dataset.  

5.7 Scatter data 
You can overlay the data points in a GSS data sheet (a .gss file) as “scatter data” on your 
Act2 diagram. First, check that the .gss file contains the axis variables on your diagram 
(pH, Eh, pe, species activity, or gas fugacity) or the activities of the original basis entries in 
the thermo dataset, so Act2 can figure these values. Act2 can figure an activity ratio from 
the activity of individual species in your .gss file. 

Remember that Act2 diagrams are plotted in terms of species’ activities and fugacities, 
not chemical concentrations. You can quickly add activities and fugacities to your .gss files 
as “calculated analytes,” as described in the Calculating analytes section of the Using 
GSS chapter in this guide. Alternatively, you can add user analytes for species’ activities, 
fugacities, or activity ratios when these values are known. See the User analytes section 
of the Using GSS chapter in this guide for more information. For an activity ratio such as 
aCa++/aH+

2 , choose the user-defined analyte category “Species activities”, and write the 
analyte’s name as Ca++/H+^2 to match its appearance on the activity diagram. 

Even if your data sheet contains O2(aq) concentration in mg/kg, for example, it would 
have to also include the activity of O2(aq) in order for the data to appear on a log a O2-pH 
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diagram. Add O2(aq) activity to your data sheet as a calculated analyte, separate from the 
dissolved oxygen measurements. 

An example of a .gss dataset containing Act2 scatter data is 

 

Click on File → Open → Scatter Data… to read a .gss file into Act2. After making the 
selection, the Scatter Dialog… dialog (which is accessible from the Format menu) can be 
used to add additional “.gss” files or remove them from the diagram. The dialog shows the 
status of each selected dataset. A “.gss” file will be skipped if, for example, it is 
incompatible with the axis variables or the temperature range of the diagram. 

After you hit Apply or OK, the program will read the data points and project them onto 
the diagram. Clear a scatter dataset by selecting it and hitting the delete button or remove 
all datasets by clicking Reset. 

The marker representing each sample in the scatter data is set in the .gss file. In GSS, 
right-click on a sample to change the marker used and its color and size. When you modify 
a .gss file, the changes will sync with Act2 automatically. To add error bars to the scatter 
points, enter triplets (0.5|2.0|3.5) in the data cells (see Error bars in Using GSS). 

You can label each data point with the sample’s “Sample ID”, as set in the .gss file, and 
display a legend showing the symbols used. In Act2, choose Format → GSS Data… and 
under “Labels” select the checkbox for “Sample” to show sample labels, and the “Legend” 
box to display the legend. Use the Format → Quick Toggle… dialog to quickly toggle on 
and off display of the scatter data, data labels, and legend. 

In GWB releases 7.0 and earlier, the program took scatter data from a specially 
formatted text file, rather than a .gss data sheet. Legacy scatter files are still supported 
and described in the Scatter Data chapter in the GWB Reference Manual. 
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5.8 Act2 command line 
You can start Act2 by clicking the icon under the “Start” menu, opening a “.ac2” file, or 
entering the command act2.exe in the Windows “Command Prompt.” 

When you start Act2 from the command line (as opposed to clicking on the icon), you 
can specify a number of arguments. For example, the command 

 

causes Act2 to read input commands from a file “my_script”, and to use 
“my_thermo.tdat” as the thermodynamic database. 

The following options are available from the command line: 
 
-cd Change the working directory to the directory containing 

the input script specified with the –i option. 

-nocd Do not change the working directory. 

<input_script> 
-i <input_script> 

Set a file from which to read input commands. 

-gtd <gtdata_dir> Set directory to search for thermodynamic datasets. 

-d <thermo_data> Set the thermodynamic dataset. 
 
 

act2 –i my_script –d my_thermo.tdat 
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Using Tact 

Tact is a program that calculates and plots temperature-activity and temperature-fugacity 
diagrams. Diagrams of this type show the effect of temperature on the stability of minerals 
and the predominance of aqueous species in chemical systems. Tact is very similar to 
Act2, except that the vertical axis represents temperature instead of an activity or 
fugacity. 

To diagram, for example, the thermal stability of phosphate species versus pH, you 
follow the same steps you would use in Act2, except that you need not specify a variable 
for the y axis. Under “diagram species” on the Basis pane, click on “???” (or any species 
already there), select “HPO4--”, and then set the species’ log activity to “-3”. Under “on 
axes”, click on “???”, choose “H+” and set units to “pH”. The Basis pane should look like 
this: 

 

Alternatively, enter the commands 

 

diagram HPO4-- vs pH 
a HPO4-- = 10^-3 
x from 0 to 14 
go 
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on the Command pane. Now move to the Plot pane to display the resulting diagram, 
which shows the predominance of phosphate species versus temperature and pH. 

 

The program also produces text output in dataset “Tact_output.txt” (click on 
File → View → Tact_output.txt). 

6.1 Diagram calculation 
Tact, like Act2, can assume any activity or fugacity variable on the x axis and can account 
for the presence of minerals, complexing species, and gas buffers. You might, for example, 
calculate the stabilities of aluminosilicate minerals versus SiO2(aq) activity in a system of 
known ratios aCa++/aH+

2  and aK+/aH+. 
To start, move to the Basis pane. Under “diagram species”, set “Al+++” and then 

 Mineral… → Kaolinite.  
On the x axis, select “SiO2(aq)” and then set the range from “-4.5” to “-1.5”. Set the y-

axis range from “0” to “200”. 
 Under “in the presence of”, click  and select “Ca++”, then click on  Ratio…. 

Set “Ca++” for the numerator and “H+” squared in the denominator with an exponent of 
“2”. Change the unit to “log ratio” and set the value to “10.5”. 
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Next, click  and select “K+”, then click on  Ratio…. Set “K+” for the numerator 
and “H+” in the denominator. Change the unit to “log ratio” and set the value to “3.5”. 

The Basis pane should look like this 

 

Alternative steps are 

 

swap Kaolinite for Al+++ 
swap Ca++/H+^2 for Ca++ 
swap K+/H+ for K+ 
diagram Kaolinite vs SiO2(aq) 
log ratio Ca++/H+^2 = 10.5 
log ratio K+/H+ = 3.5 
x from -4.5 to -1.5 incr 1/2 
y from 0 to 200 
go 



124   GWB Essentials 
 

 
 

Move to the Plot pane to view the diagram of the stability of aluminosilicate minerals 
versus aSiO2 (aq), assuming aK+/aH+ = 103.5 and aCa++/aH+

2  = 1010.5. 

 

To diagram the same system with the SiO2(aq) activity fixed by equilibrium with 
tridymite, and the aCa++/aH+

2  ratio as the axis variable, return to the Basis pane. Move to the 
“in the presence of” section and select “Ca++/H+^2”, then press delete. Under “on axes”, 
click on “SiO2(aq)” and select “Ca++” from the pulldown to take its place, then click 

 Ratio. Set “Ca++” for the numerator and “H+” squared in the denominator with an 
exponent of “2”. Set the x axis to range from “8” to “16”.  
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Now that “SiO2(aq)” has been automatically transferred to the “in the presence of” 
section, select  Mineral → Tridymite. The pane should look like this 

 

Or type the commands 

 

(cont’d) 
diagram vs Ca++/H+^2 
swap Tridymite for SiO2(aq) 
x from 8 to 16 
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Move to the Plot pane to view the diagram. The resulting diagram is shown here. 

 

As a second exercise, diagram the equilibrium point of the souring reaction of natural 
gas 

 
 Anhydrite + CH4(g) → Calcite + H2O + H2S(g) (6.1) 

 
in terms of the fugacity ratio of methane to H2S. Reset the configuration (select 
File → Reset Configuration) and move to the Basis pane. Under “diagram species”, set 
“Ca++” and then  Mineral… → Calcite.  

On the x axis, select “SO4--” and then  Ratio…. Set “H2S(g)” for the numerator and 
“CH4(g)” in the denominator. Set the range from “-15” to “10”. 
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The Basis pane should look like this 

 

Or use the commands 

 

swap Calcite for Ca++ 
swap H2S(g)/CH4(g) for SO4-- 
diagram Calcite vs H2S(g)/CH4(g) 
x from -15 to 10 
go 



128   GWB Essentials 
 

 
 

Move to the Plot pane to view the diagram, which shows the equilibrium point of the 
methane souring reaction, calculated as a function of temperature. 

 

6.2 Solubility diagrams 
To construct a solubility diagram, specify the main species as the x-axis variable. To plot 
the solubility of quartz (in terms of SiO2 activity), for example, set “SiO2(aq)” under 
“diagram species”, and then again under “on axes” as the x-axis variable. Set the log 
activity to range from “-5” to “-1”. 
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The pane should look like 

 

Alternatively, use the commands 

 

Move to the Plot pane to view the diagram. If you suppress quartz using the Config → 
Suppress… dialog 

 

diagram SiO2(aq) vs SiO2(aq) 
x from -5 to -1 
go 
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or by typing 

 

the resulting diagram shows the solubility of the next most stable polymorph, tridymite 
(and a small field for chalcedony at high temperature). Continuing this cycle produces 
plots of the solubilities of each of the silica polymorphs. The figure below shows a 
composite of five Tact diagrams. 

 

6.3 Mosaic diagrams 
Tact, like Act2, can consider complexing ions that speciate over the diagram axes. To 
calculate the stable forms of uranium versus pH in the presence of dissolved phosphate, 
for example, Tact must first consider the speciation of the phosphate ion, which has 
already been calculated (see the example in section 6.1).  

Under “diagram species”, set “U++++” and change the unit from “activity” to “log 
activity”. Set the value to “-10”.  
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(cont’d) 
suppress Quartz 
go 
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On the x axis, select “H+” and set units to “pH”. Under “in the presence of”, click  
and select “HPO4-”. Set log activity to “-3”, then click on the pulldown next to log activity 
and select “speciates over x”. The Basis pane should look like this 

 

The commands are 

 

diagram U++++ vs pH 
x from 0 to 14 
log a U++++ = -10 
log a HPO4-- = -3 
speciate HPO4-- 
go 
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Move to the Plot pane to view the mosaic diagram of the uranium-phosphate system 
versus temperature and pH. 

 

Subdiagrams in mosaic, from upper left to lower right, are for H3P2O7– , H2P2O7– – , HP2O7– – – , 
P2O7– – – – ,  H2PO4

– , HPO4– – , and PO4– – – . You can hover with your mouse over any field in the 
diagram to display the species assemblage there as a tooltip, and over any line to see the 
reaction it represents. 

6.4 Solid solution diagrams 
Tact, like Act2, can draw diagrams accounting for solid solutions in discrete mode. The 
details of constructing such plots are given in the Using Act2 section of this guide. 

6.4 Editing plot appearance 
Tact, like Act2, allows you to interactively modify many aspects of the diagram. The 
details of using active items, aspect menus, and dialogs to edit the plot appearance are 
given in the Using Act2 section of this guide. 
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6.5 Reaction traces and scatter plots 
Tact, like Act2, can project reaction traces and scatter data onto a diagram. These 
features are especially useful for displaying polythermal reaction paths or datasets. The 
details of constructing such plots are given in the Using Act2 section of this guide. 

6.6 Tact command line 
You can start Tact by clicking the icon under the “Start” menu, opening a “.tac” file, or 
entering the command tact.exe from the Windows “Command Prompt.” 

When you start Tact from the command line (as opposed to clicking on the icon), you 
can specify a number of arguments. For example, the command 

 

causes Tact to read input commands from a file “my_script”, and to use 
“my_thermo.tdat” as the thermodynamic database. 

The following options are available from the command line: 
 
-cd Change the working directory to the directory containing 

the input script specified with the –i option. 

-nocd Do not change the working directory. 

<input_script> 
-i <input_script> 

Set a file from which to read input commands. 

-gtd <gtdata_dir> Set directory to search for thermodynamic datasets. 

-d <thermo_data> Set the thermodynamic dataset. 
 

tact –i my_script –d my_thermo.tdat 
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Using SpecE8 

SpecE8 is a flexible program that models the equilibrium states of geochemical systems 
that contain an aqueous fluid. The program calculates the equilibrium distribution of 
aqueous species in a fluid, the fluid’s saturation state with respect to minerals, the 
sorption of aqueous species onto various types of surfaces, and the fugacity and partial 
pressure of gases dissolved in the fluid. 

7.1 Example calculation 
The input file “Freshwater.sp8” equilibrates a hypothetical water sample at 25°C. Double-
click the file, which can be found in the “Scripts” subfolder of the GWB installation 
directory, to launch SpecE8, then move to the Basis pane to see the compositional 
constraints on the hypothetical water. 
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If you were starting from scratch, you would click  and select each of the 
components Na+, K+, Ca++, and so on to add them to the basis, then set appropriate 
constraints and units. You can select from a variety of chemical units using the pulldown 
for each basis entry. 

Alternatively, typing the following commands  

 

configures the same system. 
You do not need to type the unit if it is the same as the unit on the previous line, 

although we will carry units throughout this manual for clarity. The following input is 
equivalent to that above 

 

Na+ = 5 mg/kg 
K+ = 1 mg/kg 
Ca++ = 15 mg/kg 
Mg++ = 3 mg/kg 
Al+++ = 1 ug/kg 
SiO2(aq) = 3 mg/kg 
Cl- = 15 mg/kg 
SO4-- = 35 mg/kg 
HCO3- = 50 mg/kg 
pH = 5 

Na+ = 5 mg/kg 
K+ = 1  
Ca++ = 15  
Mg++ = 3  
Al+++ = 1 ug/kg 
SiO2(aq) = 3 mg/kg 
Cl- = 15  
SO4-- = 35  
HCO3- = 50  
pH = 5 
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You can further set concentrations in elemental equivalents: SO4-- as S, HCO3- as C, 
As(OH)4- as As, and so on. For example, click on the unit pulldown for SO4-- and select 
as → S 

 

rather than as → SO4-- to constrain the mass of sulfur, rather than that of the sulfate 
oxyanion. Set the mass to “12 mg/kg as S”. 

 

Similarly, you can set concentrations in terms of protonated or deprotonated forms of 
the basis entries: HPO4-- as PO4--, NH4+ as NH3, and so on. Click on the unit pulldown for 
HCO3 and select as → CO2(aq) 

 

rather than as → HCO3–. Set the mass to “36 mg/kg as CO2(aq)”. 
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Press the Run button on the Results pane 

 

to calculate the equilibrium species distribution in the fluid. You can alternatively select 
Run → Go from the menubar or type go in the Command pane. 

SpecE8 produces as output a dataset “SpecE8_output.txt” (click on View Results on 
the Results pane, or File → View → SpecE8_output.txt from the menubar) that shows 
calculation results in tabular form, and a dataset “SpecE8_plot.gtp” (click on Plot Results 
on the Results pane) that passes more complete information to the graphics program 
Gtplot. The plot below shows results from the calculation displayed on a Piper diagram. 
Use the Plot menu to control the type and configuration of the plot produced (see the 
section Using Gtplot in this guide). 
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7.2 Equilibrium models 
When SpecE8 calculates a model of a system’s equilibrium state, it uses the input 
constraints you provide to predict the distribution of dissolved species in solution, the 
fluid’s saturation state with respect to various minerals, the amount of species sorbed 
onto any sorbing surfaces you specify, and the fugacity and partial pressure of gases 
dissolved in the fluid. 

For example, to calculate the equilibrium state of seawater in contact with the 
atmosphere, you could assume that the seawater’s oxidation state is controlled by the 
partial pressure of oxygen in the atmosphere and that pH is set by atmospheric carbon 
dioxide. 

To get started, double-click the “Seawater.sp8” input file to launch SpecE8, then move 
to the Basis pane. 

 

To set the atmospheric buffer, O2 and CO2 have been swapped into the basis. If we had 
not done so already, you would click the  button next to the basis entry for “O2(aq)” and 
select Gas… → O2(g), then swap “CO2(g)” for “H+” and set appropriate fugacities for each. 
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The commands below prescribe the same model. 

 

By default, the model calculation assumes that the system contains 1 kg of solvent water. 
Execute the model by pressing the Run button on the Results pane, selecting Run → Go 

from the menubar, or typing go in the Command pane. 
When SpecE8 runs, it reports the imbalance in electrical charge in the system, as 

specified by the input constraints you provide. Alternatively, you can have the program 
adjust the concentration of one component as necessary to achieve an exact ionic charge 
balance, and report the amount of adjustment. To do so, select “Balance on” under the 
unit pulldown menu for the desired basis entry. You could, for example, have the program 
adjust the Cl– concentration. The analytical concentration entered above for Cl– is a 
starting point for iterating to a solution in this case, not a true constraint on the system’s 
composition. 

When you run the preceding calculation, the “SpecE8_output.txt” dataset contains the 
calculation results for seawater, including the concentration of a number of aqueous 
species, the saturation state of various minerals, fugacity and partial pressure of gases, 
and the system’s bulk composition. You can compare the results to the input commands. 
The O2 and CO2 fugacities agree exactly. 

The concentrations of free species such as Na+, however, do not agree with the input 
constraints. This apparent discrepancy occurs because the input sets the total amounts of 
all species containing Na+, not just the Na+  ion. The fluid’s bulk composition, toward the 
bottom of the block, reflects the input. 

To calculate a model in which the presence of a mineral buffers the fluid composition, 
swap the mineral into the basis and specify the mineral’s mass. Continuing in our 

swap O2(g) for O2(aq) 
swap CO2(g) for H+ 
 
Na+ = 10760 mg/kg 
K+ = 399 mg/kg 
Ca++ = 411 mg/kg 
Mg++ = 1290 mg/kg 
SiO2(aq) = 6 mg/kg 
Cl- = 19350 mg/kg 
SO4-- = 2710 mg/kg 
HCO3- = 142 mg/kg 
 
f O2(g) = 0.2 
log f CO2(g) = -3.5 
go 
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example, click the  button next to the basis entry for “SiO2(aq)” and select Mineral… → 
Quartz, then set “1” free cm3 in the system. 

The Basis pane should look like this 

 

If you are working from the Command pane, continue by typing 

 

In this example, the system contains 1 kg solvent, various solutes, and 1 cm3 of the mineral 
quartz. The amount of free quartz in the system does not affect the fluid composition, as 
long as some small amount of the mineral is present. 

It is important to understand the difference between bulk and free constraints on the 
system’s composition. In the previous example, the input constrains components Na+, 
Mg+ +, and the others to a bulk number of mg/kg. The value for Na+ includes the sodium 
present in each of the dissolved species: Na+, NaSO4

– , NaCl, NaHCO3, etc. Only by 

(cont’d) 
swap Quartz for SiO2(aq) 
1 free cm3 Quartz 
go 
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specifying units of free mg/kg would you constrain the Na+ ion alone. In contrast, pH is a 
free constraint, since it applies only to the free hydrogen ion, H+. Settings for the O2 and 
CO2 fugacities similarly serve as free constraints. 

The bulk amount of quartz in the system, by the same reasoning, includes the mineral 
quartz plus the silica dissolved in solution as species such as SiO2(aq). The commands in 
the example specify 1 cm3 of free quartz (i.e., the silica present as the mineral quartz 
itself). Mineral buffers generally should be set as free constraints instead of bulk values. 

When setting the concentration or activity of species, the mass of minerals, or the 
fugacity or partial pressure of gases in the Basis pane, it is important to avoid 0 (zero) 
values, as these will prevent the GWB programs from solving for the distribution of mass. 
Where the concentration of a particular component is negligible, set a small positive 
value. Log values, such as log activity, pH, pe, or Eh, however, can be set to 0. 

SpecE8 recognizes a number of units for constraining a system’s composition besides 
those introduced so far. Most of these can be applied either as bulk constraints or as free 
constraints by preceding the unit name with the word free. Table 7.1 lists the units 
recognized by the program. 

 

Table 7.1 Units for specifying the composition of the initial system 

By mass or volume (free or bulk): 

mol mmol umol nmol  

kg g mg ug ng 

eq meq ueq neq  

cm3 m3 km3 l  

By concentration (free or bulk): 

mol/kg mmol/kg umol/kg nmol/kg  
molal mmolal umolal nmolal  

mol/l mmol/l umol/l nmol/l  

g/kg mg/kg ug/kg ng/kg  

wt% wt fraction    

g/l mg/l ug/l ng/l  

eq/kg1 meq/kg1 ueq/kg1 neq/kg1  

eq/l meq/l ueq/l neq/l  
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By carbonate alkalinity (applied to bicarbonate component): 

eq_acid meq_acid ueq_acid neq_acid  

eq_acid /kg meq_acid /kg ueq_acid /kg neq_acid /kg  

eq_acid /l meq_acid /l ueq_acid /l neq_acid /l  

g/kg_as_CaCO3 mg/kg_as_CaCO3 ug/kg_as_CaCO3 ng/kg_as_CaCO3  

wt%_as_CaCO3     

g/l_as_CaCO3 mg/l_as_CaCO3 ug/l_as_CaCO3 ng/l_as_CaCO3  

mol/kg_as_CaCO3 mmol/kg_as_CaCO3 umol/kg_as_CaCO3 nmol/kg_as_CaCO3  

mol/l_as_CaCO3 mmol/l_as_CaCO3 umol/l_as_CaCO3 nmol/l_as_CaCO3  

By activity or redox state (free constraints): 

activity fugacity ratio   
pH V pe   

Relative to system bulk volume: 

volume% vol. frac. (any unit)/cm3 (any unit)/m3  

By ionic charge balance (a bulk constraint): 

balance     
1Expressed per kg solvent. 

7.3 Redox disequilibrium 
Redox reactions in natural waters, especially at low temperatures, cannot always be 
assumed to approach thermodynamic equilibrium. For this reason, you may want to 
calculate a model in which redox reactions are in a state of disequilibrium. You control the 
extent to which SpecE8 honors redox equilibrium when calculating a chemical model by 
interactively enabling and disabling redox coupling reactions (see Redox couples in the 
Configuring the Programs chapter of this guide). 

The coupling reactions, when enabled, prescribe redox equilibrium between species of 
differing oxidation states. You use the Config → Redox couples… dialog (or the 
decouple and couple commands) to control coupling between a redox species and a 
basis species. Table 2.2 shows the relationships among redox and basis species. 
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As an example, double-click the “Redox.sp8” input file to launch SpecE8, then move to 
the Basis pane. 

 

The input configures a model of a fluid of a certain pH, Eh, and major ion composition, as 
shown above. 
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Open the Config → Redox couples… dialog 

 

and note the decoupled redox pairs. Disabling the redox couples between ferric and 
ferrous iron and between trivalent and pentavalent arsenic [i.e., basis species AsO4

– – –  and 
As(OH)4

– ] causes the program to consider that oxidized and reduced iron and arsenic 
species exist in quantities not related to the value entered for Eh. Other redox couples, 
such as between HS– and SO4

– – , remain enabled and will reflect the specified Eh. 
By nature, you need more information to constrain a model of a fluid in redox 

disequilibrium than you do for an equilibrium model. As you can see on the Basis pane in 
the example above, separate constraints are required for the oxidized and reduced forms 
of iron and arsenic. Analytical values constrain the fluid’s total Fe+ +, AsO4

– – – , and As(OH)4
–  

content, and the amount of ferric iron in the fluid is controlled by equilibrium with 
hematite. 

In the calculation results (in “SpecE8_output.txt”), SpecE8 honors mass balance and 
mass action among ferric species and among ferrous species, but ferric species do not 
exist in equilibrium with ferrous species. Similarly, the program honors equilibrium among 
oxidized and reduced arsenic species, but not between oxidation states. 

Whenever there are two or more independent redox couples in a run, SpecE8 reports in 
“SpecE8_output.txt” the theoretical oxidation state of each couple. In this example, the 
couples and corresponding Nernst Eh and pe values are: 

 

 Eh (volts) pe 

e– + 1
4⁄  O2(aq)+ H+ ⇆ 1

2⁄  H2O    0.400   6.762 

2 e– + 4 H+ + AsO4
––– ⇆ As(OH)4–    0.081   1.362 

e– + Fe+++ ⇆ Fe++ –0.002 –0.035 
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The first line reflects the Eh specified as an input constraint. The second and third lines 
show the oxidation states calculated from the activities of arsenic and iron species. The 
differences in oxidation state reflect the extent of redox disequilibrium in the solution. 

7.4 Activity coefficients 
SpecE8 can employ two broad methods to calculate activity coefficients for the aqueous 
species—variations of the Debye-Hückel equation and virial methods—depending on the 
thermodynamic dataset in use. The methods are also known as “ion association” and “ion 
interaction” approaches, respectively. 

Most commonly, the program uses the “B-dot” equation, an extended form of the 
Debye-Hückel equation described by Helgeson (see Further Reading). This method, which 
assigns a coefficient to each species in solution, is a general formulation that can be 
applied to a range of natural waters, including dilute fluids and dominantly Na–Cl 
solutions with ionic strengths of up to about 3 molal. This method is not especially 
accurate, however, at ionic strengths greater than about one-half molal. 

In this method, species’ activity coefficients are calculated by using the solution’s ionic 
strength, and the water activity is calculated from the stoichiometric ionic strength. 
Because coefficients for the method have been correlated to ionic strengths of 3 molal, 
SpecE8 limits the ionic strength values it uses in calculating activities. For species 
activities, it uses the value of the actual ionic strength or the value of variable “timax”, 
whichever is lowest. It normally calculates the water activity using the lower value of the 
stoichiometric ionic strength or variable “simax”. Variables “timax” and “simax” are 
initially set to “3” molal, but you can change them (see Settable variables in this section) 
on the Config → Iteration… dialog. 

 

SpecE8 can also emulate the activity coefficient calculations used in the MINTEQ, 
PHREEQC, and WATEQ4F software packages. These packages use Debye-Hückel based 
methods, such as the Truesdell-Jones and Davies equations, that are similar but not 
identical to the B-dot method described above. Consult the MINTEQ, PHREEQC, and 
WATEQ4F documentation for information about the ranges in temperature and ionic 
strength over which these calculations can be reliably applied. 
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Special options for calculating the activity of water and the activity coefficients of 
neutrally charged aqueous species in the various Debye-Hückel methods are described in 
the Thermo Datasets chapter of the GWB Reference Manual. 

Virial methods provide an alternative technique for determining activity coefficients 
that can be applied to concentrated waters. The techniques employ expressions similar to 
the Debye-Hückel equation, but with extra terms that represent interaction among the 
solution components. The virial coefficients that appear in the extra terms have been 
determined empirically by statistical regression of a body of experimental data. 

SpecE8 makes use of a virial technique known as the Harvie-Møller-Weare (or H-M-W) 
method, a formalism of the “Pitzer equations” (see a reference by these authors in Further 
Reading). The H-M-W method may be used at very high ionic strength, but extra care 
should be taken because of the empirical nature of the virial techniques. Virial methods 
can give misleading results for fluids that differ in composition from those in the 
experiments used to regress the coefficients. 

Projecting the methods to elevated (or lowered) temperatures also requires caution 
because the model coefficients were derived largely from the results of experiments 
conducted at 25°C. In addition, the methods treat solutes in bulk without attempting to 
predict their distribution among the various aqueous species. Virial methods, nonetheless, 
commonly predict saturation states for concentrated solutions that are considerably more 
accurate than those calculated by the Debye-Hückel method. 

The H-M-W method requires its own databases, six of which—“thermo_hmw.tdat”, 
“thermo_phrqpitz.tdat”, “thermo_ymp.R2.tdat”, “THEREDA_2021_GWB.tdat”, 
“thermo_frezchem.tdat”, and “thermo_coldchem.tdat”—are included in the software 
release. Database “thermo_hmw.tdat” contains data from the Harvie-Møller-Weare 
compilation. This compilation contains data at only 25°C and should not be employed at 
any other temperature. 

The “thermo_phrqpitz.tdat” dataset contains an expanded version of the H-M-W 
database, as implemented in the PHRQPITZ geochemical model (see Further Reading). 
This dataset includes more components than the H-M-W version and provides some 
capability for temperature extrapolation. The data for temperature extrapolation, 
however, is not complete; it is important to read the PHRQPITZ documentation carefully 
before working at temperatures other than 25°C. Table 7.2 lists the basis species available 
in “thermo_hmw.tdat” and “thermo_phrqpitz.tdat”. 

Datasets “thermo_ymp.R2.tdat” and “THEREDA_2021_GWB.tdat” are the Yucca 
Mountain Project  and THEREDA Project’s compilations, each of which invokes the H-M-W 
activity model. The former dataset is based on the data0.ypf.R2 data file from EQ3/6. The 
two datasets contain more chemical components than “thermo_hmw.tdat”, and include 
provision for extrapolating the data for many of the components to temperatures other 
the 25°C. Before applying any Pitzer dataset at temperatures other than 25°C, you should 
study its documentation (see Further Reading) carefully. 
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The “thermo_frezchem.tdat” dataset is based on data from the FREZCHEM program, as 
set out by Toner and Sletten in the PhreeqC data file frezchem.dat (see Further Reading). 
The dataset contains a component set similar to “thermo_hmw.tdat”, and can be applied 
at 25°C, but is designed to be carried down to temperatures well below the freezing point 
of pure water. The “thermo_coldchem.tdat” dataset is another H-M-W parameterization 
for very low temperature applications, from Toner and Catling (see Further Reading). It is 
based on the PhreeqC data file ColdChem.dat. The dataset is for the Na-K-Ca-Mg-Cl-SO4 
system, and may be valid down to 200 K or below. As always, you should study details of 
their temperature dependence (see Further Reading) carefully. 

SpecE8 can also use the Specific ion Interaction Theory (SIT) activity model, a virial 
technique significantly simpler in form than the Pitzer equations (see a reference for the 
method by Grenthe et. al. in Further Reading). Common implementations of the SIT 
method carry more ion pairs and complexes than many Pitzer compilations. The method 
is accurate to higher ionic strengths than the Debye-Hückel equations, but not to the 
salinities achievable using the Pitzer equations.  

The “thermo_sit.tdat” dataset is the ThermoChimie project’s database (version 10a) 
invoking the SIT method, and “thermo_nea.tdat”, from the Nuclear Energy Agency 
(version 1.0), uses the same method. See reference by Giffaut et. al. in Further Reading for 
the ThermoChimie database, and by Lemire et. al., along with earlier volumes in the 
series, for the NEA Thermochemical Database. 

 

Table 7.2 Basis species in the H-M-W and PHRQPITZ databases 

Harvie-Møller-Weare 

H2O H+ Mg++ 

Ca++ HCO3- Na+ 

Cl- K+ SO4- 

PHRQPITZ   

H2O Fe++ Mn++ 

B(OH)3 H+ Na+ 

Ba++ HCO3- SO4- 

Br- K+ Sr++ 

Ca++ Li+  

Cl- Mg++  
 
To use the H-M-W method, go to File → Open → Thermo Data… and select database 

“thermo_hmw.tdat”, or enter the command 
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Similarly, selecting “thermo_phrqpitz.tdat” invokes the PHRQPITZ database.  
To use the SIT method, select “thermo_sit.tdat” or type 

 

to load the ThermoChimie database, or use “thermo_nea.tdat” for the NEA database. 
The dataset “thermo.tdat”, which you can invoke with the command 

 

returns the program to the default method for calculating activity coefficients. 
In the following example, we use the Debye-Hückel B-dot and H-M-W methods to 

calculate the saturation index of halite in a groundwater sampled from an evaporite bed. 
Double-click the “HMW.sp8” input file to launch SpecE8. The program moves to the 
Results pane automatically, as shown below. 

 

The example is set up to perform multiple calculations automatically, so take a look at 
the results from the first calculation (“SpecE8_output.txt” and “SpecE8_plot.gtp”) before 
continuing the simulation. These results show the log Q/K of halite for the B-dot extended 
Debye-Hückel method. To compare with the Harvie-Møller-Weare method, hit Yes to 
continue the simulation. The program will load “thermo_hmw.tdat” 

read thermo_hmw.tdat 

read thermo_sit.tdat 

read thermo.tdat 
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and repeat the calculation. With your original results still open, double-click on the new 
results files to compare the calculations side-by-side. 

The calculations give the results 
 

 log Q/K 
Debye-Hückel B-dot -0.94 
Harvie-Møller-Weare  0.02 

7.5 Gas partial pressure 
SpecE8 calculates the fugacity coefficients ϕi that relate the fugacity fi of a gas i to its 
partial pressure Pi, where fi = ϕi Pi, according to one of three models: Tsonopoulos, Peng-
Robinson, and Spycher-Reed. Details of the three models are given in references listed 
under Gas partial pressure. 

The program by default uses the pressure model identified in the header section of the 
thermo dataset in use. Most of the databases distributed with the software set the default 
model to Tsonopoulos, although the PhreeqC, Wateq, and Cemdata18 databases set 
Peng-Robinson. You can, nonetheless, set an alternative pressure model on the Config → 
Options… dialog, or with the press_model command. 

7.6 Solid solutions 
SpecE8 can incorporate into its calculations any number of binary solid solutions, each in 
either continuous or discrete mode (see Solid solutions in the Configuring the Programs 
chapter of this guide). To model equilibrium with a continuous solid solution, you swap its 
end members into the basis and constrain the mass of each. SpecE8 will determine the 
equilibrium fluid composition, reflecting the basis constraints you set. 

A solid solution has a saturation state, whether present in the basis or not. For each 
continuous solid solution, SpecE8 will determine the composition at which the solution is 
most saturated, along with the saturation index at that composition. 

Suppose we wish to determine the composition of a fluid in equilibrium with a 
plagioclase solid solution. We could define a solution “Plag” composed of end members 
albite (tag “Ab”) and anorthite (“An”). We would then swap Plag::Ab for “Na+” and 
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Plag::An for “Ca++”, and constrain the free mass of each end member. Equivalent 
commands might be 

 

If you were to swap only one of a solid solution’s end members into the basis, SpecE8 
would treat it as a pure mineral. The amount of each end member, furthermore, is 
required, since SpecE8 figures mole fractions from free masses of the end members, and 
the end member activities follow from the mole fractions. 

SpecE8 reports the calculation results to a plot file “SpecE8_plot.gtp”, where it is 
available for diagramming with Gtplot. Output there includes end member masses, 
saturation states of the solid solutions considered (as well as any binodal points they may 
contain), and the resulting fluid composition. Calculation results are available as well in 
the text-format dataset “SpecE8_output.txt”. The text file includes additional information 
about solid solutions, including total masses and the mole fractions, activity coefficients, 
and end member activities.  

In a discrete model, SpecE8 calculates saturation indices of each tranche considered in 
the solid solution. The end members’ activity coefficients are folded into the tranches’ log 
Ks, so the model treats tranches as if they were pure minerals. You can constrain a run by 
swapping a tranche in place of a single basis entry. For example, 

 

To approximate the continuous model previously considered, in which equilibrium with 
the solution constrains two basis entries, set a fine “step” before swapping two adjacent 
tranches into the basis 

solid_solution Plag Albite tag Ab contains Anorthite tag An 
swap Plag::Ab for Na+ 
swap Plag::An for Ca++ 
3 free mmol/kg Plag::Ab 
7 free mmol/kg Plag::An 

(cont’d) 
solid_solution Plag discrete  
swap Ab(.3)-An(.7) for Na+ 
10 free mmol/kg Ab(.3)-An(.7) 
Ca++ = 1 mg/kg 
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and rerunning the calculation. 
To complete a fully worked example (“SSoln.sp8”), we model a fluid in equilibrium with 

a solid solution of calcite and rhodochrosite, using a continuous implementation. First, 
configure the solution on the Config → Solid Solutions… dialog 

 

The single Guggenheim coefficient sets up a regular solution of the carbonate minerals. 
On the Basis pane  

 

(cont’d) 
solid_solution Plag step .01 
swap Ab(.3)-An(.7) for Na+ 
swap An(.31)-An(.69) for Ca++ 
5 free mmol/kg Ab(.3)-An(.7) 
5 free mmol/kg Ab(.31)-An(.69) 
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swap the two end members into the system and constrain the mass of each. As shown, 
SpecE8 is set to find the equilibrium fluid composition when the mole fraction XCalcite of 
calcite in the solid solution is 0.9. To work this problem from the Command pane instead, 
enter the commands 

 

In either case, move to the Results pane, click  and choose View → Results to 
examine the calculation results. 

Since the solid solution’s end members were set in equilibrium with the fluid, the 
solution’s saturation index is zero. The minerals corresponding to the end members, in 
contrast, are undersaturated in the fluid, reflecting the greater stability of the solid 
solution relative to its pure components. The calculation predicts a log activity ratio for 
Ca++/Mn++ of ~4. As an exercise, how would this value change if the solution were ideal? If 
it were replaced in the basis by the pure end member minerals? 

7.7 Sorption onto mineral surfaces 
SpecE8 can model the sorption of species from solution onto mineral surfaces according 
to a number of methods (see Sorption onto mineral surfaces in the Configuring the 
Programs chapter of this guide). To consider sorption in your SpecE8 calculation, drag a 
surface reaction dataset into the SpecE8 window, or use the File → Open → Sorbing 
Surfaces… (or Config → Sorbing Surfaces…) dialog  

 

(or the surface_data command) to point to a dataset for the surface of interest. 
Notably, you may load any number of surface datasets, describing reaction at any number 
of surfaces, in a single run and they will be considered simultaneously in your calculations. 

solid_solution Cal-Rds Calcite tag Cal contains \ 
   Rhodochrosite tag Rds Guggenheim a0= -3.2  
 
swap Cal-Rds::Cal for Ca++ 
swap Cal-Rds::Rds for Mn++ 
Cal-Rds::Cal = .9 free mmol/kg 
Cal-Rds::Rds = .1 free mmol/kg 
pH = 7 
balance on HCO3- 
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To disable consideration of a surface complexation dataset, highlight the dataset on 
the Sorbing Surfaces... dialog and press the  button, or type the command 

 

To disable all loaded datasets, select all of the datasets on the Sorbing Surfaces… dialog 
and press the  button, or type the command 

 

7.7.1 Surface complexation 
SpecE8 can account for surface complexation according to any of the methods supported 
by the GWB, including the two-layer, triple-layer, and CD-MUSIC models. To invoke surface 
complexation, simply load the dataset or datasets of interest. 

Dataset “FeOH.sdat”, for example, describes sorption onto the surface of hydrous ferric 
hydroxide according to the two-layer surface complexation model. Adding this dataset, as 
described above, causes the program to consider surface complexation whenever a 
hydrous ferric hydroxide mineral such as Fe(OH)3 precipitate, goethite, or hematite 
appears in the system. 

To trace an example, double-click on the “Surface.sp8” input file to launch SpecE8, 
then move to the Basis pane. 

surface_data remove <dataset> 

surface_data off 
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This input sets up a model of a dilute fluid coexisting with a ferric hydroxide surface. The 
program calculates the sorbing surface area from the amount of mineral present (1 g) and 
the specific surface area given in “FeOH.sdat” (600 m2/g). 

The compositional constraints apply to species in the fluid, excluding those sorbed 
onto the surface, unless you specify otherwise by checking “sorbate” on the 
Config → Options… dialog 
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or with the sorbate command (see SpecE8 Commands in the GWB Command 
Reference). In the example above, the fluid contains 2.4 mg/kg Ca++, 15 mg/kg SO4--, etc.; 
the mineral surface will be in equilibrium with the fluid and hence contain sites with 
additional amounts of calcium, sulfate, and so on. 

SpecE8 writes the calculated sorbing surface area, surface charge density, mean 
surface potential, mole numbers of the surface species, and the sorbed fractions of each 
component into the text-format dataset “SpecE8_output.txt”, as well as 
“SpecE8_plot.gtp”, where it is available for plotting with Gtplot. In this example, Ca+ + and 
Ba+ +  are sorbed only weakly, whereas Zn+ + and SO4

– –  sorb rather strongly. 
Several datasets (“FeOH.sdat”, “FeOH+.sdat”, and “FeOH_minteq.sdat”) describing 

surface complexation on hydrous ferric oxide are included in the software release, along 
with datasets for goethite and gibbsite, but you can prepare additional datasets for other 
surface types. You can also invoke more than one dataset in a single SpecE8 calculation. 
For example, if you have prepared a dataset “SiOH.sdat” to describe sorption onto silica, 
adding both “FeOH.sdat” and “SiOH.dat” with the File → Open → Sorbing Surfaces… 
dialog or the commands 

 

causes SpecE8 to account for sorption onto both ferric and silica surfaces. 
The constant capacitance and constant potential models are variants of the surface 

complexation model. You set these models from the Config → Sorbing Surfaces… dialog, 
or using the surface_capacitance and surface_potential commands (see 
Constant capacitance model and Constant potential model in the Configuring the 
Programs chapter of this guide). 

7.7.2 Ion exchange 
As described in the Configuring the Programs chapter of this guide (see the Ion exchange 
section), you can model ion exchange in two ways. The first method is to swap an activity 
ratio into the basis. This method is equivalent to assuming that there exists a sufficiently 
large reservoir of exchanging ions that the composition of the exchanging surface remains 
invariant. 

Once you have swapped the activity ratio into the basis, constrain its value. For 
example, in the Basis pane, select  → Ratio… and set the ratio aCa++/aNa+

2  to “0.2”, or 
follow the steps 

 

surface_data FeOH.sdat 
surface_data SiOH.sdat 

swap Ca++/Na+^2 for Ca++ 
ratio Ca++/Na+^2 = 0.2 
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For a more general treatment of ion exchange, prepare a small dataset of the exchange 
reactions to be considered, using file “IonEx.sdat” as a template. Load the dataset of 
exchange reactions with the File → Open → Sorbing Surfaces… dialog, or the 
surface_data (or read) command 

 

You can load one or more exchange datasets (containing one or more exchange 
reactions) at a time, and in a single run combine ion exchange datasets with other types of 
surface reaction datasets. 

SpecE8, in its calculations, maintains a mass balance on the exchanging sites and 
reports the composition of the exchanging surface. You must, therefore, specify the 
exchange capacity in the modeled system. On the Sorbing Surfaces… dialog, enter the 
value and hit Apply 

 

or use the exchange_capacity command

 

You can set the exchange capacity (i.e., the CEC or AEC) in terms of either the total 
number of charge equivalents in the system (eq, meq, and so on), or the number of 
equivalents per gram of mineral (eq/g, …). In the latter case, the program determines the 
total mineral mass in the system, including equilibrium and kinetic minerals and end 
members, and unreactive or inert minerals in the system, to calculate the total exchange 
capacity. You set inert volume with the inert command, or on the Medium pane; inert 
minerals are taken to have a density 2.65 g/cm3. 

As an example of a SpecE8 calculation accounting for an ion exchange reaction, 
double-click on the “IonEx.sp8” input file to launch SpecE8. Go to the Config → Sorbing 
Surfaces… dialog  

surface_data MyIonEx.sdat 

exchange_capacity = 10 meq/g 
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to confirm that you’ve loaded IonEx.sdat, a surface dataset of ion exchange reactions, and 
to see the value assumed for the surface’s exchange capacity. 

Move to the Basis pane 

 

to see the composition of the fluid. In this example, the amount of Na+ and Ca++  in 
solution controls the composition of the exchanging surface. 

7.7.3 Distribution coefficients (Kd) 
To set up a calculation considering sorption described by Kd, read one or more datasets 
containing distribution coefficients for sorption reactions from the File → Open → Sorbing 
Surfaces… dialog, or using the surface_data command (see Distribution 
coefficients (Kd) in the Configuring the Programs chapter of this guide). You prepare the 
datasets using “Kd.sdat” as a template file. 

Unlike the other sorption methods, this approach carries the sorbed concentration in 
moles per mass solid, rather than liquid phase. It is important in configuring a SpecE8 
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calculation, therefore, to specify carefully the mass of minerals in the system. Minerals 
include equilibrium and kinetic minerals and end members, as well as the unreactive or 
inert volume. You specify inert volume (in cm3) with the inert command, or on the 
Medium pane (the program converts this value to mass, assuming a density of 2.65 g/cm3). 

As an example of using the distribution coefficient method to model ion sorption in 
SpecE8, double-click on the “KD.sp8” input file. When SpecE8 opens, go to the Config → 
Sorbing Surfaces… dialog  

 

to confirm that you’ve loaded the Kd.sdat sorption dataset. 
Move to the Medium pane  

 

to see the volume of minerals in the system. The Basis pane 
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describes the fluid. In this case, the program models a system including a fluid containing 
10 𝜇𝜇g/kg Pb++ in contact with minerals onto which a considerably greater mass of the ion 
is predicted to be sorbed. 

7.7.4 Freundlich isotherms 
To describe sorption in terms of Freundlich isotherms (see Freundlich isotherms in the 
Configuring the Programs chapter of this guide), prepare a dataset of sorption reactions 
following the format of file “Freundlich.sdat”. The procedure is otherwise parallel to the Kd 
approach, as described in the previous section. 

Continuing the example above, use Config → Sorbing Surfaces… to select the 
“Kd.sdat” file and click the  button, then hit Apply  

 

then click  and select “Freundlich.sdat” from the Gtdata folder within the GWB 
installation directory  
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or use the steps 

 

to implement the Freundlich model in place of the Kd approach. Alternatively, double-click 
on the “Freundlich.sp8” input file to load the example directly. 

7.7.5 Langmuir isotherms 
To model sorption according to Langmuir isotherms, prepare a reaction dataset 
containing the sorbing reactions and their equilibrium constants, as described under 
Langmuir isotherms in the Configuring the Programs chapter of this guide. Prepare 
the dataset in the format of file “Langmuir.sdat”. 

Enter the dataset into a SpecE8 run, as above. You can enter one or more Langmuir 
datasets, and mix Langmuir datasets with datasets for other sorption methods. As with 
the ion exchange method, specify the total number of sorbing sites in either absolute 
terms (mol, mmol, ...) or per gram of dry sediment (mol/g, mmol/g, ...). Enter the sorption 
capacity on the Sorbing Surfaces… dialog, or with the exchange_capacity 
command. 

As an example, double-click on the “Langmuir.sp8” input file. When SpecE8 opens, go 
to the Config → Sorbing Surfaces… dialog  

  

to confirm that you’ve loaded Langmuir.sdat, an example surface dataset, and to see the 
value assumed for the surface’s exchange capacity. 

surface_data remove Kd.sdat 
surface_data Freundlich.sdat 
go 
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Move to the Basis pane 

 

to see the composition of the fluid. 
SpecE8 accounts for the sorption of Ca+ + and Sr+ + according to the Langmuir 

isotherms in the example dataset “Langmuir.sdat”. 

7.8 Fractionation of stable isotopes 
SpecE8 can figure the equilibrium fractionation of stable isotopes among solvent, 
aqueous and surface species, minerals, end members, and gases. To define an isotopic 
system, set the bulk isotopic composition of the fluid, either from the Config → Isotopes… 
dialog or the Command pane. The Isotopes… dialog lists the isotope systems included in 
the isotope fractionation file loaded into the program (see Isotope fractionation datasets 
in the Configuring the Programs chapter of this guide). The “isotope.dat” file, distributed 
with the software, contains coefficients for calculating fractionation factors of stable 
isotopes 2H, 13C, 18O, and 34S as functions of temperature.  

To configure a SpecE8 run, specify compositions relative to any isotopic standard, 
including SMOW, PDB, or CDT. The program predicts isotopic compositions for species, 
minerals, end members, and gases relative to the same standard, and writes the results to 
the dataset “SpecE8_isotope.txt”, as well as to “SpecE8_plot.gtp”, where it is available for 
plotting by Gtplot. 
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The program begins by calculating the compositions of solvent and dissolved species 
to honor the fluid’s bulk composition, as specified, assuming isotopic equilibrium among 
species. The program then sets minerals and end members in the system and any buffered 
gases to isotopic compositions in equilibrium with the fluid. 

As an example (file “Iso.sp8”), we calculate the isotopic composition of calcite (CaCO3) 
and CO2(g) in equilibrium with a Ca-HCO3 water for which δ13C = 0‰ and δ18O = −6‰. 
Begin by setting the water composition on the Basis pane  

 

or enter the commands 

 

pH      = 9 
Ca++    = .2 mmol/kg 
swap Calcite for HCO3- 
Calcite = 1 free cm3 
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Next, move to the Config → Isotopes… dialog 

 

to set the δ13C and δ18O for the fluid, or issue the commands 

 

Move to the Results pane, click , then choose View → Results → Isotopic to 
display results of the calculation. 

In output, we see the δ13C of calcite in isotopic equilibrium with the fluid is 2.8‰, and 
δ18O is 22.6‰. For CO2(g), δ13C is −7.6‰ and δ18O is 34.5‰. Owing to hydration effects, the 
carbon isotopic composition of the dissolved carbonate and bicarbonate species is higher 
than CO2(aq). In terms of 18O, in contrast, dissolved carbon dioxide is heavier than the bulk 
fluid. 

7.9 Settable variables 
SpecE8 allows you to alter the values of certain variables carried in the calculation. 
Table 7.3 lists these variables and their units and default values. To change a variable, 
type the new value in the Config → Iteration… dialog box, on the Basis pane (click  to 
expand the “advanced” section), on the Medium pane, or enter as a command the 
variable name followed by the new value. 

carbon-13 =  0 
oxygen-18 = -6 
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Table 7.3 Settable variables, their units and default values 

Pane or Dialog Variable Default Unit Description 

Basis density not set g/cm3 Density of initial fluid. 

 TDS not set mg/kg Total dissolved solids, initial 
fluid. 

Medium inert 0 cm3 Volume of inert minerals in 
system. 

Iteration epsilon 5 x 10–11 – Convergence criterion. 

 itmax 999 – Allowed number of iterations. 

 pitz_dgamma 0.1 – For virial activity coefs., 
maximum fractional change 
per iteration. 

 pitz_precon 10 – For virial activity coefs., 
maximum number of pre-
conditioning steps. 

 pitz_relax 0.5 – For virial activity coefs., 
relaxation factor during 
iteration. 

 simax 3 Molal Maximum stoichiometric 
ionic strength used to 
calculate water activity 
(Debye-Hückel model). 

 timax 3 Molal Maximum true ionic strength 
used to calculate activity 
coefficients (Debye-Hückel 
model). 

 
Examples: 

 

The value given must be in the units carried internally by the program, as listed in 
Table  7.3. 

itmax = 1000 
epsilon = 10^-9 
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To restore a variable to its default value, enter a blank field in the dialog box, or on the 
Command pane type its name without a value or followed by a ?: 

 

Current values of the variables can be viewed at any time by looking at the dialog box, the 
Basis or Medium pane, or using the command show variables. 

7.10 Controlling the printout 
SpecE8 lets you control the amount of detail presented in the calculation results written 
to “SpecE8_output.txt”. The dataset is known commonly as the “printout”, although it 
need never be printed. The printout can contain information about (1) the concentration 
and activity of dissolved species, (2) the saturation indices of various minerals, (3) gas 
fugacity and partial pressure, (4) surface complexes, and (5) the system’s bulk 
composition in terms of elements of either the current or original basis. The printout can 
also contain a list of the chemical reactions considered in the calculation, and their initial 
log Ks, as well as initial values of virial coefficients. 

You can specify that any of these lists be excluded from the printout, or included in a 
short or long format. To vary the printout, the user can set each aspect in Table 7.4 to 
“none”, “short”, or “long” on the Config → Output… dialog, or in a command. For 
example: 

 

The current print settings can be viewed at any time by looking at the three-way check 
boxes on the Config → Output… dialog. A blank check box  indicates exclusion from the 
printout, a check  indicates inclusion in short format, and shading  indicates 
inclusion in long format. 

itmax 
itmax = ? 

print species = long 
print basis = short 
print saturations = none 
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Alternatively, type 

 

 

Table 7.4 Print options and default settings in SpecE8 

 Default Description 

print dataset on to “SpecE8_output.txt” 

print alphabetically off Arrange entries in dataset alphabetically 

species long Aqueous species 

surfaces long Surface complexes 

saturations long S.I. of minerals and solid solutions 

gases long Gas fugacity and partial pressure 

basis none Composition, current basis 

orig_basis long Composition, original basis 

elements long Elemental composition 

reactions none Reactions and log Ks, and virial coefficients 

stagnant none Composition of stagnant zone 

show printout 
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7.11 SpecE8 command line 
You can start SpecE8 by clicking the icon under the “Start” menu, opening a “.sp8” file, or 
entering the command spece8.exe from the Windows “Command Prompt.” When you 
start SpecE8 from the command line (as opposed to clicking on the icon), you can specify 
a number of arguments. For example, the command 

 

causes SpecE8 to read input commands from a file “my_script”, and to use 
“my_thermo.tdat” as the thermodynamic database. 

The following options are available from the command line: 
 

-cd Change the working directory to the directory containing 
the input script specified with the –i option. 

-nocd Do not change the working directory. 

<input_script> 
-i <input_script> 

Set a file from which to read input commands. 

-gtd <gtdata_dir> Set directory to search for thermodynamic datasets. 

-cond <cond_data> Set the dataset for calculating electrical conductivity. 

-d <thermo_data> Set the thermodynamic dataset. 

-iso <isotope_data> Set the file of isotope fractionation factors to be used. 

-s <surface_data> Set a dataset of surface sorption reactions. 

 

spece8.exe –i my_script –d my_thermo.tdat 



 

169 
 

Using Gtplot 

Gtplot is an interactive, mouse-driven program that produces various types of diagrams 
showing the results of modeling aqueous speciation with SpecE8 or the data stored in a 
GSS spreadsheet. 

After running SpecE8, start Gtplot by clicking on Plot Results on the Results pane, or 
selecting Run → Gtplot from SpecE8’s menubar. The program will read the calculation 
results from the “.gtp” file SpecE8 produced and render them on any of a number of types 
of geochemical diagrams. You can leave Gtplot active when you run further SpecE8 
calculations. Each time SpecE8 completes a run, it signals Gtplot, which updates its 
display to reflect the new results. 

After preparing a GSS spreadsheet (“.gss” file, see the Using GSS chapter of this guide), 
start Gtplot by selecting the analytes you want to plot and making a choice from the Plot 
menu. The program will load the data values and render them initially on the chosen type 
of diagram. You can select which samples to plot within the Samples pane of the dialog 
for that plot. 

You can also start Gtplot by opening any “.gtp” file, clicking on the Gtplot icon under 
the “Start” menu, or by typing gtplot -i <filename> from the Windows command 
prompt. 

You can take input from a different dataset by choosing File → Open → Data File…. 
from the menubar and opening a “.gtp” or “.gss” file. 

Gtplot opens a window on your computer screen, loads the input data, and renders the 
data as a two-dimensional plot. The window has three parts: a graphics area, a menubar 
with pulldown menus, and a frame showing the name of the input dataset and its activity 
model. 
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Gtplot works using information about the fluid modeled, including its bulk 
composition (i.e., its composition in terms of Na+, Ca++, and so on), pH, TDS, and 
carbonate speciation. Plots labeled “HCO3 + CO3” show the sum of the concentrations in 
solution, in terms of electrical equivalents per kg fluid, of the free HCO3

–  and CO3
– –  species. 

The program calculates this sum from the fluid’s carbonate alkalinity, as determined by 
the SpecE8 program. Hence, the value shown for the variable depends not only on 
carbonate concentration, but the fluid’s pH. In contrast, plots labeled “HCO3” represent 
the bulk carbonate concentration of the fluid, taking no account of the speciation of 
carbonate to the CO3

– – , HCO3
– , and CO2(aq) species. 

When Gtplot starts for the first time in a given directory, it assumes a default 
configuration. Upon finishing, the program saves for its next run a dataset containing the 
current configuration of your plots. You can select options from the File menu to specify 
an alternative configuration (see Loading and saving plot configuration) or reset the 
entire program configuration. 
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8.1 Plot types 
Use the Plot menu to control the type and configuration of the plot produced.  

 

An XY Plot shows a plot of fluid composition, with one variable on the x axis and one or 
more variables on the y axis. Use the following to specify the way the variables are plotted: 

 Variable type to control the type of variables to appear along the plot’s axes. 
 Filter to list, for species or mineral saturation plots, the set of just those that 

contain a given basis species. 
 Auto-scale to set the data range for the axis to span the data to be plotted. 
 Minimum, Maximum, and Tick Factor to set the data range for the axis. 
 Reverse axis to reverse the sense of the axis. 
 Units to select alternative units, if any, for the axis. 
 As to plot values as elemental equivalents, or as protonated or deprotonated 

species equivalents. 
 Type to set the axis to a linear, log, or delta scale. A delta scale shows change in 

a variable’s value from the initial point in the reaction path. 
 First, Previous, Next, Last, and Select all to cycle through the variable choices. 
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A Series Plot is a special type of xy plot that shows GSS data sample by sample, with 
one or more variables opposite the Sample ID. Other notable examples include the Time 
and date plot, in which Gtplot combines the “Date” and “Time” variables from GSS into a 
single variable, and Time of day, in which data from one or more days are plotted on a 
single 24-hour span. 

 

A Ternary Diagram shows the fluid composition on a tri-linear plot. On the Plot pane, 
use the following to specify the way the diagram is plotted: 

 Components to control the three components plotted on the diagram. 
 Units to select alternative units for the axes, which are plotted as fractions. 
 Show TDS as circles to control how circles representing a sample’s dissolved 

solids content should be displayed.  
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A Piper Diagram shows the fluid’s major ion composition. Use: 
 Show TDS as circles to control how circles representing a sample’s dissolved 

solids content should be displayed.  

 

A Durov Diagram represents the fluid’s major ion composition, TDS, and pH. Use: 
 TDS Axis to set the Auto-scale; Minimum, Maximum, and Increment; and Units 

for the TDS axis. 
 pH Axis to set the Auto-scale and Minimum, Maximum, and Increment for the 

pH axis. 
 Show TDS as circles to control how circles representing a sample’s dissolved 

solids content should be displayed.  
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A Schoeller Diagram shows the pattern of component concentration on a logarithmic 

scale. Use: 
 Add, Add All, Remove, Remove All, and Default to choose the components to 

include in the diagram. 
 Up, Down to arrange the order of chosen components along the horizontal axis. 
 Auto-scale, Minimum, and Maximum to set the data range for the vertical axis. 
 Units to select alternative units for the vertical axis. 
 Max samples shown to set the number of samples to display together when the 

“Block” and “Next Block” buttons on the Samples pane are clicked.  
 

 

A Stiff Diagram represents the fluid’s major ion composition as a polygonal shape. Use: 
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 Add, Add All, Remove, Remove All, and Default to choose the components to 
include in the diagram. 

 Up, Down to arrange the order of chosen components, with cations plotting on 
the left and anions on the right. 

 Auto-scale, Maximum, and Increment to set the data range for the diagram. 
 Max samples shown to set the number of samples to display together when the 

“Block” and “Next Block” buttons on the Samples pane are clicked. 
 Labels to control whether the axes and plot labels appear on all samples, only 

the first sample, or no samples. 
 Units to select alternative electrical equivalent units. 
 Auto-size and Size to optimize sizing and spacing of multi-sample plots. 

 

A Radial Plot shows the fluid’s composition in a manner similar to a Stiff diagram, but 
in radial coordinates. Unlike Stiff diagrams, Radial plots can display uncharged 
components. Use: 

 Add, Add All, Remove, Remove All, and Default to choose the components to 
include in the diagram. 

 Up, Down to arrange the order of chosen components. 
 Auto-scale and Maximum to set the data range for the diagram. 
 Max samples shown to set the number of samples to display together when the 

“Block” and “Next Block” buttons on the Samples pane are clicked. 
 Labels to control whether the axes and plot labels appear on all samples, only 

the first sample, or no samples. 
 Units to select alternative units. 
 Auto-size and Size to optimize sizing and spacing of multi-sample plots. 



176   GWB Essentials 
 

 
 

 

 
A Bar Chart represents the fluid’s cation–anion balance graphically. Use: 
 Auto-scale, Minimum, Maximum, and Increment to set the data range for the 

diagram. 
 Max samples shown to set the number of samples to display together when the 

“Block” and “Next Block” buttons on the Samples pane are clicked. 
 Labels to control whether the axes and plot labels appear on all samples, only 

the first sample, or no samples. 
 Units to select alternative units for the axis. 
 Common ions to control whether a default set of major ions or all ions in the 

sample are plotted. 
 Show all labels to control whether all ions are labeled for a given sample, or 

only those that are abundant enough that the label would fit naturally. 
 Auto-size and Size to optimize sizing and spacing of multi-sample plots. 
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A Pie Chart is an alternative method for showing cation–anion balance, with the radial 
direction representing the fluid’s total electrical equivalent content. Use: 

 Auto-scale and Maximum to set the data range for the radial axis. 
 Max samples shown to set the number of samples to display together when the 

“Block” and “Next Block” buttons on the Samples pane are clicked. 
 Labels to control whether the axes and plot labels appear on all samples, only 

the first sample, or no samples. 
 Units to select alternative units for the radial axis. 
 Common ions to control whether a default set of major ions or all ions in the 

sample are plotted. 
 Show all labels to control whether all ions are labeled for a given sample, or 

only those that are abundant enough that the label would fit naturally. 
 Auto-size and Size to optimize sizing and spacing of multi-sample plots. 

8.1.1 Sample selection 
Gtplot can display data for multiple samples (when plotting GSS data) or calculation steps 
(when plotting results of SpecE8 and React models) in all of its plots. For the XY Plot, 
Ternary Diagram, Piper Diagram, Durov Diagram, and Schoeller Diagram, all selected 
samples (or steps) are displayed on a single set of axes or in a single diagram. The other 
plots (Stiff Diagram, Radial Plot, Bar Chart, and Pie Chart) are more suitably displayed 
side-by-side. 

Use the Samples (or Steps) pane of the appropriate Plot Configuration dialog to select 
samples for plotting. For the XY Plot, Ternary Diagram, Piper Diagram, and Durov 
Diagram, use the following to specify the way samples are plotted: 

 Add, Add All, Remove, and Remove All to make samples available or 
unavailable for plotting. 
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 Up, Down to rearrange the order of samples in the Available list. 
 First, Previous, Next, Last, and Select all to cycle through the available 

samples. Only selected samples in the Available list will plot.  

 

The Samples pane for the Schoeller Diagram, Radial Diagram, Stiff Diagram, Bar 
chart, and Pie chart is similar to that described above. Instead of a “Select all” button, 
however, the “Block” button plots a subset of samples together. Use “Next block” to plot 
the next subset of samples. You control the number of samples displayed in the “block” by 
setting “Max samples shown” on the Plot pane, as described above. 
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8.2 Editing plot appearance 
In Gtplot, you can interactively modify many aspects of the diagram. A right-click on an 
aspect or area of the plot displays a menu showing the options available. You may choose 
to reset an axis range or an aspect’s appearance to its default state. Using the Font tab 
within the Format → Appearance… dialog you can change the font for the entire plot. 

To change the font for individual aspects, choose Font from that aspect’s menu. A 
double-click on an aspect brings up a dialog box related to the first item on the pulldown 
menu, which in most cases is the plot configuration dialog. These dialogs can also be 
accessed through the Plot menu. 

The aspect appearance dialogs can be accessed through the Format menu. A double-
click on the background area will bring up the Quick Toggle… dialog, which lets you 
select the graphical elements to be shown.  

 

Double-click 
background to show 
Quick Toggle dialog 

Right-click on 
plot interior 

Right-click on  
plot background 
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A left-click on an aspect causes it to be “selected”. An aspect has been selected when 
its color changes, as in the case of lines, or when it is surrounded by manipulation 
handles, in the case of text or markers. Change the size of text, markers, and, in the case of 
the XY Plot, the plot itself by dragging the sizing cursors. Adjust the placement of the plot 
by clicking within the plot or on either axis and dragging it. The plot title can be moved in 
the same way. 

Right-click text 
to show menu 

options 

Right-click line to 
show menu options 
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When you read new input data and update the plot with the Auto-scale option set, 
Gtplot automatically adjusts the axis ranges to the new data. Otherwise, Gtplot maintains 
the axis ranges you have set for the previous plot. This option lets you quickly adapt the 
axis ranges to new data. 

You can change the range on an axis by clicking and dragging a tick mark, number, or 
grid line. Dragging a tick within an axis shifts all of the values along the axis, effectively 

Left-click title and 
drag to reposition 

Left-click edge and 
drag to resize plot 

Left-click to select; 
drag handle to resize Left-click and 

hover to view 
data values 

Left-click axis and 
drag to move plot 

Left-click axis and 
drag to move plot 

Drag inner tick, number, 
or grid line to shift axis 

 

Drag outer tick, number, or 
grid line to scale axis range 
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changing the minimum and maximum values at the ends of the axis, but keeping the 
spacing the same. Dragging the tick at the end of an axis changes the minimum or 
maximum value. Any tick in a Stiff diagram, radial plot, or pie chart behaves like an end 
tick because the minimum is always zero and cannot be changed. To reset the axis range 
to span the range of the data being plotted, choose Auto-scale or Reset Range from the 
aspect menu, or Format → Reset Axis Range. 

You can set all of the graphical attributes in the aspect appearance dialogs available 
through the Format menu. When you make changes to values or selections in an aspect 
appearance dialog, the changes don’t take effect on the plot immediately. You may set up 
your choices for as many of the aspects as you like, or use the Reset button to reset the 
dialog to its default values. Use the Apply or OK button to apply the changes to the plot. 
Use the Cancel button if you decide that you don’t want the changes applied. 

Selecting Color → More Colors… from any aspect menu or clicking on any color button 
in an aspect appearance dialog allows you to set the color of the relevant aspect.  

 

The Colors dialog presents a hexagonal palette of colors on the Standard tab. To 
create custom colors, move to the Custom tab.  

Right-click → Color 
→ More Colors… 

Left-click button to 
select new color 

Automatic 
multicolor  

Reset dialog options 
to program defaults 
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In either tab, the current color of the aspect is displayed, as is any new selection you 
make. Once you make a selection, click OK to set the color, or Cancel to discard the 
selection and close the dialog. 

8.3 Scatter data 
Gtplot can plot the data in a GSS data sheet (a .gss file) as “scatter data” in its own 
diagram, or overlain on a diagram of the results of a SpecE8 or React calculation. You can 
plot chemical parameters in your data sheet, like pH and TDS, or the measured 
composition (mg/kg Na+, ...) of the samples in the sheet. Or you can plot “calculated 
analytes” such as species activity, gas fugacity, and mineral saturation state. 

Your .gss file might look like 

 

To read the file into Gtplot, select File → Open → Scatter Data…. If some of the data 
points lie outside the plot’s axis range, press Ctrl+Z. Clear scatter data from a diagram on 
the Open → Scatter Data… dialog, with the OFF button. 

The marker representing each sample in the scatter data is set in the .gss file. In GSS, 
right-click on a sample to change the marker used and its color and size. When you modify 
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a .gss file, the changes will sync with open plots automatically, unless you’ve paused 
automatic plot updates (Plot → uncheck Auto Updates), in which case you can click Plot → 
Update Plot(s) when you are ready to sync the changes. 

On xy plots, you can associate the marker for a data point with the analyte (Na+, Ca+ +, 
...), rather than the sample (Well #1, Well #2, ...). On the Format → GSS Data… dialog, you 
can assign the marker, its color, and its size according to the settings in the .gss file for the 
analytes, or for the samples. 

You can label each scatter data point with the sample’s “Sample ID”, as set in the .gss 
file, and display a legend showing the symbols used. In Gtplot, choose Format → GSS 
Data…, and under “Labels” select the checkbox for “Sample” to show sample labels, and 
the “Legend” box to display the legend. If the “Color from sample” box is checked, the 
color for each sample label matches that of the sample’s marker. Use the Format → Quick 
Toggle… dialog to quickly toggle on and off display of the scatter data, data labels, and 
legend. 

If an analysis falls below detection limit, enter in your GSS data sheet the detection 
limit preceded by a “<”, for example “< 0.01”. Gtplot will add a downward arrow to the 
symbol for this entry, signifying it represents the upper limit to concentration. To add 
error bars to the scatter points, enter triplets (0.5|2.0|3.5) in the data cells in your .gss file 
(see Error bars in Using GSS). 

In plots showing the variable “HCO3 + CO3”, you should enter a value in the scatter 
dataset for the chemical parameter “Carbonate alkalinity” so Gtplot can render the 
variable correctly. If you do not enter a value for alkalinity, the program will render the 
variable in terms of the reported HCO3 concentration, if available, in which case the 
diagram produced will not account for the speciation of carbonate. 

Certain unit conversions, such as changing mg/l to mmolar, or mg/kg of solute to mg, 
require knowledge of the fluid’s density and TDS, and the mass of solution in the system. 
Gtplot first looks for entries “Density”, “TDS”, and “Mass solution” in the .gss file. If it does 
not find them, it estimates density and TDS, and assumes a solution mass of 1 kg. 

In order to see TDS represented as circles on Piper, ternary, and Durov diagrams, you 
should enter a value for dissolved solids for each sample or use the Calculate with 
SpecE8… option to determine a value consistent with SpecE8’s speciation. Lacking either 
of these options, Gtplot will use a value estimated from the bulk composition in GSS. 

To coordinate the plotting of scatter data versus time on a reaction path, include 
values for “Time elapsed”, “Time”, and/or “Date”. 

In GWB releases 7.0 and earlier, the program took scatter data from a specially 
formatted text file, rather than a .gss data sheet. Legacy scatter files are still supported 
and described in the Scatter Data chapter in the GWB Reference Manual. 
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8.4 Loading and saving plot configuration 
Upon exiting, Gtplot writes into the user’s working directory a file, “gtplot_conf.gtc”, 
containing the configuration of the current plots. When the program starts again in the 
same directory, it reads the file and assumes the same configurations. 

Choosing File → Reset Configuration or the reset option from the command line 
(see Gtplot command line) returns the configuration for each plot type to its default 
state. This option is useful, for example, when you begin to examine results of a SpecE8 
simulation unrelated to the previous run. 

You can save plot settings to an alternative configuration file by selecting 
File → Save As…. Later, double-click on the “.gtc” file to reopen the plot you saved. You 
may also read the file into Gtplot by selecting File → Open → Configuration…, or simply 
dragging it into an instance of Gtplot. 

Exiting the program by choosing File → Abort (No Save) causes an immediate exit from 
the program; the plot configuration is lost. 

8.5 Exporting the plot 
Gtplot makes it convenient to use the plots you create in articles, reports, presentations, 
and databases. You can copy the current plot to the clipboard and then paste it into a 
variety of applications, in a format meaningful to the application. 

To copy a plot, use Edit → Copy (Ctrl+C). If you paste the plot into MS PowerPoint, it 
will appear as an EMF (an MS Enhanced Metafile) graphic object. Pasting into Adobe 
Illustrator places a native AI graphic. 

If you paste the plot into MS Excel or a text editor such as Notepad or MS Word, the 
numerical values of the data points that make up the lines on the plot will appear in 
spreadsheet format. 

You can control the format in which the plot is copied to the clipboard by selecting Edit 
→ Copy As. You can choose to copy the plot as an AI object, an EMF object, or a bitmap, or 
to copy the data points in the plot as tab-delimited or space-delimited text. 
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Use the tab-delimited option to paste the data into a spreadsheet program like MS 
Excel 

 

For examining the data in a text file created with an editor like Notepad or MS Word, the 
space-delimited option writes a nicely aligned table. 

In MS Word or MS Excel, use Paste Special…  

 

to paste the plot as a picture instead. 

“Paste” in Excel or Word 
inserts numerical values 

“Paste Special…” in 
Excel or Word 

inserts a picture 
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Use File → Save Image… to copy the plot, in your choice of formats (selected under 
Save as type:), from the graphics area to a file in the specified directory. The Enhanced 
Metafile option, for example, saves the plot image in a format that can be read by most art 
and illustration programs (see Graphics Output in the GWB Reference Manual). The other 
file formats available are: PNG, JPEG, TIFF, Bitmap, Adobe Illustrator, PDF, Scalable 
Vector Graphics, Compressed SVG, Encapsulated PostScript, Color PostScript, and B/W 
PostScript. 

When saving a PNG, JPEG, TIFF, or bitmap file, you may specify the quality of the saved 
image by choosing its resolution: High, Medium, Low, or Custom. Use Custom… to set the 
pixel width and height of the image, and to choose whether to preserve the aspect ratio of 
the plot. 

Use the Spreadsheet File (Tab delimited) or Text File (Space delimited) option to 
save the numerical coordinates of the data points on the plot into a table. The 
spreadsheet table may be read directly into many popular spreadsheet programs. 

Certain graphics types support font embedding. PDF files should always display and 
print properly, regardless of fonts installed on the system. PostScript files should also, if 
you have used the option to embed fonts. 

If you may want to edit the PostScript file, however, you should deselect the option to 
embed fonts, because programs such as Adobe Illustrator may restrict your ability to edit 
a document using embedded fonts. To edit these files, be sure that all of the required 
fonts are installed on your computer (see Font for data markers in the GWB Reference 
Manual). 

When importing AI graphics to Adobe Illustrator, the program may prompt you to 
update the legacy text before you can edit the file. In this case, choose “Update”. You need 
to release the clipping mask before you attempt to edit individual elements of the plot. 
Use the “Ungroup” and “Group” functions when repositioning or modifying elements. 
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8.6 Gtplot command line 
To run Gtplot, click on the Gtplot icon on the GWB dashboard, or open a “.gtp” or “.gtc” 
file. The program can also be initiated from the Windows command prompt by typing 
gtplot.exe. Starting the program in this way allows you to make use of the command 
line arguments described below. 

Gtplot accepts a number of arguments from the command line. For example, the 
command 

 

causes Gtplot to read as input the file “SpecE8_plot1.gtp”, and to use the plot 
configuration stored in “Config1.gtc”. 

The following options are available from the command line: 
 

<input_data> 
-i <input_data> 

Set the “SpecE8_plot.gtp” dataset, produced by a 
SpecE8 run, which contains the data to be plotted. The 
program, by default, looks for file SpecE8_plot.gtp in 
the user’s working directory. 

-c <config_file> Set the configuration file to be read at startup. By 
default, the program reads the file gtplot_conf.gtc if it 
exists in the working directory. 

-scat <scatter file> Take scatter data from the named dataset. By default, 
Gtplot does not plot scatter data. 

-graph <plot_type> Set the type of plot displayed at startup. By default, it 
is set from the configuration file. Choose from: xyplot, 
ternary, piper, durov, schoeller, stiff, radial, bar, pie, 
series, and time. 

-reset Set the default configuration at startup; do not read 
gtplot_conf.gtc. 

  

gtplot –i SpecE8_plot1.gtp –c Config1.gtc  
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Table 8.1 Keyboard shortcuts in Gtplot  

Ctrl+Shift+A Copy plot to the clipboard as an Adobe Illustrator file 

Ctrl+Shift+B Copy plot to the clipboard as a bitmap 

Ctrl+C Copy plot to the clipboard 

Ctrl+Shift+E Copy plot to the clipboard as an Enhanced Metafile 

Ctrl+F Refresh display 

Ctrl+Shift+G Get scatter data 

Ctrl+L Load a configuration file 

Ctrl+M Save the graphic image to a file 

Ctrl+O Open an input (“React_plot.gtp”) file 

Ctrl+P Print the plot 

Ctrl+Q Quit Gtplot, save configuration 

Ctrl+Shift+Q Abort Gtplot, do not save configuration 

Ctrl+R Reset the plot configuration 

Ctrl+S Save the current configuration to a file 

Ctrl+Shift+S Copy plot to the clipboard as a Spreadsheet (tab delimited) 

Ctrl+Shift+T Copy plot to the clipboard as Text (space delimited) 

Ctrl+U Update the plot from the current input file 

Ctrl+X Reset data range on the x axis 

Ctrl+Y Reset data range on the y axis 

Ctrl+Z Reset data ranges on the x and y axes 

F1 Open GWB Essentials Guide 
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Using TEdit 

TEdit is a graphical editor that lets you create and modify the thermodynamic and surface 
reaction datasets used by the GWB programs. You can alternatively use a simple text 
editor such as Notepad to modify the datasets. If you prefer to use a text editor, details of 
the datasets’ formats are given in the Thermo Datasets and Surface Datasets chapters in 
the GWB Reference Manual. 

With TEdit you can view and modify the entries in a dataset, as well as add or delete 
them. Specifically, you can alter 

 Header lines, data tables, and dataset information 
 Elements and species in the dataset, and their properties 
 Reactions among the species, and their log K temperature expansions 
 Binary solid solutions of end-member minerals, and their properties 
 Virial coefficients for species pairs or triplets, and their temperature expansions 

You can also: 
 Copy entries from one dataset to another 
 Filter entries by composition and search on text strings 
 Swap to recast reactions and recalculate log Ks 
 Reduce arbitrarily written reactions to the set of basis and redox species  
 Exchange the positions of basis, redox, and aqueous species 
 Adjust the coupling of redox reactions 
 Troubleshoot common errors 
 Import datasets from the PhreeqC and EQ3/6 programs, and export to EQ3/6 

9.1 Getting started with TEdit 
9.1.1 Opening datasets 
To open TEdit, click its icon on the Apps pane of the GWB Dashboard. Then, go to File → 
Open… and browse to open any “.tdat” or “.sdat” file (for thermo and surface datasets, 
respectively), or a “.dat” file, for very old GWB reaction datasets. You can alternatively 
drag a file from your Desktop or File Explorer into TEdit. Either way, you can open several 
datasets in a single TEdit window. You can also double-click any “.tdat” or “.sdat” file to 
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open it in TEdit. To open a dataset currently loaded in any GWB program, go to File → 
View and select the desired file.  

9.1.2 Navigating datasets 
A thermo dataset in TEdit might look like this 

 

On the left side of the window is a tree structure with sections labeled “Header”, “Tables”, 
“Elements”, “Basis species”, “Redox couples”, “Aqueous species”, “Free electron”, 
“Minerals”, “Solid solutions”, “Gases”, “Oxides”, and, in some cases, “Virial coefficients”. 
For detailed descriptions of each section, see the Thermo Datasets chapter in the GWB 
Reference Manual.  

Click “Header” on the tree to view the dataset format, activity model, default fugacity 
model, log K temperature expansion format, and bibliographic information. The pane also 
shows the number of elements, basis species, and so on in the dataset. Click on one of the 
buttons to navigate to the corresponding section of the dataset. 

The next section, “Tables”, contains tables showing how various coefficients used by 
the programs vary with temperature (see Temperature expansions under Thermo 
Datasets in the GWB Reference Manual). The principal temperatures of the dataset are 
set in the top of this section 
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Additional temperatures can be appended or inserted as needed using , and values 
can be removed using . Note that deleting a principal temperature will also delete 
values of header variables and log K s set at that temperature, when supplied as T-tables. 
You can optionally superimpose lower and upper temperature bounds on the database, if 
for some reason the limiting values differ from the first and last principal temperatures, by 
setting values for “Tmin” and “Tmax”. 

The temperature expansions may be given as either a T-table, with values 
corresponding to the principal temperatures 

 

or as a set of six polynomial coefficients a-f spanning the range of those temperatures 

   

Each subsequent section contains a list of entries. Use the  button to view its 
contents or expand the entire tree by going to View → Expand All. 

Under “Elements” is a list of chemical elements from which species in the dataset can 
be created. Each element’s entry contains a name, symbol, and molecular weight 
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The “Basis species” are listed in the next section. Each entry contains a name, charge, 
ion size parameter in angstroms (plus a second b term for activity coefficients in the 
phreeqc, minteq, wateq4f, and davies activity models), mole weight, and optionally, a 
chemical formula, in the labeled text boxes, as well as its elemental composition 

   

The “Redox couples” are similar to Basis species, except that redox couples are 
constructed from species in the dataset, rather than from elements. The species form a 
balanced reaction for which equilibrium constants are supplied as T-tables of log K values 

   

or as a polynomial temperature expansion, with an optional temperature range of validity 
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In the absence of settings for “Tmin (K)” and “Tmax (K)”, the stability is assumed to span 
the range of the principal temperatures. 

Entries in the following sections, for “Aqueous species”, “Free electron”, “Minerals”, 
“Gases”, and “Oxide” components, are added in a similar manner to redox couples, with a 
few differences. The name, charge, ion size parameter, and mole weight of the free 
electron cannot be modified, although you can modify its reaction and log K temperature 
expansion, as you would for any other species. Minerals have fields for entering the 
mineral’s molar volume, type, and formula. Gases have fields for the factors needed to 
calculate fugacity coefficients. Minerals, gases, and oxide components do not have fields 
for charge or ion size parameter. The oxide components do not have thermodynamic 
stabilities, so there is no place to enter log K values. 

The “Solid solutions” are composed of end-member minerals defined in the preceding 
section. Entries include the activity coefficient model and parameters for evaluating that 
model, as needed, along with the end members and composition range of the solution.  

Datasets that utilize virial equations (the H-M-W and SIT activity models) include 
coefficients describing the energetic interactions among basis, redox, and aqueous 
species. In “thermo_hmw.tdat”, for example, the entry for Ca+ +  lists interaction terms 
with anions, cations, neutral species, and triplets of species. TEdit displays the interaction 
terms for various pair-wise and triplet combinations of species under “Virial coefficients”, 
as well as a summary view under the entry for all involved species. 

 

For example, Ca+ + and Cl– basis species both display a summary of the Ca+ +  – Cl– 

cation–anion pair interaction terms, as well as all the triplets involving both species. If, 
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while on the entry for Ca++, you double-click the row with the Ca+ +  – Cl– pair, the Ca+ +  – 
Cl– pair’s entry on the tree will open, where you can view more information and edit the 
entry. After doing so, the summaries in the Ca+ + and Cl– basis entries will update. 

In the entry for a pair or triplet, each coefficient is listed at 25°C (the value in the first 
row). You can enter up to five additional coefficients (b-f in the new polynomial, or c1-c5 for 
the legacy expansion) to account for temperature effects, as well as a range of validity. For 
more information, see Virial Coefficients under the Thermo Datasets chapter in the GWB 
Reference Manual.  

 

Surface datasets are organized much like thermo datasets and can be navigated in 
TEdit using a similar tree structure. For detailed information about their contents, see the 
Surface Datasets chapter in the GWB Reference Manual.  

9.1.3 Creating new datasets 
To create a new thermo dataset, go to File → New → Thermo Data…. In the dialog that 

opens, select an activity model, temperature expansions for header variables and log Ks, 
and, for virial datasets, the virial coefficient format, then click OK. TEdit can format GWB 
datasets that invoke variations of the Debye-Hückel equations or the virial techniques (see 
Thermodynamic datasets under Configuring the programs, and Activity coefficients 
under Using SpecE8). Note the format labeled “b-dot” was previously labeled “debye-
huckel”. Additionally, the format labeled “Pitzer” is outdated and not recognized by TEdit; 
support for the Pitzer equations has been superseded by the “h-m-w” format. TEdit can 
format the temperature expansions for header variables and log Ks as a table of values at 
the principal temperatures or as coefficients in a polynomial. Virial coefficients can be 
formatted using the same polynomial, or a similar legacy format. For details of the 
temperature expansions, see the Thermo Datasets chapter in the GWB Reference 
Manual. 

In the “Header” section, choose a default fugacity model; options include Tsonopoulos, 
Peng-Robinson, and Spycher-Reed.  
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TEdit creates new datasets with a commonly used eight-temperature T-table spanning 
0–300°C, but you can extend or limit the range, or add intermediate values, in the “Tables” 
section. Supply the temperature expansions for the required header variables. 

Finally, add desired elements, species, reactions, and so on, as described later in 
Adding and deleting entries. 

In the same manner, to create a surface dataset, go to File → New → Sorbing 
Surfaces…. In the dialog that opens, choose one of the surface models (see Sorption 
onto mineral surfaces under Configuring the Programs) and a convention, if required, 
then click OK. If you create a two-layer, three-layer, CD-MUSIC, or Langmuir dataset, you 
need to pick a convention for polydentate reactions (see Polydentate sorption). Similarly, 
an ion exchange dataset requires an activity convention.  

You should set a unique “type” in the Header section for each surface to be considered 
at a given time. The “type” is a label that identifies the dataset within the GWB modeling 
programs when more than one surface dataset has been loaded.  

Finally, identify a thermo dataset from which the species are drawn to make up surface 
reactions. The header lines in surface dataset “FeOH_minteq.sdat”, for example, link it to 
the thermo dataset “thermo_minteq.tdat”. TEdit, then, will look to “thermo_minteq.tdat” 
to find aqueous species to be used in balancing chemical reactions within 
“FeOH_minteq.sdat”. 

  

9.1.4 Saving and dataset formats 
Click File → Save to save your dataset. Use File → Save As… to save the file with a new 
name or location. TEdit will save thermo datasets as “.tdat” files and surface datasets as 
“.sdat” files. If you try to save a dataset with errors, TEdit will open the Troubleshoot… 
dialog to list the errors it finds (see Troubleshooting in this section). 

In the current release, thermo datasets are distributed in the “jul22” format, and 
surface datasets in the “sep22” format. TEdit can read and write datasets in these 
formats, which are preferred for current installations of the software, or in various legacy 
formats (see Legacy formats in the Thermo Datasets and Surface Datasets chapters of 
the GWB Reference Manual) for use with earlier releases of the software package. To 
enable new features in a dataset created for an earlier release, update it by choosing the 
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most recent format in the Save As… dialog. To save a dataset for use with an earlier 
release, choose a legacy format and TEdit will downgrade the dataset as necessary.  

 

The earlier “jan19” format was the first to allow polynomial temperature expansions 
for log Ks and header variables in thermo datasets. Although not recommended, you can 
convert such a dataset to use the older T-table expansion. On the Header section, change 
the “log K format” pulldown from “polynomial” to “table” before saving. Note, the 
transformation can only be performed once. TEdit does not convert T-tables to 
polynomial expansions.  

The polynomial temperature expansions for virial coefficients can be set out in the 
legacy format, the new format used for header variables and log Ks, or a combination of 
the two formats. To set the dataset to use only one format, select the appropriate entry on 
the “virial coefficient format” pulldown on the “Header” section before saving. 
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9.2 Working with datasets 
9.2.1 Summaries, filtering, and searching 
When you click on any section (except “Header” and “Tables”) on TEdit’s tree structure, 
the program displays a pane summarizing its contents. For example, the “Minerals” 
section displays an alphabetical list of the dataset’s minerals in a condensed view 

   

Double-click on an entry to go to its editing pane. Use the buttons or right-click menu to 
add or remove entries, control filters, and so on, as described later in this chapter. 

Change the pulldown from “List” to “Details” to see properties of the entries, such as 
mole weights and formulae 
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or to “Reactions” to see their reactions and log K values at 25°C 

   

or “Redox reactions” to list only oxidation-reduction reactions. You can similarly identify 
“Non-redox reactions” within the “Redox couples” section. 

In any case, you can use the “element” pulldown or “match” box to limit the entries 
shown in the list. In the screenshot above, “alb” was typed into the “match” box to 
compare the stability of albite with its polymorphs.   

To filter the species shown in the tree, go to one of the section headers, choose one or 
more options in the list, then click on the Apply button under “Filter”. By filtering on the 
element “C”, the tree shows only species containing that element 

   

To show all the entries again, choose Clear.  
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Similarly, if you go to the “Basis species” section and filter on a species like “HCO3-”, 
you can set the tree structure to show only species containing inorganic carbon 

  

If you check “Follow redox couples”, on the other hand, the filter would include redox 
couples linked to “HCO3-”, such as “CH3COO-” and “CH4(aq)”. 

You can additionally apply and clear filters through the right-click menus of entries in 
the tree structure or in the Find…, Mole Weight…, and Troubleshoot… dialogs, 
described later. 

To search the dataset, go to Edit → Find… (Ctrl+F) and type in a character string. The 
dialog lists each occurrence of the string, along with its context. You can limit the search 
to specific sections (e.g. “Minerals”) or search fields (“Name”, “Formula”, “Reaction”, “End 
members”, “Comment”, or “Mineral type”). Double-click on an entry to go to its editing 
pane, or right-click for more options. 

9.2.2 Adding and deleting entries 
To add an element, species, solid solution, or virial interaction term to a dataset, right-
click on the appropriate section heading in the tree and choose Add. The new entry will 
appear on the tree at the end of the selected section, as well as within the dataset when 
you save it. Or, add from an entry on the tree to place the new entry directly after it. 
Complete the data template that appears, as described in the next section.  
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To remove one or more entries from a dataset, select on the tree the entries to be 
deleted, then right-click on one and choose Delete. Alternatively, click on the Delete 
button within the section’s summary pane. A popup dialog will appear listing the chosen 
entries, along with any dependent entries. You may choose OK to delete all the entries, or 
Cancel to retain them.  

Alternatively, choose Extract to preserve your selected entries while deleting 
everything else from that section. If you extract the elements H, O, Na, and Cl, for example, 
all other elements (and their dependent species and reactions) will be deleted. 

Anything you delete is temporarily stored in the “Deleted entries” section of the tree. 
From there you can restore entries to the dataset or clear them out permanently. All 
deleted entries will be discarded when you close the dataset. 

9.2.3 Completing entries in thermo datasets 
When adding an element to a database, you enter a name, symbol, and mole weight. For 
basis species, fill in the species’ name, charge, ion size parameter, b term, if applicable, 
mole weight, and chemical formula, if desired. Last, click the  button to build up the 
species’ elemental composition. 

For the remaining species, set a balanced chemical reaction, in terms of any species in 
the dataset. Under “Species in reaction”, click   to select the species. By default, the 
dialog that opens lists the basis and redox species, as well as the electron, but you can 
change the pulldown to show all aqueous species, minerals, or gases. Double-click on the 
entries to include in the reaction. You can also traverse the dialog with the keyboard; type 
one or more characters to find species beginning with that sequence, then hit the Enter 
key to add the species, and Esc to close the dialog. Next, supply a reaction coefficient in 
the space to the right of each species’ name. Species with a negative reaction coefficient 
appear on the reaction’s left-hand side; those with a positive coefficient are on the right. 
As you add coefficients, TEdit automatically writes the reaction out and checks for charge 
and mass balance.  

In the fields below the reaction, set the log K temperature expansion for the reaction as 
written. For T-table datasets, specify values at the principal temperatures; use “500” to 
indicate “no data”. If the log K is known at a different temperature, you can add to the T-
table on the “Tables” pane. For polynomial datasets, set coefficients a-f, and optionally 
set a temperature range of validity. For more information, see Temperature expansions 
in the Thermo Datasets chapter of the GWB Reference Manual. 

As an example, suppose we want to add the aqueous species FeCl3, as in the reaction 
below, to “thermo.tdat” 

 
 FeCl3 ⇄ FeCl2

+ + Cl–,  log K = 1.0006 at 25°C (9.1) 
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To do so, right-click on “Aqueous species” and choose Add. In the blank pane that 
opens, type “FeCl3(aq)” as the species name. Set the mole weight to “162.206” and the ion 
size to “4”. Click , and in the dialog that opens, change the pulldown to “All Aqueous 
species” 

 

then select “FeCl2+” and hit the Enter key, then repeat for “Cl-”, then close the dialog.  
The entry pane will look like 

 

Set a reaction coefficient of “1” for each and enter the log K value above 

 

For solid solutions, set the name, the activity model, the end-member minerals, and 
their “tags” (short labels). In binary solutions, you can specify a range for the second end 
member’s mole fraction. For solutions of more than two end members (this and certain 
other features are currently supported only for conversion to EQ3/6 format, see Exporting 
EQ3/6 datasets), set the maximum mole fraction for each end member. For site-mixing 
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solutions, set the site number b. For Guggenheim solutions, set the dimensionless 
parameters 𝑎𝑎0, 𝑎𝑎1, and 𝑎𝑎2. Alternatively, specify second-order temperature expansions for 
J mol−1 Guggenheim coefficients 𝐴𝐴0, 𝐴𝐴1, and 𝐴𝐴2 by clicking the  button and setting 
values for 𝑝𝑝1−𝑝𝑝9. The sign of the 𝑎𝑎1 (or 𝑝𝑝4−𝑝𝑝6) coefficient reflects the order in which end 
members appear, as well as the GWB’s convention for setting out the Guggenheim 
equations. Note, if you reorder the end members, the range and Guggenheim a1 (or 𝑝𝑝4−𝑝𝑝6) 
coefficients will be adjusted. For the various other models, supply coefficients 𝑝𝑝1−𝑝𝑝6 as 
necessary. For more information, see Solid solutions in the Configuring the Programs 
chapter of this guide, as well as Solid solutions in the Thermo Datasets chapter of the 
GWB Reference Manual. 

For virial datasets, also enter coefficients reflecting pair-wise and triplet interactions 
among the species, as necessary. For those invoking the SIT method, you can specify 
interaction terms for cation–anion pairs and ion-neutral species pairs, as well as their 
temperature ranges of validity. For those invoking the “Pitzer equations”, you can 
additionally specify interaction terms for cation–cation or anion–anion pairs and species 
triplets. You can see a summary of these terms (their values at 25°C) on the data pane for 
any basis, redox, or aqueous species, but you specify them under the subsections of the 
“Virial coefficients” heading. Click Add in the appropriate section and select species to 
form a pair or triplet from the pulldown list. Fill in values for some or all of the coefficients 
(see Virial Coefficients in the Thermo Datasets chapter of the GWB Reference Manual). 

If you rename an entry, the change will propagate to reactions, solid solutions, and 
virial coefficient pairs or triplets within the dataset, but not to datasets of surface 
reactions that draw species from the thermo dataset, nor to ancillary datasets (for 
electrical conductivity, isotope fractionation, and water quality standards).  

9.2.4 Completing entries in surface datasets 

9.2.4.1 Two-layer datasets 
Two-layer datasets are arranged much like thermo datasets. You start by adding one or 
more “Basis surface species”, for which you specify a name, charge, and mole weight. 
Each basis entry defines a sorbing site. Click  to define the site’s elemental 
composition, drawing from the list of elements in the thermo dataset, which is named in 
the dataset “Header”. 

Second, compile a list of surface complexes under “Surface species”. For each 
complex, set a reaction written in terms of a surface site, combined with basis, redox, and 
aqueous species drawn from the thermo dataset. Set an equilibrium constant as a log K 
for each reaction at 25°C (the a= value), as well as the temperature expansion. 

Finally, specify one or more minerals to carry the surface. Right-click on “Sorbing 
minerals” and select Add. Each sorbing mineral may host an arbitrary number of sorbing 
sites, which are the basis species in the dataset. Next to “Name”, click “New Sorbing 
Mineral” → “Minerals…” and choose a mineral from the thermo dataset. Enter the 
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mineral’s specific surface area, in m2 g–1. Under sorption sites, click  to pull in the 
surface’s basis species; for each, set site density in mol (mol mineral)–1 or sites nm–2

. 

You can specify a value for constant capacitance or constant potential, but not both, in 
the Header section. You may prefer to leave these unset and allow the user to set values as 
desired from within Rxn, SpecE8, React, Phase2, X1t, or X2t (see Two-layer surface 
complexation model under Configuring the Programs). 

9.2.4.2 Triple-layer and CD-MUSIC datasets 
The process for completing entries for triple-layer and CD-MUSIC datasets differs from 
that for the two-layer case above principally in the need to distribute surface charge 
across two or three planes. For triple-layer datasets, you enter separate values for zo and 
zβ. Datasets for the CD-MUSIC method, in contrast, require you to enter values for ∆zo, ∆z1, 
and ∆z2. Note that in current usage, the value for ∆z2 is commonly taken to be zero. 

Supply the required capacitance values C1 and C2 in the “Header” section. 

9.2.4.3 Langmuir datasets 
Langmuir datasets contain a single basis entry, which represents the sorbing site. The 
Langmuir site is uncharged and carries no mass, so you need enter only a name. You can 
load any number of Langmuir datasets simultaneously into the GWB modeling programs, 
as long as each has a unique “type” set in the “Header”, and a unique name for the basis 
entry. 

To define the surface complexes, right-click on “Surface species” and choose Add. 
Then, click in the “Species” box and choose a species to complex with the surface site. 
TEdit will construct a balanced reaction including the Langmuir site and will fill in all the 
entries, except for the log K temperature expansion, which you must supply. 

9.2.4.4 Kd and Freundlich datasets 

Kd and Freundlich surface datasets include surface complexes but not basis species. To 
define a surface complex, right-click on “Surface species” and choose Add. Click in the box 
to the right of “Species:” and choose from the basis, redox, and aqueous species in the 
thermo dataset. TEdit automatically completes the entry, except for the Kd, or the values 
of Kf  and nf , which you must also enter. 

9.2.4.5 Ion exchange 

An ion exchange dataset contains a single basis species. To define it, right-click on “Basis 
species” and choose Add. In the box to the right of “Sorbed species”, choose from the 
charged basis species in the thermo dataset. TEdit will automatically complete the entry. 

To define the surface species that exchange with the basis species, right-click on 
“Surface species” and select Add. Click in the box to the right of “Species” and choose 
from the list of species of like charge in the thermo dataset. TEdit will construct a 
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balanced reaction following the activity convention you have chosen, and fill in all entries 
except for the selectivity coefficient, which you must enter as a linear value. 

9.2.5 Adding references 
From the “Header” section, you can add comments to appear at either the beginning of a 
dataset or at the end. Text you type into the “Preamble” appears just below the Header 
lines at the top of the dataset, whereas the contents of the “Bibliography” appear at the 
bottom. If you would like to add comments or a reference to an individual species in the 
dataset, open the species’ data pane and enter text in the “Reference” block. TEdit saves 
this text after the species’ block of thermodynamic data.  

9.2.6 Reordering entries 
Entries within each section of the dataset can appear in arbitrary order. You can move an 
entry by dragging it (as described below) within the same section. You can also right-click 
on any section heading (except “Header” and “Tables”) and click Sort to alphabetize the 
entries within that section. Use Edit → Sort to alphabetize the entire dataset. Keep in mind 
H2O must be the first basis species, so it will not be affected by dragging or sorting.  

9.2.7 Transferring entries to other datasets 
You can transfer data tables, elements, species, solid solutions, or virial coefficients from 
one dataset to another. Copy entries to the clipboard by selecting them on the tree 
structure, then right-click one and select Copy, or alternatively use Edit → Copy. Edit → 
Cut performs a similar function but removes the entries in question from the source 
dataset. Select multiple entries by holding the Ctrl or Shift key while making your 
selections. 

To paste, go to the target dataset and select Edit → Paste. TEdit includes the type of 
entry (e.g. Element) in the information it copies to the clipboard, so the entry will be 
pasted in the appropriate section. If you select an entry within the correct section of the 
target dataset before pasting, TEdit will paste the copied entry immediately after it; 
otherwise, the entry will be added at the end of the list. 

You can also drag entries (see Drag and drop feature under Introduction) from one 
dataset to another. Select one or more entries on the tree structure of the source dataset, 
then hold the left mouse button down and drag to the tree structure or current entry of 
the target dataset, and release. As with copying and pasting, if your cursor is within the 
correct section, TEdit will place the entry where you drop it. If not, TEdit will place it at the 
end of the appropriate section. If the source and target datasets are open in the same 
TEdit window, switch to the target dataset by hovering over its tab while dragging. 

You should use your judgment when transferring thermodynamic data from one 
dataset to another. TEdit will issue a warning when activity models differ and will not 
allow you to transfer data in some cases. For example, you cannot transfer virial 
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coefficients from an SIT to an H-M-W dataset. Similarly, the program will not allow you to 
transfer surface species unless both datasets use the same surface model: you cannot 
transfer a reaction for sorbed Pb+ + from a two-layer to a three-layer model dataset. 

TEdit will issue a warning if you try to transfer an entry that would be undefined in the 
target dataset. For example, you would need to add the element Cadmium to 
“thermo.tdat” before you can paste in the basis species Cd+ +. Similarly, a dataset utilizing 
the virial equations must include the Ca+ + and Cl– species before you can paste the Ca+ +  – 
Cl– cation–anion pair interaction term. 

When transferring log Ks within a T-table to another T-table dataset, TEdit will check 
the principal temperatures of both datasets and transfer only values corresponding to 
exact temperature matches. When transferring log Ks set as polynomial expansions to a 
dataset utilizing T-tables, TEdit will evaluate the polynomial at the principal temperatures 
of the target dataset and store the data as T-tables. It will not transfer data in T-tables to a 
polynomial dataset. 

9.2.8 Rebalancing reactions 
In the current release, reactions can be written in terms of any species in the dataset (see 
Species and reactions in the Thermo Datasets chapter of the GWB Reference Manual). 
Deprotonation reactions, for example, can be written equally validly in terms of the proton 
H+ or the hydroxyl ion OH–, even though the latter is a secondary aqueous species. As a 
second example, the stability of aragonite might be defined relative to its polymorph 
calcite, rather than the basis species “HCO3-”.  

Reactions in the dataset can be rebalanced by various methods, described below. In 
each case, TEdit recalculates equilibrium constants automatically.  

9.2.8.1 Basis swapping 

To rebalance a reaction in TEdit, there’s no need to add or delete species manually. 
Instead, swap the basis to automatically rebalance reactions (see Setting and 
constraining the basis under Configuring the Programs). To do so, click the “swap” 
button  next to the species you’d like to remove, select the type of species to swap in, 
then choose the species from the pulldown list.  

To recast the reaction for the redox species Fe+++ in “thermo.tdat”  
 

 Fe+++ + .5H2O ⇄ Fe++ + H+ + .25O2(aq),  log K = -8.4878  (9.2) 
 

as a half-cell reaction  
 

 Fe+++ + e- ⇄ Fe++,  log K = 13.01265  (9.3) 
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click the “swap” button  next to “O2(aq)” and select Electron… → e− 

    

TEdit will display how it rebalances the initial reaction and recalculates log K values 

 

and will temporarily disable editing. Click  to accept the changes, or  to revert to 
the original reaction. 

9.2.8.2 Automatically reducing reactions 
You can automatically reduce reactions written in arbitrary form to the set of redox and 
basis species, or the set of basis species alone. For example, the dissociation reaction for 
FeCl3(aq) might be written in stepwise fashion in terms of the aqueous species FeCl2+  

 
 FeCl3 ⇄ FeCl2

+ + Cl–,  log K = 1.0006 at 25°C (9.4) 
 

To automatically reduce that reaction to the set of redox and basis species, click the 
 pulldown button under “Species in reaction”, then select Reduce to redox and 

basis. Note how TEdit automatically swaps out the aqueous species FeCl2+ for the redox 
species Fe+ + + and recalculates the equilibrium constant to reflect the cumulative reaction 
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 FeCl3 ⇄ 3Cl– + Fe+++,  log K = -1.1295 at 25°C (9.5) 
 

Click  to accept the changes, or  to revert to the original reaction. 
To reduce the reaction to the set of basis species, click reduce once again, then select 

Reduce to basis. This time, TEdit swaps out the redox species Fe+ + + for the basis species 
Fe+ + and again recalculates the equilibrium constant 

 
 FeCl3 + .5H2O ⇄ 3Cl– + Fe+++ H+ + .25O2(aq),  log K = -9.6173  (9.6) 
   

Note, the latter option limits the ability of the GWB programs to interactively decouple 
redox reactions. 

9.2.8.3 Exchanging species positions 

You can use TEdit to exchange the positions of basis, redox, and aqueous species within a 
thermo dataset. For example, you might replace the basis species “HCO3-” with the 
aqueous species “CO3--”. In this case, “CO3--” will appear in the basis, and “HCO3-” 
among the aqueous species; all of the reactions in the dataset that had been written in 
terms of “HCO3-” will be rebalanced in terms of “CO3--”. 

To exchange the positions of two species, right-click on the entry for one of them on 
the tree structure and click Exchange with…, select the type of species to exchange with, 
then choose from the pulldown list the second of the species. TEdit exchanges the 
species’ position in the dataset, as you can see in the tree structure, and rewrites the 
reaction between them. In some cases, dependent reactions throughout the dataset will 
be rebalanced, as well. 

To perform the “CO3--” for “HCO3-” swap described above, for example, right-click on 
“HCO3-”, then select Exchange with… → Aqueous… → CO3--, as shown below: 
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A dialog will open showing the species whose reactions will be rebalanced. Hover over any 
species to see how it will be rebalanced. Click OK to proceed, or Cancel to back out. The 
rebalanced reaction for “CH3COO-” is shown below 

   

You could accomplish the same thing in reverse, by selecting “CO3--” from the tree and 
exchanging it with “HCO3-”. If you were to exchange the same two species a second time, 
the dataset would revert to its original state.  

The exchange feature provides a quick method for changing the redox pivot of a 
thermo dataset (see Basis species under the Thermo Datasets chapter in the GWB 
Reference Manual). In “thermo.tdat”, when you exchange the basis species O2(aq) for the 
redox species H2(aq), the latter becomes the redox pivot. All reactions written in terms of 
dioxygen, including the redox coupling reactions and that for the free electron, will be 
rebalanced in terms of dihydrogen.  

H2O and H+ are required as entries in the basis and have therefore been excluded from 
the exchange feature. O2(aq) and H2(aq) can only be exchanged with each other. 

9.2.9 Adjusting redox coupling 
Besides changing the redox pivot of a dataset or otherwise rebalancing redox reactions 
(see previous section), you can couple or decouple redox reactions, and rebalance 
dependent reactions accordingly. You can also create or eliminate redox couples. For 
more information on how redox reactions are interactively enabled or disabled in the 
apps, see Redox couples in the Configuring the Programs chapter of this guide, and 
Redox disequilibrium under Using SpecE8. 

9.2.9.1 Coupling and decoupling reactions 
You can decouple an aqueous species to move it to the “Redox couples” section of the 
dataset. As an example, given a dataset with the following aqueous species 

 
 ClO4

–  ⇄ Cl–  + 2O2(aq),  log K = 15.7091 at 25°C (9.7) 
 ZnClO4

+ ⇄ Zn++ + Cl– + 2O2(aq),  log K = 14.4323 at 25°C (9.8) 
   
you might wish to decouple the perchlorate ion to allow for redox disequilibrium, and to 
rebalance the Zn-perchlorate complex in terms of the new couple as below 
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 ZnClO4
+ ⇄ Zn++ + ClO4

– ,  log K = -1.2768 at 25°C (9.9) 
 

To do so, right-click on “ClO4-” and choose Decouple. A dialog will pop up asking you 
to confirm the decoupling. If any redox reactions within the “Aqueous species”, 
“Minerals”, and “Gases” sections of the dataset can be rebalanced with the new couple so 
as to eliminate the change in oxidation state, TEdit will open a second dialog offering to 
rebalance those entries. Mouse over an entry to see how it will be rebalanced, then click 
OK to continue, or Cancel to skip the rebalancing. 

The opposite action, coupling a redox species, moves it to the “Aqueous species” 
section of the dataset. A redox species that invariably remains coupled in your 
calculations might benefit from permanent coupling in this way, as would any non-redox 
reaction that happens to be in that section of the dataset. To couple a reaction, right-click 
on the redox species and select Couple. Click Yes in the first dialog that pops up to 
confirm the move. A second dialog will offer to rebalance dependent reactions in terms of 
the remaining basis and redox species. Mouse over an entry to see the rebalanced 
reaction, and Click OK to continue, or Cancel to skip the rebalancing.  

Coupling a redox species in the dataset limits the flexibility of calculations using that 
data, whereas decoupling an aqueous species increases flexibility. 

9.2.9.2 Making and breaking redox couples 
You can turn a basis species into a redox couple by writing a reaction linking it to another 
basis or redox species. By making a redox couple, you can account for redox equilibrium 
or disequilibrium in your calculations as needed. In “thermo_minteq.tdat”, for example, 
you might want to couple the basis species “Acetate-” and “CO3--”, with the former 
serving as the redox species. To do so, right-click on “Acetate-” and select Make Couple, 
which moves the entry to the “Redox couples” section. Complete the entry by providing 
reaction and log K expansion (see Completing entries in thermo datasets in this section).  

Conversely, you can eliminate a redox coupling reaction that is unlikely to reach 
equilibrium under any circumstances. To do so, right-click on a redox species and select 
Break Couple. The redox species will be moved to the “Basis species” section and the 
reaction and log K expansion replaced with the species’ elemental composition. 

Whereas making a couple increases the flexibility of the calculations you can consider, 
breaking a couple limits you. It is generally preferable to decouple a reaction in the apps 
than to break a redox couple in the thermo dataset. 

9.2.9.3 Identifying redox and non-redox reactions 
Redox reactions should ideally be limited to the “Redox couples” section of the dataset. As 
such, reactions for “Aqueous species”, “Minerals”, and “Gases” should be written without 
species O2(aq), O2(g), H2(aq), H2(g), and e−, and without pairs of species of different 
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valences, such as Mn++ and MnO4
--, to the extent practical. In other words, reactions are 

ideally balanced in terms of species of the same oxidation state as the species in question.  
You can identify “Redox reactions” or “Non-redox reactions” by selecting the 

appropriate pulldown option from the summary panes of the aforementioned sections 
(see Summaries, filtering, and searching).  

In some cases, you may be able to rebalance redox reactions by swapping in an existing 
basis or redox species that eliminates the change in oxidation state. Or, lacking an 
appropriate species, you might copy one from another dataset, or add one from the 
literature, and then rebalance with it (see previous sections).  

In other cases, you might find that an aqueous species might be utilized to the same 
effect. That species, then, could serve well as a redox couple and might benefit from 
decoupling, as described above. 

9.2.10 Troubleshooting 
TEdit will open the Troubleshoot… dialog if it finds any issues when you open or save a 
dataset, and when you go to File → Troubleshoot…. The dialog lists warnings for specific 
entries that can typically be fixed within TEdit, such as charge or mass imbalances. 
Double-click on an entry to go to its editing pane. A second box describes omissions, 
broader dataset problems, and errors that may need to be fixed in a text editor, and 
additionally indicates when a new dataset format is available. Click Refresh to recheck for 
issues after making updates, or after changing focus to another open dataset. Finally, you 
can click View Errors to open an error log generated when TEdit first reads a dataset. The 
log indicates the line numbers on which errors are found and is intended as a guide for 
fixing errors in a text editor. The log does not refresh, so reopen an updated dataset to 
continue troubleshooting. 

Each entry’s editing pane includes its own troubleshooting status. A  indicates that 
no problems have been found, while a  symbol flags one or more problems. A message 
provides more details. If the reaction is not mass-balanced, you can adjust the mole 
weight, assuming the reaction is correct, by clicking . 

To check the entire dataset for mass imbalances, go to Edit → Mole Weight…. The 
dialog lists all imbalances exceeding a threshold (0.9 g/mol by default) in descending 
order. Double-click any row to go to that species’ entry pane. Or, select one or more rows 
in the dialog and click  to recalculate using the mole weight expected from the 
elemental composition. Clicking  recalculates the mole weights of all species 
exceeding the specified threshold. 

If TEdit cannot open a corrupted dataset, you will need to fix it in a text editor. The 
error messages from TEdit or the other apps should help you locate the approximate line 
or entry that needs to be fixed. Formatting details are given in the Thermo Datasets and 
Surface Datasets chapters in the GWB Reference Manual. 
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9.3 Importing and exporting databases for other 
modeling programs 
9.3.1 Importing PhreeqC datasets 
TEdit can convert datasets for the PhreeqC program (see Further Reading) to GWB-format 
thermo and surface datasets. To do so, go to File → Import → PhreeqC… and browse to 
open a PhreeqC “.dat” file, or drag a dataset into TEdit.  

Depending on the keywords encountered in the PhreeqC dataset, TEdit will produce a 
GWB dataset using either the phreeqc, b-dot, sit, or h-m-w activity model (see 
Thermodynamic datasets under Configuring the programs, and Activity coefficients 
under Using SpecE8), corresponding to PhreeqC’s default, LLNL, SIT, and PITZER models, 
respectively. 

The GWB programs enforce an operable temperature range, as constrained by the 
lower and upper principal temperatures of the dataset in use (see Thermo Datasets in the 
GWB Reference Manual). Unless laid out in the PhreeqC dataset with the 
LLNL_AQUEOUS_MODEL_PARAMETERS data block, you must specify an appropriate range 
for the imported dataset so that TEdit can construct a principal temperature grid. 
Pressure defaults to one atmosphere up to 100°C, and above that follows a correlation for 
the vapor pressure of water.  

For the phreeqc, sit, and h-m-w models, polynomial coefficients for Debye-Hückel 
parameters A and B are taken from the THEREDA project’s dataset (see Further Reading). 
If the –APHI keyword is used in a PITZER dataset, however, Debye-Hückel 𝐴𝐴 polynomial 
coefficients are calculated according to the relation 𝐴𝐴𝜙𝜙 = 2.303𝐴𝐴 3⁄ . For the b-dot 
model, 𝐴𝐴, 𝐵𝐵, and �̇�𝐵  are read from the LLNL_AQUEOUS_MODEL_PARAMETERS data block, 
and the remaining “CO2” and “H2O” header variables are taken or fit from the tables 
spanning 0–300°C in “thermo.tdat” but are not used by default, as described below. 

For the b-dot model, TEdit sets “ion size” of each neutral aqueous species for which 
the -CO2_llnl_gamma keyword is encountered to -0.6; the flag triggers the Drummond 
(1981) activity coefficient equation used in PhreeqC. You can change the setting to -0.5 to 
apply Helgeson’s method, using the “CO2” tables described above. H2O’s “ion size” 
parameter is similarly used as a flag; the default setting of -1 for imported b-dot datasets 
triggers the Garrels and Christ (1965) water activity calculation used in PhreeqC. To revert 
to the standard Helgeson (1969) model using the “H2O” tables, change “ion size” of H2O 
to 0. More options are described in Species and reactions under Thermo Datasets in the 
GWB Reference Manual. 

TEdit contains an internal list of elements and their mole weights, along with a list of 
common organic compounds, which it compares to the elements and master species laid 
out in the PhreeqC dataset. Whereas a PhreeqC dataset might contain a fictitious element 
“Ac” corresponding to its master species Acetate-, TEdit will create a basis species 
Acetate- composed of true elements: 2 C, 3 H, and 2 O, rather than 1 Ac. When TEdit 
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encounters an element it does not recognize, it will prompt you to substitute a known 
element, use the fictitious element, or define the elemental composition of a compound. 

The temperature dependence of log Ks in GWB datasets is described with a polynomial 
containing up to six coefficients a-f, (see Temperature expansions under Thermo 
Datasets in the GWB Reference Manual). GWB polynomial coefficients were converted 
from coefficients A1-A6 in PhreeqC's analytic expression as follows: 

   
𝑎𝑎 = 𝑙𝑙𝑙𝑙𝑙𝑙 𝐾𝐾𝑇𝑇𝑟𝑟 = 𝐴𝐴1 + 𝐴𝐴2𝑇𝑇𝑟𝑟 + 𝐴𝐴3

𝑇𝑇𝑟𝑟
+ 𝐴𝐴4𝑙𝑙𝑙𝑙𝑙𝑙 𝑇𝑇𝑟𝑟 + 𝐴𝐴5

𝑇𝑇𝑟𝑟
2 + 𝐴𝐴6𝑇𝑇𝑟𝑟

2  

𝑏𝑏 = 𝐴𝐴2  
𝑐𝑐 = 𝐴𝐴6  
𝑑𝑑 = 𝐴𝐴3  
𝑒𝑒 = 𝐴𝐴5  
𝑓𝑓 = 𝐴𝐴4

ln(10)  

 
where Tr is 298.15 K. Lacking an analytical expression, the log K at 25°C in PhreeqC was 
used, with the standard enthalpy change when available, as follows: 

   
𝑎𝑎 = 𝑙𝑙𝑙𝑙𝑙𝑙𝐾𝐾𝑇𝑇𝑟𝑟   
𝑏𝑏 = 0  
𝑐𝑐 = 0  
𝑑𝑑 = −𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑_ℎ

𝑅𝑅 ln(10)   
𝑒𝑒 = 0  
𝑓𝑓 = 0  
  

where delta_h is the standard enthalpy of reaction in kJ/mol and R is the gas constant in 
kJ/(mol K).  

PhreeqC’s polynomial for virial coefficients in the PITZER and SIT models differs from 
its log K polynomial. GWB polynomial coefficients for virial coefficients were converted 
from coefficients A0-A5 in PhreeqC's PITZER/SIT expansion as follows: 

   
𝑎𝑎 = 𝐴𝐴0  
𝑏𝑏 = 𝐴𝐴3  
𝑐𝑐 = 𝐴𝐴4  
𝑑𝑑 = 𝐴𝐴1  
𝑒𝑒 = 𝐴𝐴5  
𝑓𝑓 = 𝐴𝐴2  
 
GWB datasets invariably contain destruction reactions, so formation reactions within 

PhreeqC SOLUTION_SPECIES, SURFACE_SPECIES, and EXCHANGE_SPECIES blocks are 
reversed and log K coefficients are negated. 
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TEdit converts charged species' names to the GWB convention. For example, Ca++ 
replaces Ca+2. The suffix (aq) is appended to species O2 and H2. Additionally, suffixes (aq) 
and (s) are added where species names are duplicated. TEdit expects gases to end in “(g)” 
or “,g” to differentiate them from minerals in the PHASES block; “,g” is changed to “(g)”. 

A PhreeqC dataset might contain surface complexation and ion exchange reactions in 
addition to those involving aqueous species, minerals, and gases. Upon reading a PhreeqC 
dataset, TEdit splits the surface reactions into separate “.sdat” files, one for each ion-
exchange, two-layer, or CD-MUSIC model surface it finds (see Sorption onto mineral 
surfaces under Configuring the Programs).  

In converting ion-exchange data, TEdit combines PhreeqC’s half-reactions into full 
reactions following the Gaines-Thomas convention, and transforms log K values to linear 
selectivity coefficients. No temperature dependence is carried over. 

In PhreeqC, information about sorbing minerals, such as the specific surface area and 
concentration of sites, is specified in the input file, rather than the dataset, as in GWB. To 
complete surface complexation datasets imported from PheeqC, you should identify the 
sorbing mineral(s), and for each, specify its specific surface area along with the site 
density of each sorbing site. If the original data was for a non-electrostatic model, you 
should set surface potential to 0 from the Header pane. Or, for a constant capacitance 
model, set surface capacitance. For a CD-MUSIC surface, set capacitance values C1 and C2.  

9.3.2 Importing EQ3/6 datasets 
TEdit can convert thermo datasets for Version 8 of the EQ3/6 package (see Further 
Reading) to GWB-format. To do so, go to File → Import → EQ3/6… and browse to open an 
EQ3/6 “data0.xxx” file, or drag the dataset into TEdit.  

Depending on the EQ3/6 dataset, TEdit will produce a GWB dataset using either the 
b-dot or h-m-w activity model (see Activity coefficients under Using SpecE8). EQ3/6 
“Temperature limits (degC)” values are written explicitly as GWB “TminC” and “TmaxC” 
fields only if the values differ from the first and last principal temperatures. For the b-dot 
model, the “CO2” and “H2O” tables are filled in as described in the previous section. For 
the h-m-w model, Debye-Hückel 𝐴𝐴 is calculated from 𝐴𝐴𝜙𝜙 as described previously. 

For the b-dot model, TEdit sets “ion size” of each neutral aqueous species for which 
the “neutral ion type” equals “−1” to “−0.6”; the flag triggers the Drummond (1981) 
activity coefficient equation used in EQ3/6. H2O’s “ion size” parameter is set to “−2” to 
trigger the water activity calculation currently used in EQ3/6. For more information, see 
Species and reactions under Thermo Datasets in the GWB Reference Manual. For any 
species missing an ion size parameter, the value is set to “4” in the GWB dataset, following 
EQ3/6. 

EQ3/6 datasets require a “strict basis species” O2(g), whereas GWB datasets require 
aqueous basis species. Thus, if the EQ3/6 dataset contains O2(aq) in its “auxiliary basis 
species” section, TEdit makes it the basis species and moves O2(g) to the gases section. 
The reaction for O2(aq) is reversed and the log Ks are negated. The remaining auxiliary 
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basis species are mapped to GWB redox couples, whether or not they actually involve 
oxidation and reduction (see Identifying redox and non-redox reactions). The EQ3/6 "Eh 
reaction" is rebalanced and used for the "free electron" reaction in the GWB dataset, and 
its log Ks are divided by “−4”. Various spellings for aqueous O2 (e.g. O2, O2,aq, O2 (aq), and 
so on) are changed to O2(aq).  

Reactions and log Ks are factored as necessary so that the left-hand side species has a 
coefficient of "−1". If the EQ3/6 dataset is flagged with "INTERPRET 500 AS NO DATA= NO", 
any 500 log K value is considered an actual value and will be changed to 500.0002 within 
the GWB dataset. The change allows the GWB apps to distinguish actual data from “no 
data” 500 values but has an insignificant effect on stability. Any mineral mole volumes set 
to 500 are assumed to mean “no data” and are changed to “0”. Any pure liquids (e.g. Hg(l)) 
are appended to the list of minerals. 

All EQ3/6 solid solutions will be imported to GWB format, although not all are currently 
supported in the GWB modeling programs. For the Guggenheim, regular (binary), cubic 
Maclaurin, third-order Maclaurin, and ternary regular solution models, model coefficients 
𝑝𝑝1𝜓𝜓−𝑝𝑝9𝜓𝜓 are converted from cal mol–1 to J mol–1. Additionally, coefficients 𝑝𝑝4𝜓𝜓−𝑝𝑝6𝜓𝜓 in the 
Guggenheim model are negated because of the different conventions followed by EQ3/6 
and the GWB programs. Solid solution “tags” default to the first six characters from each 
end member, but you might wish to update them, and in some cases, you might be 
required to (e.g. an end member Albite’s tag cannot match its name). For more 
information, see Solid solutions under the Configuring the Programs chapter of this 
guide, as well as Solid solutions under Thermo Datasets in the GWB Reference Manual. 

In virial datasets that follow the Version 7 format (i.e., with keywords “single-salt 
parameters” and “mixture term parameters”), only the virial coefficient values at 25°C are 
carried over. The coefficients a1−a5 in the high-temperature Pitzer treatment introduced in 
Version 8 are converted to the new GWB format virial polynomial (see Virial coefficients 
under Thermo Datasets in the GWB Reference Manual) according to: 

   
𝑎𝑎 = 𝑎𝑎1  
𝑏𝑏 = 𝑎𝑎4  
𝑐𝑐 = 𝑎𝑎5  
𝑑𝑑 = 𝑎𝑎2  
𝑒𝑒 = 0  
𝑓𝑓 = 𝑎𝑎3  
 
Any text encountered before either the “Miscellaneous parameters” block or any type 

of “Configuration data” is stored as a comment in the GWB dataset between the initial 
lines and the list of principal temperatures. Text from the “References” block is added as 
comments to the end of the GWB dataset. The comments are visible in TEdit in the 
“Preamble” and “Bibliography” sections, respectively, of the “Header” pane.  
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9.3.3 Exporting EQ3/6 datasets 
TEdit can convert GWB thermo datasets using the b-dot or h-m-w models to EQ3/6 
format. To do so, go to File → Export → EQ3/6…, then choose a folder and supply a name 
for the EQ3/6 “data0.xxx” file.  

TEdit will supply tables of header variables appropriate for either model. The 
“Temperature limits (degC)” are taken from the global “TminC” and “TmaxC” if specified. 
Otherwise, they are taken from the first and last principal temperatures. For h-m-w 
datasets, Debye-Hückel 𝐴𝐴𝜙𝜙 is calculated according to 𝐴𝐴𝜙𝜙 = 2.303𝐴𝐴 3⁄ . The log Ks for the 
“Eh reaction” are converted from the “free electron” reaction, if present, as long as TEdit 
can rewrite the reaction in terms of H+ and O2(g). If not, log Ks from thermo.tdat are used.  

For b-dot datasets, uncharged species with an “ion size parameter” of “−.5” or “−.6” 
(flagging the Helgeson and Drummond "CO2" equations, respectively) are set with a value 
of "−1" for "neutral ion type". For all other species, the flag is set to “0” and “azer0” set to 
the “ion size” value in the GWB dataset. 

EQ3/6 requires a one-to-one mapping of elements and strict basis species, beginning 
with O:H2O, continuing, for example, with H:H+, C:HCO3

-, and so on, and concluding with an 
unpaired basis species O2(g). No strict basis species can contain more than one element 
beyond H and O. If a GWB dataset contains multiple basis species that would map to the 
same element (e.g. HCO3

- and CH3COO- both contain C) you will be alerted (see description 
of the EQ3/6 Export Errors… dialog at the end of this section). To make the dataset 
workable in EQ3/6, you might make one of them a redox couple so that it is exported as an 
auxiliary basis species (see Making and breaking redox couples). For disequilibrium 
calculations in EQ3/6, it is acceptable to supply all 500 (“no data”) log K values. If you 
leave multiple basis species paired with the same element, the first such species 
encountered will be the strict basis species, and subsequent species will become auxiliary 
basis species, but with an incomplete reaction and no log K data in the data0 file. 

Various spellings for aqueous and gaseous O2 (e.g. O2, O2,aq, O2 (g), and so on) are 
changed to O2(aq) and O2(g), respectively. Since EQ3/6 requires reactions to be written in 
terms of strict and auxiliary basis species, any arbitrarily written reactions are rebalanced 
in terms of their GWB analogues, the basis and redox species (see Automatically reducing 
reactions). Although redox reactions in EQ3/6 are often balanced in terms of O2(g), the 
GWB programs will rebalance such reactions in terms of O2(aq). Reaction log Ks are limited 
to four digits after the decimal place. 

The various expansion coefficients 𝑝𝑝1−𝑝𝑝9 for solid solution models are converted from 
J mol–1 to cal mol–1. In the Guggenheim model, coefficients 𝑝𝑝4−𝑝𝑝6 are negated. GWB ideal 
and site_mixing models map to EQ3/6 ideal site-mixing models. The 𝑝𝑝7 site parameter is 
taken to be unity, in the former case, or equal to b, in the latter. The various 𝑝𝑝𝑛𝑛 parameters 
are limited to three digits after the decimal place in EQ3/6 datasets, so the conversion can 
be somewhat lossy. 
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GWB virial coefficient temperature expansions (a−f for the new polynomial and 𝛽𝛽25−c5 
for the legacy polynomial; see Virial coefficients under Thermo Datasets in the GWB 
Reference Manual) are mapped to EQ3/6 coefficients a1−a5 according to: 

   
𝑎𝑎1 = 𝑎𝑎 or 𝛽𝛽25  
𝑎𝑎2 = 𝑑𝑑 or 𝑐𝑐2  
𝑎𝑎3 = 𝑓𝑓 or 𝑐𝑐3  
𝑎𝑎4 = 𝑏𝑏 or 𝑐𝑐1  
𝑎𝑎5 = 𝑐𝑐 or 𝑐𝑐4  
 

If any virial coefficient contains an 𝑒𝑒 (or 𝑐𝑐5) value, TEdit will warn you that EQ3/6 will not 
be able to reproduce the temperature expansion (see next paragraph). TEdit writes out an 
extra 𝑎𝑎6 coefficient in this case, although it will cause an error in EQ3/6. 

TEdit will launch the EQ3/6 Export Errors… dialog, a version of the Troubleshoot… 
dialog described previously (see Troubleshooting), if it detects certain issues. The dialog 
lists species-specific as well as global issues, allowing you to make changes before 
proceeding with the export. For example, species names in EQ3/6 datasets are limited to 
24 characters, so the dialog will flag species with longer names. If you continue without 
renaming, TEdit will simply truncate the problematic species names in the data0.xxx 
dataset, without regard for any duplicates it creates in the process. As a second example, 
TEdit expects datasets treating redox reactions to use O2(aq) as the redox pivot. If H2(aq) is 
the pivot, TEdit will alert you. In this case, you can use the “Exchange” feature to make 
O2(aq) the pivot before re-exporting (see Exchanging species positions).  

9.4 TEdit command line 
You can start TEdit by clicking the icon on the GWB dashboard, opening a “.tdat” or 
“.sdat” file, or entering the command tedit.exe from the Windows “Command 
Prompt.”  

When you start TEdit from the command line, you can specify an optional argument. 
For example, the command 

 

causes TEdit to silently open the “my_thermo.tdat” thermodynamic database and save it 
again with the same name. 

The following options are available from the command line: 
 
-touch <dataset> Silently read in the specified thermo or surface dataset 

and save it with the same name. 

tedit –touch my_thermo.tdat 
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-mw <dataset> Open the specified dataset and recalculate the mole 
weight of all species directly from their elemental 
composition, then save it with the same name. 

 
 

Table 9.1 Keyboard shortcuts in TEdit  

Ctrl+A Select all 

Ctrl+C Copy 

Ctrl+F Find  

Ctrl+N Open the dialog to add species to a reaction 

Ctrl+O Open a thermo or surface dataset 

Ctrl+Q Quit TEdit 

Ctrl+S Save 

Ctrl+Shift+S Save As 

Ctrl+V Paste 

Ctrl+X Cut 

Delete Delete 

F1 Open GWB Essentials Guide 
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Appendix: Further Reading 

The following literature references, from the many hundreds that have been published, 
provide a starting point for further reading on various aspects of geochemical modeling 
and its applications. Additional references are available in the GWB Reaction Modeling 
Guide and the GWB Reactive Transport Modeling Guide. 

A.1 Natural waters 
Anderson, G.M. and D.A. Crerar, 1993, Thermodynamics in Geochemistry, The Equilibrium 

Model. Oxford University Press. 
Appelo, C.A.J. and D. Postma, 1993, Geochemistry, Groundwater, and Pollution. Balkema, 

Rotterdam, 536 p. 
Ball, J.W. and D.K. Nordstrom, 1991, User’s manual for WATEQ4F, with revised 

thermodynamic data base and test cases for calculating speciation of major, trace, and 
redox elements in natural waters. U.S. Geological Survey Open File Report 91–183. 

Bethke, C.M., R.A. Sanford, M.F. Kirk, Q. Jin and T.M. Flynn, 2011, The thermodynamic 
ladder in geomicrobiology. American Journal of Science 311, 183–210. 

Chapelle, F.H., 2001, Ground-Water Microbiology and Geochemistry, 2nd ed. Wiley, New 
York. 

Drever, J.I., 1988, The Geochemistry of Natural Waters, 2nd ed. Prentice-Hall, Englewood 
Cliffs, NJ. 

Drummond, S.E., 1981, Boiling and Mixing of Hydrothermal Fluids: Chemical Effects on 
Mineral Precipitation: Ph.D. dissertation, The Pennsylvania State University. 

Garrels, R.M. and M.E. Thompson, 1962, A chemical model for sea water at 25°C and one 
atmosphere total pressure. American Journal of Science 260, 57–66. 

Hem, J.D., 1985, Study and interpretation of the chemical characteristics of natural water. 
U.S. Geological Survey Water-Supply Paper 2254, 263 p. 

Kharaka, Y.K. and I. Barnes, 1973, SOLMNEQ: Solution-mineral equilibrium computations. 
U.S. Geological Survey Computer Contributions Publication 215-899. 

Lasaga, A.C., 1998, Kinetic Theory in the Earth Sciences. Princeton, Princeton, New Jersey. 
Lindberg, R.D. and D.D. Runnells, 1984, Ground water redox reactions: An analysis of 

equilibrium state applied to Eh measurements and geochemical modeling. Science 
225, 925–927. 

Nordstrom, D.K. and J.L. Munoz, 1994, Geochemical Thermodynamics, 2nd ed. Blackwell, 
Boston. 
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Truesdell, A.H. and B.F. Jones, 1974, WATEQ, a computer program for calculating chemical 
equilibria of natural waters. U.S. Geological Survey Journal of Research 2, 233–248. 

Westall, J.C., J.L. Zachary and F.M.M. Morel, 1976, MINEQL, a computer program for the 
calculation of chemical equilibrium composition of aqueous systems. Hydrodynamics 
Laboratory Technical Note 18, Massachusetts Institute of Technology, 91 p. 

A.2 Speciation modeling 
Allison, J.D., D.S. Brown and K.J. Novo-Gradac, 1991, MINTEQA2/PRODEFA2, a 

geochemical assessment model for environmental systems, version 3.0 user’s manual. 
US Environmental Protection Agency Report EPA/600/3–91/021. 

Bethke, C.M., 2022, Geochemical and Biogeochemical Reaction Modeling, 3rd ed. 
Cambridge University Press, New York, 520 p. 

Kharaka, Y.K., W.D. Gunter, P.K. Aggarwal, E.H. Perkins and J.D. DeBraal, 1988, 
SOLMINEQ.88, a computer program for geochemical modeling of water–rock 
interactions. US Geological Survey Water Resources Investigation Report 88–4227. 

Marion, G.M., M.V. Mironenko, and M.W. Roberts, 2009, FREZCHEM: A geochemical model 
for cold aqueous solutions. Computers & Geosciences 36, 10–15. 

Parkhurst, D.L. and C.A.J. Apello, 2013, Description of input and examples for PHREEQC 
version 3—A computer program for speciation, batch-reaction, one-dimensional 
transport and inverse geochemical calculations. US Geological Survey Techniques and 
Methods 6-A43. 

Plummer, L.N., D.L. Parkhurst, G.W. Fleming and S.A. Dunkle, 1988, PHRQPITZ—A 
computer program incorporating Pitzer’s equations for calculation of geochemical 
reactions in brines. U.S. Geological Survey Water-Resources Investigations Report 88–
4153, 310 p. 

Reed, M.H., 1982, Calculation of multicomponent chemical equilibria and reaction 
processes in systems involving minerals, gases and an aqueous phase. Geochimica et 
Cosmochimica Acta 46, 513–528. 
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